Bug 716527 - After upgrade, KDE network manager broken
After upgrade, KDE network manager broken
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-24 14:56 EDT by Joe Christy
Modified: 2011-09-08 05:10 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-08 05:10:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joe Christy 2011-06-24 14:56:40 EDT
Description of problem:
After upgrading to latest version this AM, I can no longer establish wireless connection w/ KDE

Version-Release number of selected component (if applicable):
0.8.9997-4.git20110620.fc15

How reproducible:
Always

Steps to Reproduce:
1. Log in to KDE session
2. try to attach to a wireless network from system tray
3.
  
Actual results:
Plasma Workspace crashes. Wireless network appears to be connected in gkrellm wireless krell and ifconfig shows an IP address for wlan0, but ping says network unreachable. Some web sites reachable with google chrome, others not. Can't load debug symbols for Plasma Workspace, because PackageKit can't reach network.

Expected results:
wireless network connection made.

Additional info:
Comment 1 Joe Christy 2011-06-24 15:10:28 EDT
Curiously, I can attache using Gnome (which I find painful to use).

As expected, owngrading to NetworkManager{,-glib,-gnome}-0.8.999-2.git20110509.fc15.x86_64 fixes the problem (thankfully).
Comment 2 Matthias 2011-06-25 00:10:01 EDT
I had the same problem. Installing "kde-plasma-networkmanagement-1:0.9-0.53.20110616git.nm09.fc15.x86_64" and "kde-plasma-networkmanagement-libs-1:0.9-0.53.20110616git.nm09.fc15.x86_64" from the updates-testing repo solved the issue for me.
Comment 3 Erwin Burema 2011-06-25 13:16:30 EDT
Same problem here, although it seems like NetworkManager sets up enough to be able to run dhclient (and thus was able to downgrade).

Sollution here was to downgrade:

Removed:
  NetworkManager.x86_64 1:0.8.9997-4.git20110620.fc15                                                  
  NetworkManager-glib.x86_64 1:0.8.9997-4.git20110620.fc15                                             

Installed:
  NetworkManager.x86_64 1:0.8.999-2.git20110509.fc15                                                   
  NetworkManager-glib.x86_64 1:0.8.999-2.git20110509.fc15
Comment 4 Thomas R. 2011-06-25 17:00:13 EDT
I can confirm this, downgrading did help.

In /var/log/messages it seemed like NetworkManager crashed with a stack trace, but I didn't copy the trace unfortunately.
Comment 5 Patrick Dubois 2011-06-26 10:32:44 EDT
I can confirm that upgrading the the packages (kde-plasma-networkmanagement*) to updates-testing fixes the issue.

Thank you Matthias.

(In reply to comment #2)
> I had the same problem. Installing
> "kde-plasma-networkmanagement-1:0.9-0.53.20110616git.nm09.fc15.x86_64" and
> "kde-plasma-networkmanagement-libs-1:0.9-0.53.20110616git.nm09.fc15.x86_64"
> from the updates-testing repo solved the issue for me.
Comment 6 Jirka Klimes 2011-06-27 12:30:13 EDT
The bug is mismatch between NetworkManager and kde-plasma-networkmanagement.
Older kde-plasma-networkmanagement used to use API for NM 0.8 and thus NetworkManager's compat interface. There's a bug for the compat interface in NetworkManager-0.8.9997-4.git20110620.fc15. The bug is handled in bug 716591.

Upgrading kde-plasma-networkmanagement to nm09 branch also solves the issue, because the proper NM 0.9 interface API (not the compat one) is used. See also bug 716446.
Comment 7 Patrick Dubois 2011-09-06 09:16:06 EDT
Seems to me this bug is fixed ?
Comment 8 Jirka Klimes 2011-09-08 05:10:36 EDT
(In reply to comment #7)
> Seems to me this bug is fixed ?

I think so.

Note You need to log in before you can comment on or make changes to this bug.