Bug 708230 - gnome-shell extensions don't work after gnome-shell-3.0.2-1.fc15 is installed
gnome-shell extensions don't work after gnome-shell-3.0.2-1.fc15 is installed
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-shell-extensions (Show other bugs)
15
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Rahul Sundaram
Fedora Extras Quality Assurance
:
: 700776 708556 708687 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-26 20:03 EDT by Andre Robatino
Modified: 2011-05-29 19:21 EDT (History)
12 users (show)

See Also:
Fixed In Version: gnome-shell-extensions-3.0.2-1.g63dd27cgit.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-28 19:55:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andre Robatino 2011-05-26 20:03:54 EDT
Description of problem:
When gnome-shell-3.0.2-1.fc15 from updates-testing is installed, the "Power off..." User menu item disappears. It comes back after downgrading to the stable gnome-shell-3.0.1-4.fc15.

Version-Release number of selected component (if applicable):
gnome-shell-extensions-alternative-status-menu-3.0.1-3.03660fgit.fc15.noarch
gnome-shell-3.0.2-1.fc15

How reproducible:
always
Comment 1 Andre Robatino 2011-05-27 12:52:09 EDT
The new gnome-shell is about to go to stable so this is fairly urgent.

https://admin.fedoraproject.org/updates/gnome-shell-3.0.2-1.fc15,mutter-3.0.2.1-1.fc15
Comment 2 Andre Robatino 2011-05-27 16:28:14 EDT
gnome-shell-3.0.2-1.fc15 just went to stable.
Comment 3 Rahul Sundaram 2011-05-27 16:38:20 EDT
I have dropped a note upstream.  I am going to busy with other things till Monday.  If anyone wants to take a look and attach a patch here or do a build, feel free to.
Comment 4 Andre Robatino 2011-05-27 21:45:00 EDT
Bug 708556 says that all extensions are disabled, not just this one, and I've confirmed it with gnome-shell-extensions-dock and gnome-shell-extensions-alternate-tab. However, that bug is against gnome-shell.
Comment 5 Scott Dodson 2011-05-27 21:49:55 EDT
*** Bug 708556 has been marked as a duplicate of this bug. ***
Comment 6 Scott Dodson 2011-05-27 21:51:42 EDT
*** Bug 700776 has been marked as a duplicate of this bug. ***
Comment 7 Scott Dodson 2011-05-27 22:27:32 EDT
This seems to be fixed by installing upstream gnome-shell-extensions 3.0.2
Comment 8 Hien 2011-05-28 00:31:07 EDT
(In reply to comment #2)
> gnome-shell-3.0.2-1.fc15 just went to stable.

It not fix for me, cause many extension could not load!
Comment 9 Timur Kristóf 2011-05-28 07:00:51 EDT
This is not surprising at all. The metadata.js file of the extensions says that they are compatible with Gnome-shell "3.0.1" - that means that Gnome-shell 3.0.2 will not try to load them at all.

The upstream 3.0.2 gnome-shell-extensions version will probably fix this, so I'll look into trying to get it downstream.
Comment 10 Fedora Update System 2011-05-28 09:17:50 EDT
gnome-shell-extensions-3.0.2-1.g63dd27cgit.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/gnome-shell-extensions-3.0.2-1.g63dd27cgit.fc15
Comment 11 Scott Dodson 2011-05-28 10:04:42 EDT
Timur,

Thanks, I've verified that all of the extensions work for me with the packages you build. The API is noted as being unstable so I guess this is something we'll have to deal with until the API is stable.
Comment 12 Timur Kristóf 2011-05-28 11:07:22 EDT
Scott,

This has nothing to do with the API's stability. Every gnome-shell extension has a metadata.json file in which it must specify which version of gnome-shell it is compatible with. Other versions of the Shell will not attempt to load it.

The fix here was to change it to a version number which the newer Shell will understand.
In the meantime, I have also updated to a newer git snapshot, which should contain some bugfixes to the extensions.
Comment 13 Christopher Aillon 2011-05-28 15:24:00 EDT
Where is 'g63dd27c' coming from?  I can't find that revision in either master or the gnome-3-0 branch.  Why not just use the official gnome-shell-extensions-3.0.2 tarball that's been released for a week now?

https://mail.gnome.org/archives/gnome-announce-list/2011-May/msg00027.html
Comment 14 Matt Chan 2011-05-28 16:29:25 EDT
Yep, I've run into this as well.

I worked around it by changing my extension metadata from 

shell-version:["3.0.x"] 

to 

shell-version:["3.0"]

It's somewhat hack-ish, but might make it easier for us later on instead of upgrading every single extension every time gnome-shell gets updated. 

A better decision about this issue can be made if we take into account the gnome-shell ABI stability between minor version changes though. Extensions not loading without manual testing/updating may be more favourable than gnome-shell crashing altogether.

Matt
Comment 15 Mohamed El Morabity 2011-05-28 16:53:25 EDT
*** Bug 708687 has been marked as a duplicate of this bug. ***
Comment 16 Fedora Update System 2011-05-28 19:55:12 EDT
gnome-shell-extensions-3.0.2-1.g63dd27cgit.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Timur Kristóf 2011-05-29 10:25:44 EDT
(In reply to comment #13)
> Where is 'g63dd27c' coming from?

git clone git://git.gnome.org/gnome-shell-extensions
Then 'git describe HEAD' told me that this was the identifier of HEAD.
So then I did:
git archive --format=tar --prefix=gnome-shell-extensions/ HEAD | xz > gnome-shell-extensions-g63dd27c.tar.xz

> Why not just use the official
> gnome-shell-extensions-3.0.2 tarball that's been released for a week now?

Because gnome-shell-extensions 3.0.1 (as packaged in Fedora) already contained some extensions that are not present in the official 3.0.2 version.

Note You need to log in before you can comment on or make changes to this bug.