Bug 711489 - atl1c: transmit queue timeout (Acer Aspire One 522)
atl1c: transmit queue timeout (Acer Aspire One 522)
Status: CLOSED DUPLICATE of bug 717211
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
RejectedBlocker AcceptedNTH
:
: 699963 709560 746125 (view as bug list)
Depends On:
Blocks: F16-accepted/F16FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2011-06-07 11:46 EDT by Andreas Tunek
Modified: 2011-10-24 15:18 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-24 15:18:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (58.61 KB, text/plain)
2011-06-07 11:46 EDT, Andreas Tunek
no flags Details
dmesg after a took out and reinserted ethernet cable (80.48 KB, text/plain)
2011-06-07 12:09 EDT, Andreas Tunek
no flags Details
dmesg4 (61.75 KB, text/plain)
2011-06-08 12:54 EDT, Andreas Tunek
no flags Details
lspci output (12.36 KB, text/plain)
2011-06-13 15:21 EDT, Andreas Tunek
no flags Details
lspci -vvnn (24.40 KB, text/plain)
2011-06-13 16:54 EDT, Helber Maciel Guerra
no flags Details

  None (edit)
Description Andreas Tunek 2011-06-07 11:46:11 EDT
Created attachment 503519 [details]
dmesg

Description of problem:
Linux seems to crash when I am using wifi on a ASUS 522. I does not happen instantly but after using wifi for a while the whole computer locks up.

Version-Release number of selected component (if applicable):
kernel.i686                  2.6.38.7-30.fc15       @updates       

How reproducible:
Always

Steps to Reproduce:
1. Enable wifi.
2. Use computer for a while.
3. Crash!
  
Actual results:
Computer crashes, no response.

Expected results:
Computer should not crash!

Additional info:
smolt: http://www.smolts.org/client/show/pub_a0b1e014-65b8-442e-9504-fadd39f81533

I also get some strange warnings when booting, do you want to see them?
Comment 1 Andreas Tunek 2011-06-07 11:57:42 EDT
After some more testing I have found out that Linux crashes when there is no ethernet cable present, regardless if there is any wireless or not...
Comment 2 Andreas Tunek 2011-06-07 12:02:56 EDT
If you remove the ethernet cable, let the computer crash (sound becomes garbled and you can not interact in any way with the computer) and then plug in the ethernet cable again everything seems to work again, except for the connected USB mouse.

Weird!!
Comment 3 Andreas Tunek 2011-06-07 12:09:09 EDT
Created attachment 503527 [details]
dmesg after a took out and reinserted ethernet cable
Comment 4 Andreas Tunek 2011-06-08 12:54:05 EDT
Tried kernel-2.6.38.8-31.fc15.i686.rpm, same results but USB mouse worked after I reinserted ethernet cable.

Here is some possibly relevant info from dmesg (dmesg4.txt):

Bootup
 0.284648] pci_root PNP0A08:00: address space collision: host bridge window [mem 0x000cc000-0x000cffff] conflicts with Video ROM [mem 0x000c0000-0x000ce1ff]


After ethernet cable removal
[  106.116023] atl1c 0000:06:00.0: atl1c: em1 NIC Link is Down
[  138.275882] psmouse.c: TouchPad at isa0060/serio1/input0 lost synchronization, throwing 2 bytes away.
[  138.281331] atl1c 0000:06:00.0: atl1c: em1 NIC Link is Up<100 Mbps Full Duplex>
[  138.803406] psmouse.c: resync failed, issuing reconnect request
[  143.712312] ------------[ cut here ]------------
[  143.712335] WARNING: at net/sched/sch_generic.c:256 dev_watchdog+0xe2/0x147()
[  143.712342] Hardware name: Aspire One 522
[  143.712348] NETDEV WATCHDOG: em1 (atl1c): transmit queue 0 timed out
[  143.712353] Modules linked in: fuse cpufreq_ondemand powernow_k8 mperf 8021q garp stp llc snd_hda_codec_conexant snd_hda_codec_hdmi snd_hda_intel snd_hda_codec arc4 snd_hwdep ath9k snd_seq snd_seq_device snd_pcm mac80211 snd_timer ath9k_common sp5100_tco snd soundcore ath9k_hw uvcvideo sparse_keymap i2c_piix4 microcode ath snd_page_alloc cfg80211 rfkill k10temp atl1c videodev wmi joydev ipv6 video radeon ttm drm_kms_helper drm i2c_algo_bit i2c_core [last unloaded: scsi_wait_scan]
[  143.712442] Pid: 0, comm: swapper Not tainted 2.6.38.8-31.fc15.i686 #1
[  143.712449] Call Trace:
[  143.712462]  [<c043aad9>] warn_slowpath_common+0x7c/0x91
[  143.712472]  [<c074f92a>] ? dev_watchdog+0xe2/0x147
[  143.712482]  [<c074f92a>] ? dev_watchdog+0xe2/0x147
[  143.712491]  [<c043ab79>] warn_slowpath_fmt+0x33/0x35
[  143.712500]  [<c074f92a>] dev_watchdog+0xe2/0x147
[  143.712511]  [<c07d6483>] ? _raw_spin_unlock_irqrestore+0x13/0x15
[  143.712521]  [<c044da73>] ? __queue_work+0x1fc/0x204
[  143.712532]  [<c0445525>] run_timer_softirq+0x152/0x207
[  143.712542]  [<c048a4d0>] ? __rcu_process_callbacks+0x64/0x1f5
[  143.712552]  [<c074f848>] ? dev_watchdog+0x0/0x147
[  143.712562]  [<c043fdc4>] __do_softirq+0xa9/0x163
[  143.712571]  [<c043fd1b>] ? __do_softirq+0x0/0x163
[  143.712576]  <IRQ>  [<c043ff17>] ? irq_exit+0x3c/0x70
[  143.712593]  [<c041a7fd>] ? smp_apic_timer_interrupt+0x6b/0x78
[  143.712603]  [<c07d6d09>] ? apic_timer_interrupt+0x31/0x38
[  143.712615]  [<c06316ca>] ? arch_local_irq_enable+0x7/0xb
[  143.712625]  [<c0632309>] ? acpi_idle_enter_simple+0x105/0x13d
[  143.712635]  [<c0712fb4>] ? cpuidle_idle_call+0xc5/0x136
[  143.712645]  [<c0401fa0>] ? cpu_idle+0x8e/0xa8
[  143.712655]  [<c07ba9d5>] ? rest_init+0x5d/0x5f
[  143.712667]  [<c0a59816>] ? start_kernel+0x357/0x35d
[  143.712676]  [<c0a5920c>] ? unknown_bootoption+0x0/0x19e
[  143.712686]  [<c0a590d6>] ? i386_start_kernel+0xd6/0xdc
[  143.712693] ---[ end trace 44c3b2c404a5df17 ]---
[  143.749261] atl1c 0000:06:00.0: irq 42 for MSI/MSI-X
[  143.749885] atl1c 0000:06:00.0: atl1c: em1 NIC Link is Up<100 Mbps Full Duplex>
Comment 5 Andreas Tunek 2011-06-08 12:54:37 EDT
Created attachment 503732 [details]
dmesg4
Comment 6 Andreas Tunek 2011-06-11 11:45:10 EDT
Tried with latest firmware, same results.
Comment 7 Kyle McMartin 2011-06-13 15:09:23 EDT
Hrm. I see this bug reported against Ubuntu and in the kernel bugzilla, with no useful responses.

https://bugzilla.kernel.org/show_bug.cgi?id=30892

Could you try booting with "pci=nomsi" to rule out an interrupt related problem?

Also, could you please attach the output of "lspci -vvnn" as root?

regards, Kyle
Comment 8 Kyle McMartin 2011-06-13 15:12:02 EDT
*** Bug 699963 has been marked as a duplicate of this bug. ***
Comment 9 Kyle McMartin 2011-06-13 15:12:14 EDT
*** Bug 709560 has been marked as a duplicate of this bug. ***
Comment 10 Andreas Tunek 2011-06-13 15:21:15 EDT
Created attachment 504524 [details]
lspci output
Comment 11 Helber Maciel Guerra 2011-06-13 16:51:14 EDT
I am using latest from git (3.0.0-rc2-helber.x86_64-00256-gb99ca60-dirty):
[  311.712032] ------------[ cut here ]------------
[  311.712050] WARNING: at net/sched/sch_generic.c:256 dev_watchdog+0x164/0x205()
[  311.712058] Hardware name: Aspire 4540     
[  311.712065] NETDEV WATCHDOG: p5p1 (atl1c): transmit queue 0 timed out
[  311.712071] Modules linked in: vboxnetadp vboxnetflt sunrpc vboxdrv powernow_k8 mperf thermal atl1c wmi processor virtio_net virtio virtio_ring [last unloaded: scsi_wait_scan]
[  311.712109] Pid: 5134, comm: mpegaudioparse0 Not tainted 3.0.0-rc2-helber.x86_64-00256-gb99ca60-dirty #111
[  311.712116] Call Trace:
[  311.712121]  <IRQ>  [<ffffffff8107d2f5>] warn_slowpath_common+0x83/0x9b
[  311.712146]  [<ffffffff8107d3b0>] warn_slowpath_fmt+0x46/0x48
[  311.712155]  [<ffffffff81509c4b>] dev_watchdog+0x164/0x205
[  311.712164]  [<ffffffff8108ac78>] ? mod_timer+0x212/0x274
[  311.712174]  [<ffffffff81089ee5>] run_timer_softirq+0x209/0x354
[  311.712183]  [<ffffffff81509ae7>] ? qdisc_reset+0x41/0x41
[  311.712192]  [<ffffffff8104ee05>] ? lapic_next_event+0x1d/0x21
[  311.712202]  [<ffffffff81083452>] __do_softirq+0xd7/0x1ef
[  311.712212]  [<ffffffff810a68af>] ? tick_program_event+0x1f/0x21
[  311.712223]  [<ffffffff8162d41c>] call_softirq+0x1c/0x30
[  311.712232]  [<ffffffff8103ca98>] do_softirq+0x46/0x86
[  311.712241]  [<ffffffff810837a8>] irq_exit+0x44/0x96
[  311.712251]  [<ffffffff8162dd4d>] smp_apic_timer_interrupt+0x8a/0x98
[  311.712260]  [<ffffffff8162cbd3>] apic_timer_interrupt+0x13/0x20
[  311.712265]  <EOI> 
[  311.712272] ---[ end trace 44d4634399b23574 ]---
[  311.725659] atl1c 0000:03:00.0: Unable to allocate MSI interrupt Error: -22
[  311.725708] atl1c 0000:03:00.0: atl1c: p5p1 NIC Link is Up<100 Mbps Full Duplex>
Comment 12 Helber Maciel Guerra 2011-06-13 16:54:24 EDT
Created attachment 504550 [details]
lspci -vvnn

boot cmdline: ro root=/dev/sda3 rd_NO_LUKS rd_NO_LVM rd_NO_MD rd_NO_DM LANG=pt_BR.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us-acentos quiet pci=nomsi
Comment 13 Nick 2011-06-14 02:07:26 EDT
Package: kernel
Architecture: i686
OS Release: Fedora release 15 (Lovelock)


Comment
-----
I simply tried to configure Samba and started downloading http://www.samba.org/samba/docs/Samba-Guide.pdf Downloading freezed and pages stopped downloading. After that error appeared.
Comment 14 Andreas Tunek 2011-07-03 11:00:30 EDT
Still happens on latest F15 Linux. Is anything going on upstream?
Comment 15 Andreas Tunek 2011-07-16 06:30:02 EDT
Still happens in latest Linux, but seems to take slightly longer to trigger.
Comment 16 Andreas Tunek 2011-07-28 08:12:25 EDT
Set as blocker.
Comment 17 Andreas Tunek 2011-07-28 08:15:27 EDT
Is there any workaround this bug, perhaps by disabling the ethernet chip?
Comment 18 Adam Williamson 2011-07-28 10:16:00 EDT
Can you confirm that this affects Fedora 16? "latest Linux" is ambiguous.

We usually don't consider very hardware-specific bugs to be blockers; is there any indication this bug is affecting a particularly wide range of users?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 19 Tim Flink 2011-07-28 17:07:22 EDT
If this only affects a small subset of hardware, I'm -1 blocker, -1 NTH on this.
Comment 20 Adam Williamson 2011-07-29 13:47:22 EDT
The system is Acer, not ASUS. =) Helber's system also appears to be an Acer. Nick, what's your hardware?
Comment 21 Tim Flink 2011-07-29 13:51:41 EDT
Discussed in the 2011-07-29 blocker review meeting. Rejected as F16 alpha blocker due to small scope of affected hardware.

If the impact of this bug turns out to be greater after investigation, please re-propose as either blocker or NTH.
Comment 22 Andreas Tunek 2011-07-30 15:37:11 EDT
Tried 2.6.40-3.fc15, no change. Will try F16 version as soon as liveUSB is available.
Comment 23 Andreas Tunek 2011-08-10 16:42:42 EDT
For all affected, here is a proper workaround:

in /etc/modprobe.d/blacklist.conf  add the follwing line
blacklist atl1c

reboot

(This will disable the ethernet chip.)
Comment 24 Andreas Tunek 2011-09-07 10:00:17 EDT
Tried with 20110906.17 live-cd, same problems.
Comment 25 Andreas Tunek 2011-09-07 10:02:27 EDT
Proposed nice ot have for F16.
Comment 26 Adam Williamson 2011-09-30 16:24:34 EDT
Discussed at 2011-09-30 NTH review meeting, accepted as NTH due to the severity of the impact of the issue: it makes it very difficult to install / use F16 on an affected system.
Comment 27 Dave Jones 2011-10-14 10:11:09 EDT
*** Bug 746125 has been marked as a duplicate of this bug. ***
Comment 28 Josh Boyer 2011-10-24 15:18:39 EDT

*** This bug has been marked as a duplicate of bug 717211 ***

Note You need to log in before you can comment on or make changes to this bug.