Bug 715979 - FTBFS clamav-0.97.1-1600.fc16
FTBFS clamav-0.97.1-1600.fc16
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: clamav (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Enrico Scholz
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Reopened, Triaged
Depends On: 716267 716460
Blocks: F16FTBFS
  Show dependency treegraph
 
Reported: 2011-06-23 11:50 EDT by FTBFS
Modified: 2011-09-12 22:21 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-13 20:25:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log (268.72 KB, text/plain)
2011-06-23 11:50 EDT, FTBFS
no flags Details
build.log (14.52 KB, text/plain)
2011-06-23 11:50 EDT, FTBFS
no flags Details
mock.log (1.29 KB, text/plain)
2011-06-23 11:50 EDT, FTBFS
no flags Details
root.log (389.21 KB, text/plain)
2011-06-23 11:50 EDT, FTBFS
no flags Details
build.log (14.51 KB, text/plain)
2011-06-23 11:50 EDT, FTBFS
no flags Details
mock.log (1.22 KB, text/plain)
2011-06-23 11:51 EDT, FTBFS
no flags Details

  None (edit)
Description FTBFS 2011-06-23 11:50:49 EDT
clamav-0.97.1-1600.fc16.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2011-06-23 11:50:52 EDT
Created attachment 508189 [details]
root.log


root.log for i386
Comment 2 FTBFS 2011-06-23 11:50:54 EDT
Created attachment 508190 [details]
build.log


build.log for i386
Comment 3 FTBFS 2011-06-23 11:50:55 EDT
Created attachment 508191 [details]
mock.log


mock.log for i386
Comment 4 FTBFS 2011-06-23 11:50:57 EDT
Created attachment 508192 [details]
root.log


root.log for x86_64
Comment 5 FTBFS 2011-06-23 11:50:59 EDT
Created attachment 508193 [details]
build.log


build.log for x86_64
Comment 6 FTBFS 2011-06-23 11:51:00 EDT
Created attachment 508194 [details]
mock.log


mock.log for x86_64
Comment 7 Nathanael Noblet 2011-06-23 13:31:44 EDT
A local mock build for rawhide works fine for me. The build.log shows configure complaining about a missing zlib, however root.log shows that zlib is in fact installed.
Comment 8 Nathanael Noblet 2011-06-23 13:32:57 EDT
Also koji reports the version of zlib as 1.2.5-4 / same as the version the root.log shows being installed. I'm confused.
Comment 9 Enrico Scholz 2011-06-23 15:27:47 EDT
I think, this bug is bogus and caused by broken mock/yum behaviour which ignores silently dependency errors in completely unrelated packages:

DEBUG util.py:250:  Error: Package: sendmail-8.14.5-1.fc16.i686 (ftbfs)
DEBUG util.py:250:             Requires: libdb-5.1.so
DEBUG util.py:250:   You could try using --skip-broken to work around the problem
DEBUG util.py:250:   You could try running: rpm -Va --nofiles --nodigest
DEBUG util.py:250:  Reading Local RPMDB
Comment 10 Matt Domsch 2011-06-23 15:46:06 EDT
re-opening, until the dependent mock bug is closed.
Comment 11 Christoph Wickert 2011-06-23 16:17:15 EDT
IHMO we should are facing two problems here. One is the mock bug 716267. The other is that sendmail has depsolving problems. sendmail itself is not FTBFS (but needs a rebuild), so the sendmail owner is probably not aware of the problem his package causes. Therefor Enrico should file another bug against sendmail and let it block this one instead of just closing it.

Note You need to log in before you can comment on or make changes to this bug.