This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 716267 - mock 1.1.11 moves to build step even if buildroot had depsolving problems
mock 1.1.11 moves to build step even if buildroot had depsolving problems
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
: 716438 718857 (view as bug list)
Depends On:
Blocks: 715670 715736 715801 715829 715851 715905 715931 715979 716024 716036 716047 716164 716166 716167 716188
  Show dependency treegraph
 
Reported: 2011-06-23 15:43 EDT by Matt Domsch
Modified: 2014-01-21 18:18 EST (History)
13 users (show)

See Also:
Fixed In Version: yum-utils-1.1.31-2.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-02 22:33:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matt Domsch 2011-06-23 15:43:37 EDT
Description of problem:

If the buildrequires of a package itself has a dependency problem, mock still winds up with "No uninstalled build requires", which is incorrect.  In fact, none of the buildrequires packages will have been installed into the chroot.  This leads the build to start, and fail when its BRs are not present, leading to confusion as to the root cause of the failure.  For example:
mock-results/x86_64/clamav-0.97.1-1600.fc16.src.rpm/result/root.log:

DEBUG util.py:250:  sendmail-8.14.5-1.fc16.x86_64 requires: libdb-5.1.so()(64bit)
DEBUG util.py:250:  --> Processing Dependency: libdb-5.1.so()(64bit) for package: sendmail-8.14.5-1.fc16.x86_64
DEBUG util.py:250:  Searching pkgSack for dep: libdb-5.1.so()(64bit)
DEBUG util.py:250:  --> Finished Dependency Resolution
DEBUG util.py:250:  Dependency Process ending
DEBUG util.py:250:  SKIPBROKEN: sendmail-8.14.5-1.fc16.x86_64 from ftbfs has depsolving problems
DEBUG util.py:250:  SKIPBROKEN:  --> Package: sendmail-8.14.5-1.fc16.x86_64 (ftbfs)
DEBUG util.py:250:    -->     Requires: libdb-5.1.so()(64bit)
DEBUG util.py:250:  Depsolve time: 0.644
DEBUG util.py:250:  Error: Package: sendmail-8.14.5-1.fc16.x86_64 (ftbfs)
DEBUG util.py:250:             Requires: libdb-5.1.so()(64bit)
DEBUG util.py:250:   You could try using --skip-broken to work around the problem
DEBUG util.py:250:   You could try running: rpm -Va --nofiles --nodigest
DEBUG util.py:250:  Reading Local RPMDB
DEBUG util.py:250:  rpmdb time: 0.000
DEBUG util.py:250:  No uninstalled build requires



Version-Release number of selected component (if applicable):
mock-1.1.11

How reproducible:
easy

Steps to Reproduce:
1. build clamav with mock 1.1.11
  
Actual results:
build fails, reportedly due to bad BRs on clamav, when it's really a problem with sendmail.

Expected results:
build fails, reportedly due to problems with one of the BR packages.

Additional info:
Comment 1 Clark Williams 2011-06-24 10:09:12 EDT
*** Bug 716438 has been marked as a duplicate of this bug. ***
Comment 2 Clark Williams 2011-06-24 10:09:28 EDT
*** Bug 709043 has been marked as a duplicate of this bug. ***
Comment 3 Levente Farkas 2011-06-24 10:15:51 EDT
the real problem here why yum-builddep return with 0 when it's fail?!
as i wrote in #709043 it's a serious bug and should have to fix asap.
Comment 4 Clark Williams 2011-06-24 10:27:13 EDT
Changing this to yum-utils component, which is what contains the yum-builddep command
Comment 5 Ville Skyttä 2011-06-24 11:48:09 EDT
Fixed upstream: http://yum.baseurl.org/gitweb?p=yum-utils.git;a=patch;h=32ec621
Comment 6 Levente Farkas 2011-06-24 12:28:45 EDT
and is there anybody who can push it to the rhel-6 too?
should i've to open another bz for rhel-6?
Comment 7 Clark Williams 2011-07-28 11:36:06 EDT
This is causing issues for the builder systems. We need to get yum-builddep updated so that the builders can move to 1.1.12+ for correct pty handling.
Comment 8 James Antill 2011-07-28 12:40:18 EDT
Building yum-utils-1.1.30-3.fc17 for dist-rawhide
Created task: 3236023
Task info: http://koji.fedoraproject.org/koji/taskinfo?taskID=3236023

Building yum-utils-1.1.30-3.fc15 for f15-candidate
Created task: 3236056
Task info: http://koji.fedoraproject.org/koji/taskinfo?taskID=3236056
Comment 9 Fedora Update System 2011-07-28 14:57:25 EDT
yum-utils-1.1.30-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/yum-utils-1.1.30-3.fc15
Comment 10 Levente Farkas 2011-07-28 16:05:28 EDT
what about el6? it's and issue on rhel6 too!
Comment 11 Fedora Update System 2011-07-30 23:44:49 EDT
Package yum-utils-1.1.30-3.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing yum-utils-1.1.30-3.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/yum-utils-1.1.30-3.fc15
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2011-08-02 22:33:24 EDT
yum-utils-1.1.30-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2011-08-10 13:28:35 EDT
yum-utils-1.1.31-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/yum-utils-1.1.31-1.fc16
Comment 14 Fedora Update System 2011-08-10 13:28:51 EDT
yum-utils-1.1.31-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/yum-utils-1.1.31-1.fc15
Comment 15 Fedora Update System 2011-08-13 12:23:59 EDT
yum-utils-1.1.31-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/yum-utils-1.1.31-2.fc16
Comment 16 Fedora Update System 2011-08-13 12:24:18 EDT
yum-utils-1.1.31-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/yum-utils-1.1.31-2.fc15
Comment 17 Fedora Update System 2011-08-17 22:37:21 EDT
yum-utils-1.1.31-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2011-08-22 10:46:39 EDT
yum-utils-1.1.31-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Ville Skyttä 2011-12-19 15:09:28 EST
*** Bug 718857 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.