Bug 71852 - gpilotd-control-applet won't start
gpilotd-control-applet won't start
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: gnome-pilot (Show other bugs)
null
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 71764 72374 74128 (view as bug list)
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-08-19 16:47 EDT by Tobias Karlsson
Modified: 2008-05-01 11:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-29 01:25:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tobias Karlsson 2002-08-19 16:47:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020809

Description of problem:
Since the pilot/handspring tool won't start, I tried to start
gpilotd-control-applet by hand which also fails.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Start gpilotd-control-applet
2.
3.
	

Actual Results:  Error output

Additional info:

Output from strace:

connect(7, {sin_family=AF_UNIX, path="/tmp/orbit-root/orb-7870607421310960715"},
41) = 0
fcntl64(7, F_SETFD, FD_CLOEXEC)         = 0
fcntl64(7, F_GETFL)                     = 0x2 (flags O_RDWR)
fcntl64(7, F_SETFL, O_RDWR|O_NONBLOCK)  = 0
writev(7, [{"GIOP\1\0\1", 7}, {"\0 \1\0\0", 5}, {"\0\0\0\0", 4},
{"\374\367\377\277\1", 5}, {"\0\0\0", 3},
{"\30\0\0\0\0\0\0\0Y\217|\277U\304\355\245\1\0\0\0L\225\5"..., 28},
{"\25\0\0\0register_capplet_new\0", 25}, {"\0\0\0", 3},
{"@\0\0\0q4/O.sR9{m\\6;h\"ST2-IP:INk7+O"..., 68}, {"\26\0\0\0", 4},
{"IDL:GNOME/capplet:1.0\0", 22}, {"\0\0", 2}, {"\1\0\0\0", 4},
{"\312\256\337\272", 4}, {"P\0\0\0\1\1\0\0)\0\0\0/tmp/orbit-root/orb-"..., 84},
{"\27\0\0\0", 4}, {"gpilotd-control-applet\0", 23}, {"\0", 1},
{"\377\377\377\377", 4}], 19) = 300
select(8, [5 6 7], NULL, [5 6 7], NULL) = 1 (in [7])
read(7, "GIOP\1\0\1\1\24\0\0\0", 12)    = 12
read(7, "\0\0\0\0\374\367\377\277\0\0\0\0\0\0\0\0\377\377\377\377"..., 20) =
20open("/usr/share/locale/en_US.UTF-8/LC_MESSAGES/gnome-pilot.mo", O_RDONLY) = -1
ENOENT (No such file or directory)
open("/usr/share/locale/en_US.utf8/LC_MESSAGES/gnome-pilot.mo", O_RDONLY) = -1
ENOENT (No such file or directory)
open("/usr/share/locale/en_US/LC_MESSAGES/gnome-pilot.mo", O_RDONLY) = -1 ENOENT
(No such file or directory)
open("/usr/share/locale/en.UTF-8/LC_MESSAGES/gnome-pilot.mo", O_RDONLY) = -1
ENOENT (No such file or directory)
open("/usr/share/locale/en.utf8/LC_MESSAGES/gnome-pilot.mo", O_RDONLY) = -1
ENOENT (No such file or directory)
open("/usr/share/locale/en/LC_MESSAGES/gnome-pilot.mo", O_RDONLY) = -1 ENOENT
(No such file or directory)
write(2, "\n** ", 4
** )                    = 4
write(2, "ERROR **: ", 10ERROR **: )              = 10
write(2, "Error initializing gpilotd cappl"..., 34Error initializing gpilotd
capplet) = 34
write(2, "\naborting...\n", 13
aborting...
)         = 13
rt_sigprocmask(SIG_UNBLOCK, [ABRT], NULL, 8) = 0
kill(1170, SIGABRT)                     = 0
--- SIGABRT (Aborted) ---
+++ killed by SIGABRT +++
Comment 1 Jeremy Katz 2002-08-22 02:59:19 EDT
The gnome_capplet_init() call is failing because registering with the control
center is failling for some reason.  But that's deep down in ORBit land.  Any
ideas Elliot?
Comment 2 Richard Torkar 2002-08-23 05:36:13 EDT
*** Bug 72374 has been marked as a duplicate of this bug. ***
Comment 3 Jeremy Katz 2002-08-23 12:07:50 EDT
*** Bug 71764 has been marked as a duplicate of this bug. ***
Comment 4 Jeremy Katz 2002-08-29 01:24:58 EDT
Fixed in 0.1.65-8.  Thanks to Elliot for the pointer
Comment 5 Jay Turner 2002-09-03 16:48:56 EDT
Fix confirmed with gnome-pilot-0.1.65-8.
Comment 6 Dennis Gilmore 2002-09-05 08:35:52 EDT
i have upgared to gnome-pilot-0.1.65-8  and still get the same error  i have
included part of the strace output


socket(PF_UNIX, SOCK_STREAM, 0)         = 6
connect(6, {sin_family=AF_UNIX,
path="/tmp/orbit-dennis/orb-9106282191857814944"}, 43) = 0
fcntl64(6, F_SETFD, FD_CLOEXEC)         = 0
fcntl64(6, F_GETFL)                     = 0x2 (flags O_RDWR)
fcntl64(6, F_SETFL, O_RDWR|O_NONBLOCK)  = 0
writev(6, [{"GIOP\1\0\1", 7}, {"\0\227\0\0\0", 5}, {"\0\0\0\0", 4},
{"\354\361\377\277\1", 5}, {"\0\0\0", 3},
{"\30\0\0\0\0\0\0\0amXx$}\v\265\1\0\0\0\234\202d\204\351"..., 28},
{"\10\0\0\0resolve\0", 12}, {"@\0\0\0P*>aw-(y\"Z|/rDKhc<\"QK/3,{qkp"..., 68},
{"\1\0\0\0", 4}, {"\6\0\0\0", 4}, {"GNOME\0", 6}, {"\0\0", 2}, {"\v\0\0\0", 4},
{"subcontext\0", 11}], 14) = 163
select(7, [5 6], NULL, [5 6], NULL)     = 1 (in [6])
read(6, "GIOP\1\0\1\1\224\0\0\0", 12)   = 12
read(6, "\0\0\0\0\354\361\377\277\0\0\0\0(\0\0\0IDL:omg.org/Cos"..., 148) = 148
writev(6, [{"GIOP\1\0\1", 7}, {"\0\323\0\0\0", 5}, {"\0\0\0\0", 4},
{"\\\362\377\277\1", 5}, {"\0\0\0", 3},
{"\30\0\0\0\0\0\0\0amXx$}\v\265\1\0\0\0\234\202d\204\351"..., 28},
{"\10\0\0\0resolve\0", 12}, {"@\0\0\0P*>aw-(y\"Z|/rDKhc<\"QK/3,{qkp"..., 68},
{"\3\0\0\0", 4}, {"\6\0\0\0", 4}, {"GNOME\0", 6}, {"\0\0", 2}, {"\v\0\0\0", 4},
{"subcontext\0", 11}, {"\0", 1}, {"\10\0\0\0", 4}, {"Servers\0", 8},
{"\v\0\0\0", 4}, {"subcontext\0", 11}, {"\0", 1}, {"\17\0\0\0", 4},
{"control_center\0", 15}, {"\0", 1}, {"\7\0\0\0", 4}, {"object\0", 7}], 25) = 223
select(7, [5 6], NULL, [5 6], NULL)     = 1 (in [6])
read(6, "GIOP\1\0\1\1\214\0\0\0", 12)   = 12
read(6, "\0\0\0\0\\\362\377\277\0\0\0\0\35\0\0\0IDL:GNOME/contr"..., 140) = 140
socket(PF_UNIX, SOCK_STREAM, 0)         = 7
connect(7, {sin_family=AF_UNIX,
path="/tmp/orbit-dennis/orb-1208041343965993066"}, 43) = 0
fcntl64(7, F_SETFD, FD_CLOEXEC)         = 0
fcntl64(7, F_GETFL)                     = 0x2 (flags O_RDWR)
fcntl64(7, F_SETFL, O_RDWR|O_NONBLOCK)  = 0
writev(7, [{"GIOP\1\0\1", 7}, {"\0\34\1\0\0", 5}, {"\0\0\0\0", 4},
{"\\\367\377\277\1", 5}, {"\0\0\0", 3},
{"\30\0\0\0\0\0\0\0i\267R\357D\272]\26\1\0\0\0\241F\261\200"..., 28},
{"\25\0\0\0register_capplet_new\0", 25}, {"\0\0\0", 3},
{"@\0\0\0P*>aw-(y\"Z|/rDKhc<\"QK/3,{qkp"..., 68}, {"\26\0\0\0", 4},
{"IDL:GNOME/capplet:1.0\0", 22}, {"\0\0", 2}, {"\1\0\0\0", 4},
{"\312\256\337\272", 4}, {"L\0\0\0\1\1\0\0&\0\0\0/tmp/orbit-root/orb-"..., 80},
{"\27\0\0\0", 4}, {"gpilotd-control-applet\0", 23}, {"\0", 1},
{"\377\377\377\377", 4}], 19) = 296
select(8, [5 6 7], NULL, [5 6 7], NULL) = 1 (in [7])
read(7, "GIOP\1\0\1\1\24\0\0\0", 12)    = 12
read(7, "\0\0\0\0\\\367\377\277\0\0\0\0\0\0\0\0\377\377\377\377"..., 20) = 20
open("/usr/share/locale/en_AU.UTF-8/LC_MESSAGES/gnome-pilot.mo", O_RDONLY) = -1
ENOENT (No such file or directory)
open("/usr/share/locale/en_AU.utf8/LC_MESSAGES/gnome-pilot.mo", O_RDONLY) = -1
ENOENT (No such file or directory)
open("/usr/share/locale/en_AU/LC_MESSAGES/gnome-pilot.mo", O_RDONLY) = -1 ENOENT
(No such file or directory)
open("/usr/share/locale/en.UTF-8/LC_MESSAGES/gnome-pilot.mo", O_RDONLY) = -1
ENOENT (No such file or directory)
open("/usr/share/locale/en.utf8/LC_MESSAGES/gnome-pilot.mo", O_RDONLY) = -1
ENOENT (No such file or directory)
open("/usr/share/locale/en/LC_MESSAGES/gnome-pilot.mo", O_RDONLY) = -1 ENOENT
(No such file or directory)
write(2, "\n** ", 4
** )                    = 4
write(2, "ERROR **: ", 10ERROR **: )              = 10
write(2, "Error initializing gpilotd cappl"..., 34Error initializing gpilotd
capplet) = 34
write(2, "\naborting...\n", 13
aborting...
)         = 13
rt_sigprocmask(SIG_UNBLOCK, [ABRT], NULL, 8) = 0
kill(2589, SIGABRT)                     = 0
--- SIGABRT (Aborted) ---
+++ killed by SIGABRT +++
Comment 7 Jeremy Katz 2002-09-05 10:42:47 EDT
You have to completely log out of X and make sure all ORBit using apps are no
longer running.  Otherwise, it picks up an old CORBA server with the cached
reference of it not working.
Comment 8 Jeremy Katz 2002-09-20 11:37:30 EDT
*** Bug 74128 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.