Bug 725125 - Fedora 15 LXDE: Canadian French KB layout - Dead keys not working in QT app.
Fedora 15 LXDE: Canadian French KB layout - Dead keys not working in QT app.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
15
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-22 19:36 EDT by nomnex
Modified: 2011-07-26 00:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-26 00:53:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
French input in QT apps using the "ca" KB layout (40.60 KB, image/png)
2011-07-22 19:36 EDT, nomnex
no flags Details
dead key with puddletag (137.81 KB, image/png)
2011-07-24 23:15 EDT, fujiwara
no flags Details

  None (edit)
Description nomnex 2011-07-22 19:36:51 EDT
Created attachment 514803 [details]
French input in QT apps using the "ca" KB layout

Description of problem:

Configuration: Linux, Fedora 15 LXDE. Language "en_US". Hardware keyboard (notebook) "jp" (default). Additional keyboard layout "ca"

I use a the "ca" keyboard layout to type French language (iBus). The dead keys "^" "¸" "`" are not recognized in applications using a QT tool kit [Anki, Puddletag, LyX, Scribus, etc.]

"ç" returns "¸c"
"à" returns "`a"
"è" returns "`e"
"ê" returns "^e"

Version-Release number of selected component (if applicable):

IBus 1.3.99.20110714

How reproducible:

Always

Steps to Reproduce:
1. Set the "ca" input and keyboard layout in ibus [LXDE DE "en_US"]
2. Open a QT application (e.g. Anki)
3. Type some letters with accents using the dead key
  
Actual results:

"ç" returns "¸c"
"à" returns "`a"
"è" returns "`e"
"ê" returns "^e"

Expected results:

"ç"
"à"
"è"
"ê"

Additional info:

Canadian French layout is very similar to a JP/US KB layout. It relies mostly on dead keys to input the accents.

Swiss-French layout has some keys inversion, and most of the accents are assigned to letters.

Side note:

I had a similar problem on Fedora 13 with the Swiss-French keyboard layout, see: https://bugzilla.redhat.com/show_bug.cgi?id=658090. The problem was only the circumflex accent "^e". The problem has been resolved.

Since I experienced a similar problem on F-15, using a "ca" KB layout this time, I have opened 2 bugs (722911) and upstream QT ( https://bugreports.qt.nokia.com//browse/QTBUG-20428). Kevin Kofler comment2, bug 722911: "These bugs are usually caused by input methods" suggests it's a ibus issue and not a QT problem.

Thank you.
Comment 1 fujiwara 2011-07-24 23:15:59 EDT
Created attachment 514958 [details]
dead key with puddletag

Attached the dead key in my env.
Comment 2 fujiwara 2011-07-24 23:18:36 EDT
(In reply to comment #0)
> Configuration: Linux, Fedora 15 LXDE. Language "en_US". Hardware keyboard
> (notebook) "jp" (default). Additional keyboard layout "ca"

How do you configure the dead key for LXDE?
E.g. I use 'gnome-control-center region' on GNOME and systemsettings on KDE.
Also did you install ibus-qt which is required for qt applications?
Comment 3 nomnex 2011-07-26 00:15:00 EDT
(In reply to comment #2)
 
> How do you configure the dead key for LXDE?
> E.g. I use 'gnome-control-center region' on GNOME and systemsettings on KDE.
> Also did you install ibus-qt which is required for qt applications?

Thank you very much for the print-screen and the ibus-qt plug-in hints!

ibus is part of the default LXDE Spin. when I installed QT applications from the F-repo, the QT-4 config module, and other QT lib came along, as part of the dependencies. I was assuming, somehow, ibus had automatically updated its dependencies in the same fashion, and that something was broken. If it was not your answer (comment #2), I would be still be wandering what/where to look for. It was confusing because some KB layout with dead keys were working on QT apps (e.g. the Swiss-French KB) while the CA KB wasn't.

You relieved me from a massive pain of 3 weeks, setting several language inputs. Thanks again for all your comments.

To answer the first part of your question: I don't configure dead key on LXDE. There is no equivalent as the "gnome-control-center" region on Gnome, or systemsettings on KDE. When I need to switch between different KB layouts, I look at "/usr/share/X11/xkb/base" for the options, and I modify the file:

/etc/xdg/lxsession/LXDE/autostart

with a setxkbmap command, in the following line before @lxpanel --profile LXDE (e.g.):

@setxkbmap -option grp:switch, grp:rctrl_rshift_toggle jp,ca
Comment 4 nomnex 2011-07-26 00:20:49 EDT
Installing ibus-qt plug-in solved the problem of dead key accents not recognized with a KB CA layout, in QT applications.
Comment 5 fujiwara 2011-07-26 00:53:51 EDT
OK, thanks.

Note You need to log in before you can comment on or make changes to this bug.