Bug 727831 - Default GRUB timeout is 20 seconds
Default GRUB timeout is 20 seconds
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-03 07:10 EDT by Kamil Páral
Modified: 2011-11-27 08:02 EST (History)
5 users (show)

See Also:
Fixed In Version: anaconda-16.19-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-24 00:35:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/boot/grub2/grub.cfg (2.54 KB, application/x-extension-cfg)
2011-08-03 07:10 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2011-08-03 07:10:52 EDT
Created attachment 516490 [details]
/boot/grub2/grub.cfg

Description of problem:
I installed F16 Alpha TC1 on a clean harddisk. No other system in there. After installation the default grub timeout is set to 20 seconds and the menu is set to be visible.

See attached grub.cfg.

I believe:
1. The menu should be hidden, because I don't have any other operating system installed.
2. The default timeout should be less than 20 seconds, that's overkill. 10 seconds maybe?

Version-Release number of selected component (if applicable):
anaconda-16.14
grub2-1.99-0.2.fc16.i686

How reproducible:
always

Steps to Reproduce:
1. install F16 Alpha TC1 no a clean disk
2. reboot and see grub
Comment 1 Fedora Update System 2011-09-23 17:48:21 EDT
anaconda-16.19-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/anaconda-16.19-1.fc16
Comment 2 Fedora Update System 2011-09-24 00:35:00 EDT
anaconda-16.19-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 3 Adam Williamson 2011-09-30 14:51:02 EDT
*** Bug 737339 has been marked as a duplicate of this bug. ***
Comment 4 João Gomes 2011-11-14 11:23:08 EST
I downloaded and installed Fedora 16 four days ago.
The default timeout is 5 seconds, but the menu is shown with only one OS installed.
Is this the normal behavior?
In fedora 15, the menu was hidden when that was only one OS in the system.
Comment 5 Kamil Páral 2011-11-15 04:15:35 EST
João, create a separate bug about that, thanks.
Comment 6 Alexander van Loon 2011-11-27 08:02:44 EST
I beat João to it, see bug #757487.

Note You need to log in before you can comment on or make changes to this bug.