Bug 728321 - telinit U causes X to crash
Summary: telinit U causes X to crash
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Adam Jackson
QA Contact:
URL:
Whiteboard: [cat:crash]
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-04 17:23 UTC by Daniel Walsh
Modified: 2018-04-11 09:36 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-12 21:01:09 UTC


Attachments (Terms of Use)
Here is the X log file. (44.31 KB, text/plain)
2011-08-04 17:23 UTC, Daniel Walsh
no flags Details
Try the attachment again. (44.31 KB, text/plain)
2011-08-04 20:31 UTC, Daniel Walsh
no flags Details

Description Daniel Walsh 2011-08-04 17:23:38 UTC
Created attachment 516752 [details]
Here is the X log file.

Comment 1 Daniel Walsh 2011-08-04 20:31:19 UTC
Created attachment 516784 [details]
Try the attachment again.

Comment 2 Matěj Cepl 2011-08-04 21:02:56 UTC
Awesome!

Backtrace:
[263512.818] 0: /usr/bin/Xorg (xorg_backtrace+0x2f) [0x46216f]
[263512.818] 1: /usr/bin/Xorg (0x400000+0x66eb6) [0x466eb6]
[263512.818] 2: /lib64/libpthread.so.0 (0x3291a00000+0xf470) [0x3291a0f470]
[263512.819] 3: /lib64/libc.so.6 (__select+0x13) [0x32916e3ae3]
[263512.819] 4: /usr/bin/Xorg (WaitForSomething+0x186) [0x45f726]
[263512.819] 5: /usr/bin/Xorg (0x400000+0x336ba) [0x4336ba]
[263512.819] 6: /usr/bin/Xorg (0x400000+0x22cf5) [0x422cf5]
[263512.820] 7: /lib64/libc.so.6 (__libc_start_main+0xed) [0x329162150d]
[263512.820] 8: /usr/bin/Xorg (0x400000+0x22fe1) [0x422fe1]

Comment 3 Matěj Cepl 2011-08-04 21:06:50 UTC
In function WaitForSomething:
(from frame 4: /usr/bin/Xorg (WaitForSomething+0x186) [0x45f726])
224: 	    i = -1;
225: 	else if (AnyClientsWriteBlocked)
226: 	{
227: 	    XFD_COPYSET(&ClientsWriteBlocked, &clientsWritable);
228: 	    i = Select (MaxClients, &LastSelectMask, &clientsWritable, NULL, wt);
229: 	}
230: 	else 
231: 	{
232: 	    i = Select (MaxClients, &LastSelectMask, NULL, NULL, wt);
233: 	}
234: >>>>>>> 	selecterr = GetErrno();
235: 	WakeupHandler(i, (pointer)&LastSelectMask);
236: 	if (i <= 0) /* An error or timeout occurred */
237: 	{
238: 	    if (dispatchException)
239: 		return 0;
240: 	    if (i < 0) 
241: 	    {
242: 		if (selecterr == EBADF)    /* Some client disconnected */
243: 		{
244: 		    CheckConnections ();


Frame 5: /usr/bin/Xorg (0x400000+0x336ba) [0x4336ba]
	/usr/src/debug/xorg-server-20110510/dix/dispatch.c:370
	Dispatch
Frame 6: /usr/bin/Xorg (0x400000+0x22cf5) [0x422cf5]
	/usr/src/debug/xorg-server-20110510/dix/main.c:291
	main

Comment 4 Matěj Cepl 2011-08-04 21:08:00 UTC

*** This bug has been marked as a duplicate of bug 727778 ***

Comment 5 Matěj Cepl 2011-08-04 21:56:34 UTC
This is probably more complicated. Rather reopening.

Comment 6 Matěj Cepl 2011-08-04 22:26:41 UTC
There are similar backtraces in bug 663804, bug 727778 (and perhaps bug 703155). Less similar (but perhaps in the same function) are bug 714746 and bug 710564.

Comment 7 Matěj Cepl 2011-08-04 23:03:54 UTC
Fatal server error:
[261172.189] Caught signal 3 (Quit). Server aborting

Comment 8 Adam Jackson 2011-09-08 19:36:02 UTC
I can't reproduce this with F16 as of today.  Dan, are you still seeing this?

Comment 9 Daniel Walsh 2011-09-12 21:01:09 UTC
Looks good.


Note You need to log in before you can comment on or make changes to this bug.