Bug 728720 - ABRT doesn't react to any crashes
Summary: ABRT doesn't react to any crashes
Keywords:
Status: CLOSED DUPLICATE of bug 737961
Alias: None
Product: Fedora
Classification: Fedora
Component: abrt
Version: 15
Hardware: i686
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Miroslav Lichvar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-06 17:46 UTC by Konstantin Svist
Modified: 2011-10-03 14:18 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-03 14:18:27 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 734585 None None None Never

Internal Links: 734585

Description Konstantin Svist 2011-08-06 17:46:38 UTC
Description of problem:
Tried testcases from https://fedoraproject.org/wiki/QA:Testcase_ABRT_python and https://fedoraproject.org/wiki/QA:Testcase_ABRT_kernel -- ABRT doesn't react to either one.


Version-Release number of selected component (if applicable):
2.0.3

How reproducible:
every time

Steps to Reproduce:
1. see https://fedoraproject.org/wiki/QA:Testcase_ABRT_python
  
Actual results:
ABRT doesn't respond

Expected results:
ABRT should appear and ask user to report the problem

Additional info:

Using XFCE. Upgraded from Fedora 14

abrtd is definitely running:
# pgrep -fl abrt
419 /usr/sbin/abrtd -d -s
1216 abrt-applet

# service abrtd status
abrtd.service - ABRT Automated Bug Reporting Tool
      Loaded: loaded (/lib/systemd/system/abrtd.service)
      Active: active (running) since Fri, 05 Aug 2011 21:30:42 -0700; 12h ago
    Main PID: 419 (abrtd)
      CGroup: name=systemd:/system/abrtd.service
          └ 419 /usr/sbin/abrtd -d -s

Comment 1 Joe Christy 2011-08-07 15:59:22 UTC
I'm seeing this in the wild.

Ever since the upgrade to kernel "2.6.40" in F15, my machine has been oops-ing, mostly in the dead of night, to the extent that the load climbs into the 50's and the machine becomes utterly unresponsive. As far as I can tell, what's going on is that it's writing oops info into /var/log/messages faster than syslog can handle it, but who knows really.

All the while abrt, though running:
[root@moby ~]# pgrep -fl abrt
1148 /usr/sbin/abrtd -d -s
2023 abrt-dump-oops -d /var/spool/abrt -rwx /var/log/messages
4954 /usr/bin/abrt-applet
is strangely unaware that anything is wrong, i.e. it just sits there and does nothing.


RPMs installed:
kernel.x86_64                            2.6.40-4.fc15
abrt.x86_64                                          2.0.3-1.fc15
abrt-addon-ccpp.x86_64                               2.0.3-1.fc15
abrt-addon-kerneloops.x86_64                         2.0.3-1.fc15
abrt-addon-python.x86_64                             2.0.3-1.fc15
abrt-desktop.x86_64                                  2.0.3-1.fc15
abrt-gui.x86_64                                      2.0.3-1.fc15
abrt-libs.x86_64                                     2.0.3-1.fc15
abrt-plugin-bugzilla.x86_64                          2.0.3-1.fc15
abrt-plugin-logger.x86_64                            2.0.3-1.fc15

Comment 2 Jiri Moskovcak 2011-08-07 16:56:03 UTC
The oops problem might be the same as 728314.

Comment 3 Konstantin Svist 2011-08-20 00:44:26 UTC
Correction: don't know if those testcases are outdated, but "sleep 100 & kill -$!" works.

Here's what doesn't work:
My XFCE session just crashed & restarted. /var/log/messages says:

Aug 19 17:36:56 mireille abrt[12938]: Unrecognized variable 'DumpLocation' in '/etc/abrt/abrt.conf'
Aug 19 17:36:56 mireille abrtd: Unrecognized variable 'DumpLocation' in '/etc/abrt/abrt.conf'
Aug 19 17:36:56 mireille abrt[12938]: saved core dump of pid 735 (/usr/bin/Xorg) to /var/spool/abrt/ccpp-2011-08-19-17:36:56-735.new/coredump (1875968 bytes)
Aug 19 17:36:56 mireille abrtd: Directory 'ccpp-2011-08-19-17:36:56-735' creation detected
Aug 19 17:36:58 mireille abrtd: Can't open file '/var/spool/abrt/pyhook-1293051654-7465/uuid': No such file or directory
Aug 19 17:36:58 mireille abrtd: Can't open file '/var/spool/abrt/kerneloops-1305228865-1427-1/uuid': No such file or directory
Aug 19 17:36:58 mireille abrtd: Can't open file '/var/spool/abrt/kerneloops-1305573542-1429-1/uuid': No such file or directory
Aug 19 17:36:58 mireille abrtd: Can't open file '/var/spool/abrt/pyhook-1310580279-9248/uuid': No such file or directory
Aug 19 17:36:58 mireille abrtd: Can't open file '/var/spool/abrt/ccpp-1301102183-2555/uuid': No such file or directory
Aug 19 17:36:58 mireille abrtd: New dump directory /var/spool/abrt/ccpp-2011-08-19-17:36:56-735, processing
Aug 19 17:36:58 mireille abrtd: Unrecognized variable 'DumpLocation' in '/etc/abrt/abrt.conf'

Comment 4 Konstantin Svist 2011-09-03 17:13:16 UTC
Doesn't react to xorg crash I keep getting almost daily, bug #734585

Comment 5 Miroslav Lichvar 2011-10-03 14:18:27 UTC
The original problem with python reported here looks like a duplicate of #737961.

For the other issues, please file new bugs if you can still reproduce it.

*** This bug has been marked as a duplicate of bug 737961 ***


Note You need to log in before you can comment on or make changes to this bug.