Bug 737961 - abrt unable to catch crash of python
Summary: abrt unable to catch crash of python
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: abrt
Version: 15
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: ---
Assignee: Jiri Moskovcak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 728720 (view as bug list)
Depends On: 737958
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-13 13:41 UTC by Richard Marko
Modified: 2016-02-01 02:21 UTC (History)
13 users (show)

Fixed In Version: abrt-2.0.4.981-1.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of: 737958
Environment:
Last Closed: 2011-09-19 07:22:10 UTC


Attachments (Terms of Use)

Description Richard Marko 2011-09-13 13:41:31 UTC
+++ This bug was initially created as a clone of Bug #737958 +++

Description of problem:
abrt-action-save-package-data is crashing during analysis

How reproducible:
Crash python

Steps to Reproduce:
1. python &
2. kill -SIGSEGV %1

Actual results:
No crash recorded

Expected results:
Crash recorded

Fedora/abrt version affected:
F15 - abrt-2.0.3-2.fc15.x86_64
F16 - abrt-2.0.4-2.fc16.x86_64

Comment 1 Fedora Update System 2011-09-13 15:20:38 UTC
abrt-2.0.4-5.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/abrt-2.0.4-5.fc16

Comment 2 Fedora Update System 2011-09-13 16:02:19 UTC
abrt-2.0.3-4.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/abrt-2.0.3-4.fc15

Comment 3 Fedora Update System 2011-09-13 22:22:09 UTC
Package abrt-2.0.4-5.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing abrt-2.0.4-5.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/abrt-2.0.4-5.fc16
then log in and leave karma (feedback).

Comment 4 Michael Schwendt 2011-09-17 11:49:28 UTC
The provided test update does not fix this issue. At least not the test-case given in the bug report.

/var/log/messages says:

abrtd: Interpreter crashed, but no packaged script detected: 'python'
abrtd: Corrupted or bad dump /var/spool/abrt/ccpp-2011-09-17-13:45:20-2034 (res:2), deleting

Comment 5 Jiri Moskovcak 2011-09-19 07:11:55 UTC
This is actually expected behaviour, in case there is no packaged python script involved there is a big chance, that the crash happened because someone was trying some nasty things which took down the interpreter and in such case we don't want to bother python maintainer with bug report. The test case needs to be updated to reflect this change.

Comment 6 Jiri Moskovcak 2011-09-19 07:22:10 UTC

*** This bug has been marked as a duplicate of bug 739182 ***

Comment 7 Fedora Update System 2011-09-23 20:05:07 UTC
abrt-2.0.4.981-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/abrt-2.0.4.981-1.fc16

Comment 8 Fedora Update System 2011-09-29 23:25:55 UTC
abrt-2.0.3-4.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Miroslav Lichvar 2011-10-03 14:18:27 UTC
*** Bug 728720 has been marked as a duplicate of this bug. ***

Comment 10 Fedora Update System 2011-10-03 18:01:17 UTC
abrt-2.0.4.981-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.