Bug 731264 - Why did anaconda use the plain partition instead of the lvm volume I specified?
Summary: Why did anaconda use the plain partition instead of the lvm volume I specified?
Keywords:
Status: CLOSED DUPLICATE of bug 693095
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 16
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:17213a2fcf934bf4c94933b410e...
: 731480 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-17 08:08 UTC by Flóki Pálsson
Modified: 2014-01-21 23:19 UTC (History)
20 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-26 21:01:51 UTC


Attachments (Terms of Use)

Description Flóki Pálsson 2011-08-17 08:08:21 UTC
abrt version: 2.0.5
executable:     /usr/bin/python
hashmarkername: anaconda
kernel:         3.0.0-1.fc16.x86_64
product:        Fedora
reason:         YumBaseError: Error: rpmdb open failed
time:           Wed Aug 17 08:07:50 2011
version:        16-Alpha

description:
:The following was filed automatically by anaconda:
:anaconda 16.14.6 exception report
:Traceback (most recent call first):
:  File "/usr/lib/python2.7/site-packages/yum/config.py", line 1024, in _getsysver
:    raise Errors.YumBaseError("Error: " + str(e))
:  File "/usr/lib/python2.7/site-packages/yum/config.py", line 879, in readStartupConfig
:    startupconf.releasever = _getsysver(startupconf.installroot, startupconf.distroverpkg)
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 300, in _getConfig
:    startupconf = config.readStartupConfig(fn, root)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/yuminstall.py", line 778, in doConfigSetup
:    yum.YumBase._getConfig(self)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/yuminstall.py", line 362, in setup
:    self.doConfigSetup(root=self.anaconda.rootPath)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/yuminstall.py", line 1240, in doBackendSetup
:    self.ayum.setup()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/backend.py", line 192, in doBackendSetup
:    if anaconda.backend.doBackendSetup(anaconda) == DISPATCH_BACK:
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 348, in dispatch
:    self.dir = self.steps[self.step].target(self.anaconda)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 235, in go_forward
:    self.dispatch()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1198, in nextClicked
:    self.anaconda.dispatch.go_forward()
:YumBaseError: Error: rpmdb open failed

Comment 1 Martin Gracik 2011-08-19 10:55:42 UTC
*** Bug 731480 has been marked as a duplicate of this bug. ***

Comment 2 Terrel Shumway 2011-09-16 07:04:02 UTC
On my system, this happened because anaconda mounted my ubuntu root (/dev/sda5)  on /mnt/sysimage instead of the newly created /dev/vg0/fc16b_root.  Obviously, there was no rpmdb in the debian-based tree.

Now the question is: Why did it use the plain partition instead of the lvm volume I specified?

This happens with boot.iso[1] (x86_64) downloaded on 2011-09-14, but not with Fedora-16-Beta-x86_64-netinst.iso[2]


The first (and second) time this happened was with a bare-metal install.
The third time was in a VirtualBox VM -- it is 100% reproducible.

I can package up the VM if anyone is interested.


1 sha256 = f8a33b002182b559cf5e5c6b01cc18686965fc871712b71ae237feacbc757747
2 sha256 = 89bf5906c68d4e940cae11f4f8d8bad85d591d9a87917e41d1bde8351cf271b4

Comment 3 Terrel Shumway 2011-09-16 07:10:54 UTC
I am pretty sure this is a problem in anaconda, not yum.

Comment 4 David Lehman 2011-09-26 21:01:51 UTC
This should be fixed in the F16 Beta, as you seem to have reported on your own..

I'm not completely certain since there are no logs attached but I suspect this has the same root cause as bug 693095.

If you see this issue in the Beta, please reopen this bug and include the log files from /tmp as attachments.

*** This bug has been marked as a duplicate of bug 693095 ***


Note You need to log in before you can comment on or make changes to this bug.