Bug 734905 - NSISdl.dll is not loadable
Summary: NSISdl.dll is not loadable
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mingw32-nsis
Version: 15
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kevin Kofler
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-31 20:03 UTC by Joel Uckelman
Modified: 2011-09-30 19:22 UTC (History)
3 users (show)

Fixed In Version: mingw32-nsis-2.46-3.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1467717 (view as bug list)
Environment:
Last Closed: 2011-09-18 01:00:06 UTC


Attachments (Terms of Use)

Description Joel Uckelman 2011-08-31 20:03:30 UTC
Description of problem:

The NSISdl.dll which is supplied with mingw32-nsis-2.46-2.fc15.x86_64 cannot be loaded by installers which call NSISdl::download.

I have this in my NSIS build script:

!define JRE_URL "http://javadl.sun.com/webapps/download/AutoDL?BundleId=52247"

StrCpy $0 "$TEMP\jre_installer.exe"
NSISdl::download /TIMEOUT=30000 ${JRE_URL} $0
Pop $R0 ; Get the return value
StrCmp $R0 "success" +3
MessageBox MB_OK "Java download failed: $R0"
Quit

When I build with Fedora's NSIS and run the resulting installer on Windows, I get this as the message above the progress bar:

"Could not load: C:\DOCUME~1\Joel\LOCALS~1\Temp\nsv3.tmp\NSISdl.dll"

When I build with a copy of NSIS 2.46 that I built myself, my download works properly.


Version-Release number of selected component (if applicable):

mingw32-nsis-2.46-2.fc15.x86_64


How reproducible:

Always.

Steps to Reproduce:
1. makensis -NOCD dist/windows/nsis/installer.nsi
2. Run resulting installer in Windows.

Actual results:

Download from installer fails.


Expected results:

Download from installer succeeds.


Additional info:

We have a very complex installer script; I've included only the relevant part. If you need the whole thing, please let me know.

Comment 1 Kevin Kofler 2011-09-08 15:20:32 UTC
Looks like this is linked against the shared libstdc++-6.dll instead of the static libstdc++.a. (Apparently, the default changed in the MinGW g++.) NSIS plugins may not depend on any additional DLLs, we have to link them statically.

Comment 2 Kevin Kofler 2011-09-08 15:29:03 UTC
AFAICT, this also affects Fedora 14, since the 2.46-1.fc14 update from August 11 which was actually built on Fedora 14. It's incredible that nobody found out before.

See also the closed bug #553971, which was about a similar issue with libgcc.

Comment 3 Kevin Kofler 2011-09-08 15:29:43 UTC
(To be clear: The F14 update which first broke this was from August 11, 2010, i.e. more than a year ago.)

Comment 4 Kevin Kofler 2011-09-08 16:10:03 UTC
Patch submitted upstream:
https://sourceforge.net/tracker/?func=detail&aid=3406350&group_id=22049&atid=373087

Comment 5 Fedora Update System 2011-09-08 16:22:08 UTC
mingw32-nsis-2.46-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/mingw32-nsis-2.46-3.fc16

Comment 6 Fedora Update System 2011-09-08 16:23:10 UTC
mingw32-nsis-2.46-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/mingw32-nsis-2.46-3.fc15

Comment 7 Fedora Update System 2011-09-08 16:24:21 UTC
mingw32-nsis-2.46-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/mingw32-nsis-2.46-3.fc14

Comment 8 Fedora Update System 2011-09-09 05:30:00 UTC
Package mingw32-nsis-2.46-3.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mingw32-nsis-2.46-3.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/mingw32-nsis-2.46-3.fc15
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2011-09-18 01:00:01 UTC
mingw32-nsis-2.46-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2011-09-18 01:01:07 UTC
mingw32-nsis-2.46-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2011-09-30 19:22:39 UTC
mingw32-nsis-2.46-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.