Bug 735635 - ibus: follow Fedora packaging guidelines for changelog changes
ibus: follow Fedora packaging guidelines for changelog changes
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
15
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-04 08:26 EDT by Harshula Jayasuriya
Modified: 2012-06-27 20:47 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-27 20:47:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Harshula Jayasuriya 2011-09-04 08:26:28 EDT
Description of problem:

Add a new changelog entry for each new build of ibus instead of removing/modifying existing changelog entries that correspond to previous builds. e.g.
------------------------------------------------------------
commit e0a5e11feee42d68c9fcb7799504de0f2757651f
Author: Takao Fujiwara <tfujiwar@redhat.com>
Date:   Thu Sep 1 15:27:02 2011 +0900

    Bumped to 1.3.99.20110817
    
    Added XIM and ISO 14755 Ctrl+Shift+u

...

@@ -371,13 +365,12 @@ fi
 %{_datadir}/gtk-doc/html/*
 
 %changelog
-* Tue Aug 23 2011 Takao Fujiwara <tfujiwar@redhat.com> - 1.3.99.20110419-18
+* Thu Sep 01 2011 Takao Fujiwara <tfujiwar@redhat.com> - 1.3.99.20110817-1
+- Fixed Bug 700472 Use a symbol icon instead of an image icon.
 - Updated ibus-HEAD.patch for upstream.
 - Removed ibus-435880-surrounding-text.patch as upstream.
 - Added ibus-711632-fedora-fallback-icon.patch
   Fixed SEGV with no icon in oxygen-gtk icon theme.
-- Added ibus-xx-icon-symbol.patch
-  Fixed Bug 700472 Use a symbol icon instead of an image icon.
 - Added ibus-xx-bridge-hotkey.patch
   Triaged Bug 707370 SetEngine timeout
   Fixed Bug 731610 Keep IM state when text input focus changes
------------------------------------------------------------
IBus 1.3.99.20110419-18.fc15 was built (https://admin.fedoraproject.org/updates/ibus-1.3.99.20110419-18.fc15?_csrf_token=853b69f2c5c9a56b8406bba163925d4e6ef8e67d) so the changelog entry should not have been removed/modified.

It's almost impossible to track down when bugs were introduced to IBus since the changelog does not show the real history of the package.

Additional info:

* http://fedoraproject.org/wiki/Packaging:Guidelines#Changelogs
Comment 1 fujiwara 2011-09-04 21:29:45 EDT
The change just bumped the version.
I don't think this is a serious problem.
Comment 2 Jens Petersen 2011-09-07 04:24:35 EDT
I agree with Harshula and would like to see the full changelog entries
restored in future builds.  It is indeed very hard to know what has
changed in each build when the last changelog is just editted.
Comment 3 Akira TAGOH 2012-06-06 04:40:40 EDT
Well, I basically agree with it though, what the purpose are we keeping this open? and what's the corresponding "fix" on this ATM?
Comment 4 Harshula Jayasuriya 2012-06-27 08:06:49 EDT
(In reply to comment #3)
> Well, I basically agree with it though, what the purpose are we keeping this
> open? and what's the corresponding "fix" on this ATM?

The BZ was opened to ensure the Fedora guidelines are followed. You would have to ask Fujiwara the status.
Comment 5 Jens Petersen 2012-06-27 20:47:54 EDT
$ rpm -q --changelog ibus
* Fri Apr 27 2012 Takao Fujiwara <tfujiwar@redhat.com> - 1.4.99.20120428-2
- Updated ibus-HEAD.patch
- Updated ibus-541492-xkb.patch
- Updated ibus-xx-branding-switcher-ui.patch
  Fixed Bug 810211 - Cancel Control + space pressing Control key.
- Updated ibus-xx-no-use.diff
  Enabled to customize trigger keys with non-modifier trigger keys.

* Fri Apr 27 2012 Takao Fujiwara <tfujiwar@redhat.com> - 1.4.99.20120428-1
- Bumped to 1.4.99.20120428
:
:

Looks okay to me, so closing.

Note You need to log in before you can comment on or make changes to this bug.