Bug 737710 - Provide native systemd services
Provide native systemd services
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: rsync (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michal Luscon
Fedora Extras Quality Assurance
:
: 876106 (view as bug list)
Depends On:
Blocks: SysVtoSystemd
  Show dependency treegraph
 
Reported: 2011-09-12 19:14 EDT by Jóhann B. Guðmundsson
Modified: 2013-02-07 06:18 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-03 06:32:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
rsync socket (124 bytes, text/plain)
2011-09-12 19:15 EDT, Jóhann B. Guðmundsson
no flags Details
rsync service (120 bytes, text/plain)
2011-09-12 19:15 EDT, Jóhann B. Guðmundsson
no flags Details

  None (edit)
Description Jóhann B. Guðmundsson 2011-09-12 19:14:30 EDT
Description of problem:

Let's get the ball rolling on this one...

http://fedoraproject.org/wiki/Features/SysVtoSystemd

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jóhann B. Guðmundsson 2011-09-12 19:15:02 EDT
Created attachment 522828 [details]
rsync socket
Comment 2 Jóhann B. Guðmundsson 2011-09-12 19:15:35 EDT
Created attachment 522829 [details]
rsync service
Comment 3 Jóhann B. Guðmundsson 2011-09-12 19:16:08 EDT
Once package and shipped your package should no longer have to depend on xinetd

https://fedoraproject.org/wiki/Packaging:Guidelines:Systemd
https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd
Comment 4 Fedora Admin XMLRPC Client 2012-05-07 05:31:57 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 Graham White 2012-11-13 05:43:09 EST
I have just accidentally raised a dup of this bug, number 876106, before finding this report.  I've made some suggestions in my bug report that might be useful, for convenience I'll past the entire text below.....


Fedora could really do with a more easily configurable rsync when used in daemon mode.  I've recently been setting up Fedora mirrors and using the Fedora guidance, the following seems to be a decent set of options to include

As a default /etc/rsyncd.conf (many options from http://fedoraproject.org/wiki/Infrastructure/Mirroring) :

uid = nobody
gid = nobody
use chroot = yes
max connections = 8
pid file = /var/run/rsyncd.pid
log file = /var/log/rsyncd.log
exclude = lost+found/
transfer logging = yes
timeout = 900
ignore nonreadable = yes
dont compress   = *.gz *.tgz *.zip *.z *.Z *.rpm *.deb *.bz2
refuse options = checksum





As a default systemd.service file (Debian did something similar for systemd last year, see http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=639632) :

[Unit]
Description=A program for synchronizing files over a network
After=syslog.target network.target
ConditionPathExists=/etc/rsyncd.conf

[Service]
EnvironmentFile=-/etc/sysconfig/rsyncd
ExecStart=/usr/bin/rsync --daemon --no-detach "$OPTIONS"

[Install]
WantedBy=multi-user.target





Finally, the environment configuration file /etc/sysconfig/rsyncd :

OPTIONS=""
Comment 6 Michal Luscon 2012-11-13 06:46:37 EST
*** Bug 876106 has been marked as a duplicate of this bug. ***
Comment 7 Michal Luscon 2012-11-13 06:47:44 EST
Hi Graham,

systemd files are prepared and will be included after resolving some minor build issues.

Michal
Comment 8 Michal Luscon 2012-12-03 06:32:20 EST
This bug is now resolved in Fedora rawhide. Please test it and provide your feedback. Any ideas for improvement are highly welcome.

Michal
Comment 9 Graham White 2012-12-03 09:21:16 EST
Looks good.  However, a couple of comments...

Do you not need the EnvironmentFile line in /usr/lib/systemd/system/rsyncd.service ???  Otherwise it wont pick up any user options added to /etc/sysconfig/rsyncd.

There's a typo on line 5 of /etc/rsyncd.conf:

# configuration examlple:
Comment 10 Michal Luscon 2012-12-06 10:47:18 EST
(In reply to comment #9)
> Looks good.  However, a couple of comments...
> 
> Do you not need the EnvironmentFile line in
> /usr/lib/systemd/system/rsyncd.service ???  Otherwise it wont pick up any
> user options added to /etc/sysconfig/rsyncd.
> 
> There's a typo on line 5 of /etc/rsyncd.conf:
> 
> # configuration examlple:

Fixed in rawhide.
Comment 11 dev002 2013-02-05 14:30:23 EST
Where is the packed I can not find it in fedora 18?

yum provides */rsyncd.service
No Matches found
Comment 12 Michal Luscon 2013-02-07 06:18:05 EST
Fedora Rawhide contains updated package - https://fedoraproject.org/wiki/Releases/Rawhide?rd=Rawhide .

Note You need to log in before you can comment on or make changes to this bug.