Bug 876106 - Add systemd service for rsync daemon
Add systemd service for rsync daemon
Status: CLOSED DUPLICATE of bug 737710
Product: Fedora
Classification: Fedora
Component: rsync (Show other bugs)
18
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Michal Luscon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-13 05:34 EST by Graham White
Modified: 2012-11-13 06:46 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-13 06:46:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Graham White 2012-11-13 05:34:53 EST
Fedora could really do with a more easily configurable rsync when used in daemon mode.  I've recently been setting up Fedora mirrors and using the Fedora guidance, the following seems to be a decent set of options to include

As a default /etc/rsyncd.conf (many options from http://fedoraproject.org/wiki/Infrastructure/Mirroring) :

uid = nobody
gid = nobody
use chroot = yes
max connections = 8
pid file = /var/run/rsyncd.pid
log file = /var/log/rsyncd.log
exclude = lost+found/
transfer logging = yes
timeout = 900
ignore nonreadable = yes
dont compress   = *.gz *.tgz *.zip *.z *.Z *.rpm *.deb *.bz2
refuse options = checksum





As a default systemd.service file (Debian did something similar for systemd last year, see http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=639632) :

[Unit]
Description=A program for synchronizing files over a network
After=syslog.target network.target
ConditionPathExists=/etc/rsyncd.conf

[Service]
EnvironmentFile=-/etc/sysconfig/rsyncd
ExecStart=/usr/bin/rsync --daemon --no-detach "$OPTIONS"

[Install]
WantedBy=multi-user.target





Finally, the environment configuration file /etc/sysconfig/rsyncd :

OPTIONS=""
Comment 1 Graham White 2012-11-13 05:42:03 EST
Whoops, looks like this might be a dup of 737710, which of course I only find after raising this one.  Hopefully, my suggestions above are of some use though.
Comment 2 Michal Luscon 2012-11-13 06:46:37 EST

*** This bug has been marked as a duplicate of bug 737710 ***

Note You need to log in before you can comment on or make changes to this bug.