Bug 739422 - Translation Editor: editor should stay open after page changes
Summary: Translation Editor: editor should stay open after page changes
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Zanata
Classification: Retired
Component: Component-UI
Version: 1.7
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 2.0
Assignee: Alex Eng
QA Contact: Ding-Yi Chen
URL:
Whiteboard:
: 740166 (view as bug list)
Depends On: 733581
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-19 01:07 UTC by Alex Eng
Modified: 2013-02-27 08:10 UTC (History)
4 users (show)

Fixed In Version: 1.7.4-SNAPSHOT (20120928-0009)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-27 08:10:32 UTC


Attachments (Terms of Use)
screenshot of the next page (36.17 KB, image/png)
2012-07-31 03:14 UTC, Runa Bhattacharjee
no flags Details

Description Alex Eng 2011-09-19 01:07:18 UTC
Description of problem:


Version-Release number of selected component (if applicable):
1.4-SNAPSHOT

How reproducible:
Always

Steps to Reproduce:
1. Go to Translation editor
2. Go to last entry of the page, enter "hi"
3. Hit Alt + Down arrow
4. View will change to next page with last changes saved. But text area not focus on the first entry.
5. Same goes if changes made on first entry on second page and hit Alt+Up arrow.
  
Actual results:
First or last entry of the text area not focused.

Expected results:
First or last entry of the text area opened and focused.

Comment 1 Ding-Yi Chen 2011-09-23 04:15:51 UTC
*** Bug 740166 has been marked as a duplicate of this bug. ***

Comment 2 Sean Flanigan 2011-09-23 04:22:08 UTC
Note that the editor on the new page is not just unfocussed, it is not open at all.

Comment 3 Sean Flanigan 2011-09-23 04:28:42 UTC
After consulting with Runa, since this bug has a workaround, I'm removing from the dependency tree for the zanata 1.4 release blocker bug.

Comment 6 Runa Bhattacharjee 2012-07-30 13:59:30 UTC
This is still a problem. Request for technical evaluation.

Comment 7 Alex Eng 2012-07-30 22:28:21 UTC
Runa, 

Can't seems to reproduce the problem now with version 1.7. Can you confirm if the problem still there? Which firefox version you tested on?

Comment 8 Runa Bhattacharjee 2012-07-31 03:13:18 UTC
I tested with firefox 14. To confirm, the editor page opens but the first string on the next page was not in focus. I had to manually click it open.

Comment 9 Runa Bhattacharjee 2012-07-31 03:14:01 UTC
Created attachment 601414 [details]
screenshot of the next page

Comment 10 Ding-Yi Chen 2012-09-28 02:20:36 UTC
VERIFIED with Zanata version 1.7.4-SNAPSHOT (20120928-0009)
and Zanata version 1.8.0-SNAPSHOT (20120928-0032)


Note You need to log in before you can comment on or make changes to this bug.