Bug 740625 - After update to 3.1.92, can't submit password on login window
Summary: After update to 3.1.92, can't submit password on login window
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
: 740685 744420 746050 746132 (view as bug list)
Depends On:
Blocks: F16Blocker, F16FinalBlocker 746132
TreeView+ depends on / blocked
 
Reported: 2011-09-22 17:50 UTC by Charles R. Anderson
Modified: 2011-10-20 19:22 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 746132 (view as bug list)
Environment:
Last Closed: 2011-10-20 19:22:24 UTC


Attachments (Terms of Use)
messages from the failed login attempt (17.00 KB, text/plain)
2011-09-26 02:52 UTC, Charles R. Anderson
no flags Details
at-spi2-registryd gdb backtrace after hitting enter key (9.82 KB, text/plain)
2011-09-26 02:57 UTC, Charles R. Anderson
no flags Details
gdm :0-greeter.log from failed login attempt (21.88 KB, text/plain)
2011-09-29 01:49 UTC, Charles R. Anderson
no flags Details
gdm :0-slave.log from failed login attempt (50.48 KB, text/plain)
2011-09-29 01:49 UTC, Charles R. Anderson
no flags Details

Description Charles R. Anderson 2011-09-22 17:50:12 UTC
Description of problem:

After updating to GNOME 3.1.92, I can no longer login via GDM.  After selecting my username from the list and typing my password, neither the Enter key nor clicking the Sign In button works.  There is no visual change when attempting this--it acts like the Enter key hasn't been typed or Sign In button hasn't been clicked.

Version-Release number of selected component (if applicable):
gdm-3.1.92-1.fc16.x86_64


How reproducible:
always

Steps to Reproduce:
1. Reboot
2. Attempt to log in
  
Actual results:

Nothing happens after typing the password to an account and hitting Enter or clicking Sign In.

Expected results:

A successful login to GNOME.

Additional info:

Comment 1 Charles R. Anderson 2011-09-22 17:58:27 UTC
There are no .xsession-errors or SELinux AVCs appearing when attempting to log in.  There are these messages from /var/log/messages:


Sep 22 13:54:57 t gnome-session[1619]: DEBUG(+): GsmDBusClient: obj_path=/org/freedesktop/DBus interface=org.freedesktop.DBus method=NameOwnerChanged
Sep 22 13:54:57 t gnome-session[1619]: DEBUG(+): GsmDBusClient: obj_path=/org/freedesktop/DBus interface=org.freedesktop.DBus method=NameOwnerChanged
Sep 22 13:54:57 t pulseaudio[1677]: module-alsa-card.c: Failed to find a working profile.
Sep 22 13:54:57 t pulseaudio[1677]: module.c: Failed to load  module "module-alsa-card" (argument: "device_id="29" name="platform-thinkpad_acpi" card_name="alsa_card.platform-thinkpad_acpi" tsched=yes ignore_dB=no card_properties="module-udev-detect.discovered=1""): initialization failed.
Sep 22 13:54:57 t gnome-session[1619]: DEBUG(+): GsmDBusClient: obj_path=/org/freedesktop/DBus interface=org.freedesktop.DBus method=NameOwnerChanged
Sep 22 13:54:57 t gnome-session[1619]: DEBUG(+): GsmDBusClient: obj_path=/org/freedesktop/DBus interface=org.freedesktop.DBus method=NameOwnerChanged

Comment 2 Charles R. Anderson 2011-09-22 18:01:55 UTC
I tried downgrading to gdm-3.1.90-1, no change.
I upgraded again to gdm-3.1.92-1 and downgraded just gnome-session-3.1.91-3, no change.

I currently have these packages from the upgrade set:


Sep 21 23:27:13 Updated: 1:NetworkManager-glib-0.9.1.90-1.fc16.x86_64
Sep 21 23:27:13 Updated: 1:NetworkManager-0.9.1.90-1.fc16.x86_64
Sep 21 23:27:13 Installed: 1:NetworkManager-gtk-0.9.1.90-1.fc16.x86_64
Sep 21 23:27:14 Updated: 1:NetworkManager-gnome-0.9.1.90-1.fc16.x86_64
Sep 21 23:30:19 Updated: glib2-2.29.92-1.fc16.x86_64
Sep 21 23:30:20 Updated: atk-2.1.92-1.fc16.x86_64
Sep 21 23:30:20 Updated: gtk3-3.1.92-1.fc16.x86_64
Sep 21 23:30:20 Updated: json-glib-0.14.0-1.fc16.x86_64
Sep 21 23:30:21 Updated: cogl-1.8.0-1.fc16.x86_64
Sep 21 23:30:21 Updated: gobject-introspection-1.30.0-1.fc16.x86_64
Sep 21 23:30:21 Updated: clutter-1.8.0-1.fc16.x86_64
Sep 21 23:30:21 Updated: libgnome-keyring-3.1.92-1.fc16.x86_64
Sep 21 23:30:21 Updated: clutter-gtk-1.0.2-4.fc16.x86_64
Sep 21 23:30:22 Updated: 1:libreoffice-ure-3.4.3.2-10.fc16.x86_64
Sep 21 23:30:22 Updated: clutter-gst-1.3.14-2.fc16.x86_64
Sep 21 23:30:22 Updated: poppler-0.17.3-1.fc16.x86_64
Sep 21 23:30:22 Updated: libmx-1.3.1-2.fc16.x86_64
Sep 21 23:30:22 Updated: poppler-glib-0.17.3-1.fc16.x86_64
Sep 21 23:30:22 Updated: liberation-fonts-common-1.07.1-1.fc16.noarch
Sep 21 23:30:22 Updated: 1:control-center-filesystem-3.1.92-1.fc16.x86_64
Sep 21 23:30:23 Updated: evince-libs-3.1.90-2.fc16.x86_64
Sep 21 23:30:23 Updated: dconf-0.9.1-1.fc16.x86_64
Sep 21 23:30:23 Updated: gnome-menus-3.1.92-1.fc16.x86_64
Sep 21 23:30:23 Updated: gjs-1.29.18-1.fc16.x86_64
Sep 21 23:30:23 Updated: polkit-gnome-0.103-1.fc16.x86_64
Sep 21 23:30:23 Updated: 2:gimp-libs-2.6.11-22.fc16.x86_64
Sep 21 23:30:24 Updated: at-spi2-core-2.1.92-1.fc16.x86_64
Sep 21 23:30:24 Updated: pyatspi-2.1.91-1.fc16.noarch
Sep 21 23:30:24 Updated: openldap-2.4.26-4.fc16.x86_64
Sep 21 23:30:24 Updated: GConf2-3.1.92-1.fc16.x86_64
Sep 21 23:30:25 Updated: gnome-session-3.1.92-1.fc16.x86_64
Sep 21 23:30:25 Updated: gnome-session-xsession-3.1.92-1.fc16.x86_64
Sep 21 23:30:25 Updated: mutter-3.1.92-1.fc16.x86_64
Sep 21 23:30:25 Updated: gnome-panel-libs-3.1.92-1.fc16.x86_64
Sep 21 23:30:26 Updated: caribou-0.3.92-1.fc16.x86_64
Sep 21 23:30:26 Updated: at-spi2-atk-2.1.92-1.fc16.x86_64
Sep 21 23:30:29 Updated: 2:gimp-2.6.11-22.fc16.x86_64
Sep 21 23:30:32 Updated: evince-3.1.90-2.fc16.x86_64
Sep 21 23:30:33 Updated: liberation-mono-fonts-1.07.1-1.fc16.noarch
Sep 21 23:30:34 Updated: liberation-serif-fonts-1.07.1-1.fc16.noarch
Sep 21 23:30:35 Updated: liberation-sans-fonts-1.07.1-1.fc16.noarch
Sep 21 23:30:36 Updated: 1:totem-3.1.92-1.fc16.x86_64
Sep 21 23:30:36 Updated: adwaita-gtk3-theme-3.1.92-1.fc16.x86_64
Sep 21 23:30:36 Updated: libwnck3-3.1.92-1.fc16.x86_64
Sep 21 23:30:36 Updated: 1:gnome-utils-libs-3.1.92-1.fc16.x86_64
Sep 21 23:30:37 Updated: glib-networking-2.29.92-1.fc16.x86_64
Sep 21 23:30:37 Updated: libsoup-2.35.92-1.fc16.x86_64
Sep 21 23:30:37 Updated: gnome-online-accounts-3.1.91-1.fc16.x86_64
Sep 21 23:30:37 Updated: libchamplain-0.12.0-1.fc16.x86_64
Sep 21 23:30:40 Updated: gnome-user-docs-3.1.1-1.fc16.noarch
Sep 21 23:30:40 Updated: checkpolicy-2.1.3-1.2.fc16.x86_64
Sep 21 23:30:51 Updated: selinux-policy-3.10.0-32.fc16.noarch
Sep 21 23:30:51 Updated: yelp-xsl-3.1.6-1.fc16.noarch
Sep 21 23:30:51 Updated: 1:yelp-libs-3.1.4-1.fc16.x86_64
Sep 21 23:30:51 Updated: 1:yelp-3.1.4-1.fc16.x86_64
Sep 21 23:30:51 Updated: adwaita-cursor-theme-3.1.92-1.fc16.noarch
Sep 21 23:30:51 Updated: 1:autocorr-en-3.4.3.2-10.fc16.noarch
Sep 21 23:30:52 Updated: p11-kit-0.6-1.fc16.x86_64
Sep 21 23:30:52 Updated: gnome-keyring-3.1.92-1.fc16.x86_64
Sep 21 23:30:52 Updated: gnome-keyring-pam-3.1.92-1.fc16.x86_64
Sep 21 23:30:52 Updated: adwaita-gtk2-theme-3.1.92-1.fc16.x86_64
Sep 21 23:30:53 Updated: gnome-themes-standard-3.1.92-1.fc16.x86_64
Sep 21 23:30:54 Updated: gnome-desktop3-3.1.92-1.fc16.x86_64
Sep 21 23:30:54 Updated: gnome-settings-daemon-3.1.92-1.fc16.x86_64
Sep 21 23:30:55 Updated: nautilus-3.1.92-1.fc16.x86_64
Sep 21 23:30:55 Updated: nautilus-extensions-3.1.92-1.fc16.x86_64
Sep 21 23:30:56 Updated: 1:cheese-libs-3.1.92-1.fc16.x86_64
Sep 21 23:30:58 Updated: 1:control-center-3.1.92-1.fc16.x86_64
Sep 21 23:30:58 Updated: file-roller-3.1.92-1.fc16.x86_64
Sep 21 23:30:59 Updated: 1:gdm-3.1.92-1.fc16.x86_64
Sep 21 23:31:00 Updated: gnome-shell-3.1.92-1.fc16.x86_64
Sep 21 23:31:01 Updated: 1:libreoffice-opensymbol-fonts-3.4.3.2-10.fc16.noarch
Sep 21 23:31:15 Updated: 1:libreoffice-core-3.4.3.2-10.fc16.x86_64
Sep 21 23:31:16 Updated: 1:libreoffice-presenter-screen-3.4.3.2-10.fc16.x86_64
Sep 21 23:31:17 Updated: 1:libreoffice-impress-3.4.3.2-10.fc16.x86_64
Sep 21 23:31:17 Updated: 1:libreoffice-graphicfilter-3.4.3.2-10.fc16.x86_64
Sep 21 23:31:17 Updated: 1:libreoffice-pdfimport-3.4.3.2-10.fc16.x86_64
Sep 21 23:31:17 Updated: 1:libreoffice-draw-3.4.3.2-10.fc16.x86_64
Sep 21 23:31:18 Updated: 1:libreoffice-calc-3.4.3.2-10.fc16.x86_64
Sep 21 23:31:18 Updated: 1:libreoffice-xsltfilter-3.4.3.2-10.fc16.x86_64
Sep 21 23:31:19 Updated: 1:libreoffice-writer-3.4.3.2-10.fc16.x86_64
Sep 21 23:31:20 Updated: 1:libreoffice-math-3.4.3.2-10.fc16.x86_64
Sep 21 23:31:20 Updated: 1:libreoffice-langpack-en-3.4.3.2-10.fc16.x86_64
Sep 21 23:31:21 Updated: gnome-panel-3.1.92-1.fc16.x86_64
Sep 21 23:31:21 Updated: 1:gdm-plugin-fingerprint-3.1.92-1.fc16.x86_64
Sep 21 23:31:21 Updated: file-roller-nautilus-3.1.92-1.fc16.x86_64
Sep 21 23:31:23 Updated: orca-3.1.92-1.fc16.x86_64
Sep 21 23:31:23 Updated: 1:cheese-3.1.92-1.fc16.x86_64
Sep 21 23:31:23 Updated: 1:totem-nautilus-3.1.92-1.fc16.x86_64
Sep 21 23:31:23 Updated: evince-nautilus-3.1.90-2.fc16.x86_64
Sep 21 23:31:23 Updated: gnome-power-manager-3.1.92-1.fc16.x86_64
Sep 21 23:31:25 Updated: eog-3.1.92-1.fc16.x86_64
Sep 21 23:31:25 Updated: gnome-contacts-0.1.5.2-1.fc16.x86_64
Sep 21 23:31:25 Updated: gnome-screensaver-3.1.92-1.fc16.x86_64
Sep 21 23:31:26 Updated: seahorse-3.1.92-1.fc16.x86_64
Sep 21 23:31:26 Updated: simple-scan-3.1.91-1.fc16.x86_64
Sep 21 23:31:29 Updated: selinux-policy-targeted-3.10.0-32.fc16.noarch
Sep 21 23:31:29 Updated: libchamplain-gtk-0.12.0-1.fc16.x86_64
Sep 21 23:31:29 Updated: 2:gimp-help-browser-2.6.11-22.fc16.x86_64
Sep 21 23:31:29 Updated: sushi-0.1.92-2.fc16.x86_64
Sep 21 23:31:30 Updated: rhythmbox-2.90.1-16.git20110829.fc16.x86_64
Sep 21 23:31:31 Updated: libgdata-0.10.1-1.fc16.x86_64
Sep 21 23:31:31 Updated: vino-3.1.92-1.fc16.x86_64
Sep 21 23:31:31 Updated: tracker-0.12.1-2.fc16.x86_64
Sep 21 23:31:33 Updated: 1:gnome-utils-3.1.92-1.fc16.x86_64
Sep 21 23:31:33 Updated: GConf2-gtk-3.1.92-1.fc16.x86_64
Sep 21 23:31:34 Updated: 1:gnome-games-3.1.92-1.fc16.x86_64
Sep 21 23:31:34 Updated: gucharmap-3.1.92-1.fc16.x86_64
Sep 21 23:31:35 Updated: gnome-color-manager-3.1.92-2.fc16.x86_64
Sep 21 23:31:38 Updated: inkscape-0.48.1-8.fc16.x86_64
Sep 21 23:31:39 Updated: liberation-narrow-fonts-1.07.1-1.fc16.noarch
Sep 21 23:31:39 Updated: poppler-utils-0.17.3-1.fc16.x86_64
Sep 21 23:31:39 Updated: 1:totem-mozplugin-3.1.92-1.fc16.x86_64
Sep 21 23:31:40 Updated: vinagre-3.1.92-1.fc16.x86_64
Sep 21 23:31:42 Updated: gnome-packagekit-3.1.92-2.fc16.x86_64
Sep 21 23:31:42 Updated: gtk3-immodule-xim-3.1.92-1.fc16.x86_64
Sep 21 23:31:43 Updated: glib2-devel-2.29.92-1.fc16.x86_64
Sep 21 23:31:43 Updated: dracut-013-12.fc16.noarch
Sep 21 23:31:43 Updated: 2:vim-minimal-7.3.315-1.fc16.x86_64
Sep 21 23:31:44 Updated: glib2-2.29.92-1.fc16.i686
Sep 21 23:31:44 Updated: openldap-2.4.26-4.fc16.i686
Sep 22 08:29:16 Updated: dracut-013-12.1.fc16.noarch
Sep 22 08:48:27 Updated: 1:folks-0.6.3-2.fc16.x86_64
Sep 22 08:49:58 Updated: 1:yelp-libs-3.1.4-2.fc16.x86_64
Sep 22 08:49:58 Updated: 1:yelp-3.1.4-2.fc16.x86_64
Sep 22 08:50:58 Installed: 1:gdm-3.1.90-1.fc16.x86_64
Sep 22 08:50:58 Installed: 1:gdm-plugin-fingerprint-3.1.90-1.fc16.x86_64
Sep 22 08:58:15 Updated: 1:gdm-3.1.92-1.fc16.x86_64
Sep 22 08:58:15 Updated: 1:gdm-plugin-fingerprint-3.1.92-1.fc16.x86_64
Sep 22 09:00:05 Installed: gnome-session-3.1.91-3.fc16.x86_64
Sep 22 09:00:05 Installed: gnome-session-xsession-3.1.91-3.fc16.x86_64
Sep 22 09:01:09 Updated: gnome-session-3.1.92-1.fc16.x86_64
Sep 22 09:01:09 Updated: gnome-session-xsession-3.1.92-1.fc16.x86_64

Comment 3 Charles R. Anderson 2011-09-22 18:09:21 UTC
Choosing "Not listed?" and then typing my username/password works.

Comment 4 Charles R. Anderson 2011-09-22 22:58:51 UTC
*** Bug 740685 has been marked as a duplicate of this bug. ***

Comment 5 Steve 2011-09-23 10:51:42 UTC
I can't even see the login-box.

Comment 6 Charles R. Anderson 2011-09-24 13:59:17 UTC
gtk3-3.1.92-2.fc16.x86_64
at-spi2-atk-2.1.92-2.fc16.x86_64
at-spi-1.32.0-5.fc16.x86_64
at-spi2-core-2.1.92-1.fc16.x86_64
gtk3-immodule-xim-3.1.92-2.fc16.x86_64

No improvement with the above packages.

Comment 7 Matthias Clasen 2011-09-25 20:16:05 UTC
(In reply to comment #5)
> I can't even see the login-box.

If you can't see the login box, this is not your bug

Comment 8 igor.redhat@gmail.com 2011-09-25 21:00:00 UTC
I have the same issue - gdm shows the login screen but no further actions can be taken there, i.e., clicking on the usernames or "not listed" does nothing. However, downgrading gdm and gdm-plugin-fingerprint to 3.1.90 did produce a working gdm login prompt my case. All other installed packages are fully up-to-date as of now:

$ yum list updates
Loaded plugins: auto-update-debuginfo, langpacks, presto, refresh-packagekit, verify
Updated Packages
gdm.x86_64                                         1:3.1.92-1.fc16                       updates-testing
gdm-plugin-fingerprint.x86_64                      1:3.1.92-1.fc16                       updates-testing
$

Comment 9 Charles R. Anderson 2011-09-26 02:52:36 UTC
Created attachment 524830 [details]
messages from the failed login attempt

Comment 10 Charles R. Anderson 2011-09-26 02:57:55 UTC
Created attachment 524831 [details]
at-spi2-registryd gdb backtrace after hitting enter key

Comment 11 Ray Strode [halfline] 2011-09-26 17:39:41 UTC
Hey Charles,

Can you set Enable=true in the [debug] section of /etc/gdm/custom.conf try to log in, reproduce, then attach /var/log/gdm/\:0-greeter.log and /var/log/gdm/\:0-slave.log ?

This sounds and awful lot like at-spi-atk bug that was fixed, but the logs would help clarify.

Comment 12 igor.redhat@gmail.com 2011-09-26 18:39:29 UTC
FWIW, I've upgraded back to gdm 3.1.92-1 and everything seems to be working fine for me now. My atk-spi2-atk is at 2.1.92-2.

Comment 13 Steve 2011-09-27 20:27:24 UTC
(In reply to comment #7)
> (In reply to comment #5)
> > I can't even see the login-box.
> 
> If you can't see the login box, this is not your bug

I made a new bug report: https://bugzilla.redhat.com/show_bug.cgi?id=741770

Comment 14 Charles R. Anderson 2011-09-29 01:49:16 UTC
Created attachment 525426 [details]
gdm :0-greeter.log from failed login attempt

Comment 15 Charles R. Anderson 2011-09-29 01:49:53 UTC
Created attachment 525427 [details]
gdm :0-slave.log from failed login attempt

Comment 16 Tim Flink 2011-10-03 17:01:26 UTC
Discussed in the 2011-09-30 blocker bug review meeting. Accepted as a Fedora 16 final blocker as it violates the following alpha release criterion [1]:

Following on from the previous criterion, after firstboot is completed and on subsequent boots, a system installed according to any of the above criteria (or the appropriate Beta or Final criteria, when applying this criterion to those releases) must boot to a working graphical environment without unintended user intervention. This includes correctly accessing any encrypted partitions when the correct passphrase is supplied.

[1] https://fedoraproject.org/wiki/Fedora_16_Alpha_Release_Criteria

Comment 17 Michael Stahl 2011-10-07 10:45:07 UTC
have had the same problem.

at-spi2-atk-2.2.0-1.fc16.x86_64

i believe gdm was 3.2.0-1.fc16.x86_64 but i had to uninstall it...

Comment 18 John L Magee 2011-10-08 22:47:54 UTC
yum remove *fingerprint* seems to have resolved this for me

Comment 19 Matthias Clasen 2011-10-13 20:04:28 UTC
I believe the a11y issue on the login screen has been resolved in current updates.
The fingerprint issue should be tracked in a separate bug.
I would tend to just close this bug as fixed, unless there are people here who still see a11y-related hangs on the login screen.

Comment 20 Charles R. Anderson 2011-10-13 20:21:24 UTC
No need to open a separate bug.  Reassigning to gdm for the gdm-fingerprint-plugin, since that component seems to be related to the cause of the problem "cannot submit password on login window" which is the reason I opened this bug in the first place.  Removing "yum remove gdm-fingerprint-plugin" solves the problem for me.

Comment 21 Matthias Clasen 2011-10-14 00:16:55 UTC
No. Please file a new bug.

Repurposing bugs like that messes up history and only confuses everybody involved.

Comment 22 Adam Williamson 2011-10-14 02:55:17 UTC
mclasen: it was charles who filed the bug in the first place, and he's seemingly had the same problem all along. it was other reporters who confused the issue.

Comment 23 Adam Williamson 2011-10-14 19:25:33 UTC
*** Bug 746132 has been marked as a duplicate of this bug. ***

Comment 24 Erinn Looney-Triggs 2011-10-14 20:20:42 UTC
*** Bug 746050 has been marked as a duplicate of this bug. ***

Comment 25 Adam Williamson 2011-10-20 16:36:01 UTC
https://bugzilla.redhat.com/show_bug.cgi?id=744420 looks like a possible dupe of this, and claims gnome-settings-daemon 3.2.1 fixes this. Charles, can you please re-test with gnome 3.2.1? Thanks!

Comment 26 Charles R. Anderson 2011-10-20 19:16:30 UTC
Indeed, 3.2.1 fixes the problem.  Thanks!

Comment 27 Charles R. Anderson 2011-10-20 19:17:09 UTC
*** Bug 744420 has been marked as a duplicate of this bug. ***

Comment 28 Adam Williamson 2011-10-20 19:22:24 UTC
Okay, the 3.2.1 update went stable, so let's close this.


Note You need to log in before you can comment on or make changes to this bug.