Bug 74187 - traceback when invoked
traceback when invoked
Status: CLOSED DUPLICATE of bug 74311
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-nfs (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
: 75173 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-17 12:01 EDT by Gene Czarcinski
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-11 14:23:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
my /etc/exports file (586 bytes, text/plain)
2002-09-17 12:19 EDT, Gene Czarcinski
no flags Details

  None (edit)
Description Gene Czarcinski 2002-09-17 12:01:21 EDT
Description of Problem:
When I try to run redhat-config-nfs I get a traceback.

Traceback (most recent call last):
  File "/usr/share/redhat-config-nfs/redhat-config-nfs.py", line 29, in ?
    mainWindow.mainWindow()
  File "/usr/share/redhat-config-nfs/mainWindow.py", line 141, in __init__
    self.exports = nfsBackend.NfsBackend()
  File "/usr/share/redhat-config-nfs/nfsBackend.py", line 31, in __init__
    self.parseFile()
  File "/usr/share/redhat-config-nfs/nfsBackend.py", line 89, in parseFile
    hostname, options = string.split(tokens[1], "(")
IndexError: list index out of range

Version-Release number of selected component (if applicable):
Release 8.0, redhat-config-nfs-1.0.1-3

How Reproducible:
every time
Comment 1 Gene Czarcinski 2002-09-17 12:18:39 EDT
OK, some additional information --- it crashes with my original /etc/exports
file.  If I let it create one then it works.  I am attaching my /exports file.

BTW, I do not see how to add the options I had specified with the
redhat-config-nfs program.
Comment 2 Gene Czarcinski 2002-09-17 12:19:24 EDT
Created attachment 76405 [details]
my /etc/exports file
Comment 3 Gene Czarcinski 2002-09-17 12:50:42 EDT
Now that I RTFM, I do not see what was "wrong" with my original "hand crafter"
etc/exports file.  My BTW comment about should be ignored.
Comment 4 Brent Fox 2002-09-30 16:15:36 EDT
Changing component from 4Suite to redhat-config-nfs
Comment 5 Brent Fox 2002-10-07 11:57:29 EDT
*** Bug 75173 has been marked as a duplicate of this bug. ***
Comment 6 Need Real Name 2002-10-11 14:23:29 EDT
Hi,

I've found some other problems with this NFS Server Configuration GUI.

The specific problem listed above is the result of the GUI parsing a blank/empty
line.  

I'll file another bug for the other problem I found (parsing multiple machines
per export).
Comment 7 Brent Fox 2002-10-14 16:53:02 EDT

*** This bug has been marked as a duplicate of 74311 ***

Note You need to log in before you can comment on or make changes to this bug.