Bug 74311 - improperly written host IPs cause cause application parse errors.
Summary: improperly written host IPs cause cause application parse errors.
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-nfs (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Keywords:
: 74187 75739 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-20 06:03 UTC by bman
Modified: 2007-04-18 16:46 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-03 22:15:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to nfsBackend to properly parse exports file (4.65 KB, patch)
2003-06-05 00:21 UTC, Michael Kenney
no flags Details | Diff

Description bman 2002-09-20 06:03:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020809

Description of problem:
If a person misenters the data in the hosts box for a share, subsequent attempts
to start redhat-config-nfs will fail.  Once /etc/exports has has been corrected
the problem goes away.  

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Create a share
2.under hosts list something inapropriate like several IP addresses separated by
semicolons (don't ask)  The error can also be recreated with an extra newline at
the end of the /etc/exports file.
3.save and quit
	

Actual Results:  # redhat-config-nfs
Traceback (most recent call last):
  File "/usr/share/redhat-config-nfs/redhat-config-nfs.py", line 29, in ?
    mainWindow.mainWindow()
  File "/usr/share/redhat-config-nfs/mainWindow.py", line 141, in __init__
    self.exports = nfsBackend.NfsBackend()
  File "/usr/share/redhat-config-nfs/nfsBackend.py", line 30, in __init__
    self.parseFile()
  File "/usr/share/redhat-config-nfs/nfsBackend.py", line 88, in parseFile
    hostname, options = string.split(tokens[1], "(")
ValueError: unpack list of wrong size


Expected Results:  the application should have started and let me correct the
host list.

Additional info:

Comment 1 Brent Fox 2002-09-30 20:21:15 UTC
Ok, I'll take a look at this.  My parser for /etc/exports could be much better
overall, so there's some work to be done here.

Comment 2 Brent Fox 2002-10-14 20:52:25 UTC
*** Bug 75739 has been marked as a duplicate of this bug. ***

Comment 3 Brent Fox 2002-10-14 20:52:56 UTC
*** Bug 74187 has been marked as a duplicate of this bug. ***

Comment 4 Michael Kenney 2003-06-05 00:21:14 UTC
Created attachment 92150 [details]
patch to nfsBackend to properly parse exports file

This bug is still present in RH9.  This patch seems to fix the problem.

Comment 5 Brent Fox 2003-09-03 22:15:14 UTC
Should be fixed with redhat-config-nfs-1.0.11 in Rawhide.


Note You need to log in before you can comment on or make changes to this bug.