Bug 742207 - No usable bootloader option during a text mode f15->f16 upgrade
No usable bootloader option during a text mode f15->f16 upgrade
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
https://fedoraproject.org/wiki/Common...
: CommonBugs, Reopened
: 800403 (view as bug list)
Depends On: 804483
Blocks: F17Beta/F17BetaBlocker
  Show dependency treegraph
 
Reported: 2011-09-29 07:51 EDT by Adam Williamson
Modified: 2012-03-26 16:23 EDT (History)
8 users (show)

See Also:
Fixed In Version: anaconda-17.14-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-26 16:23:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2011-09-29 07:51:21 EDT
When you do a text mode upgrade from f15 to f16, you don't get any workable bootloader choice.

You only get two options: "skip bootloader" and "update bootloader". There is a hidden third option: you can proceed without checking either.

"skip bootloader" does what it says on the tin, and doesn't touch the bootloader, which is fine and all, but not what we want in most cases and usually results in a non-booting system.

"update bootloader" you can't proceed with, anaconda refuses to let you.

if you pick neither, on reboot, you wind up at a grub prompt, according to mkrizek (my test is still finishing up).

several issues here:

* "update bootloader" should be 'greyed out' somehow so you can't even try to choose it (maybe just don't list it at all)

* it should not be possible to proceed without selecting one option or another

* most importantly, "install new bootloader" should be present and should be the default, as is the case for graphical upgrade

Proposing as Beta blocker just so we have something to talk about at the go/no-go tomorrow. But text-mode upgrade isn't explicitly in the Beta criteria, and I would be okay with punting to Final.
Comment 1 Tim Flink 2011-09-30 11:20:41 EDT
Discussed in the 2011-09-29 go/no-go meeting. Rejected as a blocker for Fedora 16 beta because it doesn't directly hit any of the beta release criteria, isn't the most common upgrade path and can be worked around.

The potential workarounds (use graphical upgrade, manually fix bootloader) will be better documented soon.
Comment 2 Kamil Páral 2011-10-31 09:59:19 EDT
I wanted to test "skip bootloader" option in text mode, but I didn't recognize that the option is not selected and I continued with no option selected. I ended with a clean grub2 prompt (no menu items installed, old menu items erased). It is quite hard to get the system to a usable state at this point.

Please note that I wanted to use "Skip bootloader", but my bootloader got re-installed instead! That's a fault of broken UI, where:
1) I couldn't recognize what option is selected
2) It allowed me to continue with no option selected
3) It did something completely else then presented options (I was presented by unselectable "Update bootloader", selectable "Skip bootloader", but I ended up with new and unpopulated bootloader).

The problem is not that some upgrade paths are not supported in anaconda text mode. That's fine. The problem is that user data might get erased just because of confusing UI.

Do we want to reconsider this as a blocker? I believe it could be appropriate. Simple UI fix is enough to correct this issue.
Comment 3 Kamil Páral 2011-10-31 10:50:02 EDT
Note: I tried it again, this time properly selecting "skip bootloader configuration". Everything worked as expected in that case, the bootloader was not touched.
Comment 4 Adam Williamson 2012-01-23 14:48:06 EST
I'm bumping this to Rawhide and proposing it again as a blocker, really just to get it above the attention line. Since we're using old-installer for F17, we really ought to fix this.

Things are somewhat complicated in the F17 case as what we want to do when upgrading from F16, and what we want to do when upgrading from F15, are different. This applies to graphical as well as text. Text may 'just work' again in F17 if we re-enable the 'update bootloader configuration' option, for upgrades from F16 at least.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Tim Flink 2012-01-27 10:21:07 EST
removing rejected blocker from whiteboard because that was for F16
Comment 6 Adam Williamson 2012-01-27 12:35:56 EST
Discussed at 2012-01-27 blocker review meeting. Agreed that this is a blocker per beta criterion "The installer must be able to successfully complete an upgrade installation from a clean, fully updated default installation (from any official install medium) of the previous stable Fedora release, either via preupgrade or by booting to the installer manually. The upgraded system must meet all release criteria" . We don't necessarily require text upgrade functionality to be *fixed* by beta, but if it is not fixed, it should be disabled: you must not be able to proceed down a path that leaves the system broken.

Note the complications mentioned in comment #4.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Brian Lane 2012-03-07 15:40:58 EST
Try this update image:
http://bcl.fedorapeople.org/updates/742207.img

Tested on a F16 to F17 upgrade using Beta TC1. System had a separate /usr LVM as well. It properly upgraded the dracut kernel params and rebooted into F17.
Comment 8 Brian Lane 2012-03-08 20:33:02 EST
*** Bug 800403 has been marked as a duplicate of this bug. ***
Comment 9 Adam Williamson 2012-03-09 12:52:21 EST
Proposing as Beta blocker per criterion "The installer must be able to successfully complete an upgrade installation from a clean, fully updated default installation (from any official install medium) of the previous stable Fedora release, either via preupgrade or by booting to the installer manually. The upgraded system must meet all release criteria"



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 10 Adam Williamson 2012-03-09 12:52:57 EST
oop, ignore the above.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 11 Kamil Páral 2012-03-13 11:10:04 EDT
I have used updates.img from comment 7 to upgrade F16 i686 to F17 in text mode. Upgrade worked fine, the only available options were "create new bootloader" or "skip bootloader" (I don't know whether that fixes this bug).
Comment 12 Kamil Páral 2012-03-13 12:08:24 EDT
I also tried to upgrade default F15 i686 to F17 using text. Exactly the same result, same bootloader options available, after choosing "create new" it worked perfect.
Comment 13 Adam Williamson 2012-03-14 14:44:30 EDT
I'd say it fixes this bug, yes. There's still a question whether we really want to be re-installing the bootloader on upgrade from F16, but that's not this bug.

So I'd say this is fixed as soon as the patch is merged and a new anaconda built (17.13 doesn't actually exist yet).



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 14 Adam Williamson 2012-03-19 19:44:47 EDT
We cannot reconfirm this with TC2 as text install is broken: http://bugzilla.redhat.com/show_bug.cgi?id=804483 .



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 15 Fedora Update System 2012-03-23 01:18:03 EDT
anaconda-17.14-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/anaconda-17.14-1.fc17
Comment 16 Fedora Update System 2012-03-23 13:10:15 EDT
Package anaconda-17.14-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-17.14-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-4546/anaconda-17.14-1.fc17
then log in and leave karma (feedback).
Comment 17 Fedora Update System 2012-03-23 13:45:32 EDT
anaconda-17.14-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Kamil Páral 2012-03-26 09:17:14 EDT
This bug was closed automatically by Bodhi, but we still need to verify it. Changing status to ON_QA.
Comment 19 Adam Williamson 2012-03-26 16:23:49 EDT
Beta RC1 defaults to 'install new bootloader configuration' and has an option for 'skip bootloader configuration', so this is fixed (the fact that these specific options aren't optimal behaviour is documented elsewhere).



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.