Bug 742763 - something is wrong with the libreoffice clipboard
Summary: something is wrong with the libreoffice clipboard
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gpaste
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mohamed El Morabity
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 742970 756604 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-10-02 16:10 UTC by Joachim Backes
Modified: 2011-12-21 17:10 UTC (History)
7 users (show)

Fixed In Version: gpaste-2.1-1.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-03 07:58:01 UTC


Attachments (Terms of Use)

Description Joachim Backes 2011-10-02 16:10:15 UTC
Description of problem:
Editing a draw document, or adding graphicals to a text document: copying some graphical objects (ctrl+c) and trying to paste the (ctrl+v): the only effect that the most recent text entry of the clipboard is pasted, but not the graphical object.

Version-Release number of selected component (if applicable):
libreoffice-3.4.3.2-10.fc16.x86_64

How reproducible:
always

Steps to Reproduce:
1.Open some document
2.Copy some text with ctrl+c
3.Make some graphical object
4. Copy this graphical object with ctrl+c
5. Try to paste this graphical object

Actual results:
The text clipboard entry is pasted

Expected results:
The graphical object is pasted

Additional info:

Comment 1 David Tardon 2011-10-03 04:36:08 UTC
Sorry, but I cannot reproduce this. I created a new text document, wrote a couple of words, copied and pasted them. Then I inserted a rectangle, copied it and pasted it again. I tried the same with a drawing and even between writer and draw, without any problem. Do you use any clipboard manager? If yes, try turning it off. If you have this problem with a specific document only, could you attach it here?

Comment 2 Joachim Backes 2011-10-03 08:17:01 UTC
rpm -qa|grep -i clip
xfce4-clipman-plugin-1.1.3-4.fc15.x86_64


That's all!

I have the problem with all libreoffice documents.

Perhaps this is a hint: Copying text to the clipboard (with ctrl+c) with any abitryry app will be resitent against reboots, that means, after a reboot, the most recent clipboard entry (before reboot)  is still available!

Comment 3 Caolan McNamara 2011-10-03 08:33:48 UTC
We have no such feature, so there has to be something else in play.

Your desktop environment is actually xfce4, right ?

Comment 4 Joachim Backes 2011-10-03 08:37:26 UTC
No, it's gnome-shell (gnome3)

Comment 5 Joachim Backes 2011-10-03 12:25:39 UTC
I think, it's a gnome3 problem: working in a xfce session shows the normal clipboard behavior.

Comment 6 Joachim Backes 2011-10-03 13:19:47 UTC
I think gpasted (/usr/libexec/gpaste/gpasted) is the culprit: after killing this process (it is not explicetely started by myself!) , I have a flawless copy/paste within libreoffice as usual!

Comment 7 Caolan McNamara 2011-10-03 13:46:31 UTC
Sounds like something new in the long line of clipboard managers which come a bit unstuck on first contact with the enemy :-)

I don't see gpaste in comps-f16.xml.in from git clone git://git.fedorahosted.org/comps.git so it doesn't look like it's directly in the default install list. So what Requires it ?, i.e. rpm -q --whatrequires gpaste ?

Comment 8 Joachim Backes 2011-10-03 14:01:42 UTC
I found out that gpaste always is installed together with gnome-shell-extension-gpaste (I installed that by yum for testing purposes). But gpaste is not not uninstalled if I remove gnome-shell-extension-gpaste by yum.

Now I removed it manually by rpm.

Comment 9 Caolan McNamara 2011-10-03 14:19:10 UTC
fair enough, not a default installed component then, so not a high impact affair

Comment 10 Joachim Backes 2011-10-03 14:30:04 UTC
(In reply to comment #9)
> fair enough, not a default installed component then, so not a high impact
> affair

I agree!

Comment 11 Mohamed El Morabity 2011-10-03 23:04:27 UTC
*** Bug 742970 has been marked as a duplicate of this bug. ***

Comment 12 Mohamed El Morabity 2011-10-03 23:22:42 UTC
(In reply to comment #8)
> I found out that gpaste always is installed together with
> gnome-shell-extension-gpaste (I installed that by yum for testing purposes).
> But gpaste is not not uninstalled if I remove gnome-shell-extension-gpaste by
> yum.
> 
gpaste consists in a DBus daemon tracking any copy action. The GS extension obviously requires the daemon to communicate with it and track copy history. But neither the daemon nor the CLI client need the GS extension: you can use both without it.
You're complaining about the default behaviour of yum, which doesn't remove all the packages required and installed by the one you try to remove. Fortunately...

Your issue will be reported upstream anyway.

Comment 13 David Tardon 2011-10-04 04:22:56 UTC
(In reply to comment #8)
> I found out that gpaste always is installed together with
> gnome-shell-extension-gpaste (I installed that by yum for testing purposes).
> But gpaste is not not uninstalled if I remove gnome-shell-extension-gpaste by
> yum.

If you want that behaviour in yum, install yum-plugin-remove-with-leaves and uncomment #remove_always = 1 in /etc/yum/pluginconf.d/remove-with-leaves.conf (or use --remove-leaves option with yum remove).

Comment 14 Marc-Antoine Perennou 2011-10-04 17:27:25 UTC
I planned to add graphical stuff support as an extra feature in one of the next versions but didn't know about this behaviour. Will focus on this !

Comment 15 Marc-Antoine Perennou 2011-11-03 12:13:37 UTC
This should be solved in upstream 1.99 release.

Feel free to report a new bug there: https://github.com/Keruspe/GPaste/issues
if it still doesn't work as expected or for suggestions about how it should work once it gets available here.

Comment 16 Fedora Update System 2011-11-30 01:08:37 UTC
gpaste-2.0-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/gpaste-2.0-1.fc16

Comment 17 Fedora Update System 2011-12-02 21:27:31 UTC
Package gpaste-2.0-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gpaste-2.0-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-16631/gpaste-2.0-1.fc16
then log in and leave karma (feedback).

Comment 18 Joachim Backes 2011-12-03 07:58:01 UTC
copy/paste now works as expected with gpaste-2.0-1.fc16

Comment 19 Gabriel 2011-12-05 19:23:37 UTC
*** Bug 756604 has been marked as a duplicate of this bug. ***

Comment 20 Fedora Update System 2011-12-09 21:25:58 UTC
gpaste-2.1-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/gpaste-2.1-1.fc16

Comment 21 Fedora Update System 2011-12-21 17:10:59 UTC
gpaste-2.1-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.