Bug 756604 - Paste works intermittently or not at all.
Summary: Paste works intermittently or not at all.
Keywords:
Status: CLOSED DUPLICATE of bug 742763
Alias: None
Product: Fedora
Classification: Fedora
Component: inkscape
Version: 16
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Lubomir Rintel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-11-24 01:53 UTC by Gabriel
Modified: 2011-12-05 19:23 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-05 19:21:27 UTC
Type: ---


Attachments (Terms of Use)

Description Gabriel 2011-11-24 01:53:33 UTC
Version-Release number of selected component (if applicable):

Arch        : x86_64
Version     : 0.48.1
Release     : 9.fc16

updates-testing is enabled.

How reproducible:

Open a new Inkscape file. Create an object. Select it. Do CTRL-C or select Copy from the menu. Hit Paste.

At this point, a paste SOMETIMES happens. It's about 50/50 odds.

If a paste does happen, hitting CTRL-V again NEVER works.

Additional info:

Copying from one document and pasting into another never works either. I'm not sure when this behaviour started - this all worked fine in F15.

I have checked my keyboard shortcuts and there's nothing conflicting with CTRL-V. Paste works fine in other apps. There's no problem with my keyboard.

Comment 1 Matt Reid 2011-11-28 19:09:36 UTC
I think I'm having the same issue with Inkscape on my machine, a Lenovo T520 running Fedora 16 x64. Inkscape works fine when running off a F15 USB flash drive, or on my RHEL 6.1 Workstation partition. A virtual RHEL 6.2 Server running Inkscape .47 within F16 works fine as well. I've installed the F15 Inkscape version, and a newer version (I think .48.3) on F16 but saw the same issue.

Duplication (CTRL-D) works fine, but copy-pasting rarely works. Text seems to work more reliably than shapes or complex figures. It looked like things were going into the clipboard (using the drag and drop testing tool), and the system knows that something has been added to the clipboard, as I can select paste from the menu, but chances are slim that anything will actually paste. When things do paste, I tend to get between 1 and 4 pastes out of it. Often it'll be one and done, but sometimes I get 2, 3 or 4. Once it stops pasting, I don't think I've gotten it to paste again without a fresh copy. I have to import other files and delete what I don't want, since I haven't had any luck copy-pasting between running instances of Inkscape.

As above, this is using either my USB wired keyboard or the laptop keyboard, and Inkscape on the same hardware in other versions of F/RHEL is fine.

Comment 2 Matt Reid 2011-11-30 17:56:54 UTC
Gabe, do you mind including what kind of hardware you're experiencing this issue on? I'm curious if you're also on a recent Lenovo laptop.

Comment 3 Matt Reid 2011-12-05 15:10:19 UTC
I'm not sure about your situation, but my issue was caused by gpasted running. Clipboard managers break inkscape and some other applications (sounds like libreoffice is one of them). I installed all of the gnome shell extensions, which pulled in gpasted for the gpaste extension, and when I enabled that extension briefly, it left gpasted in my startup programs, which I had to get rid of with gnome-session-properties.

You can check with ps -A | grep gpasted to see if you have it running. 

Full bug report on launchpad is here - https://bugs.launchpad.net/inkscape/+bug/897709 .

Comment 4 Gabriel 2011-12-05 19:21:27 UTC
Yep, that was it. I did the same as you and pulled in all the gnome-shell extensions.

Thanks for chasing this down. I guess we can consider this a duplicate of bug #742970 - I will comment on that bug and link in your Launchpad thread as well so nothing gets lost.

*** This bug has been marked as a duplicate of bug 742970 ***

Comment 5 Gabriel 2011-12-05 19:23:37 UTC
Actually, that bug is also a duplicate. Here's the first: bug #742763. Looks like the fix is in.

*** This bug has been marked as a duplicate of bug 742763 ***


Note You need to log in before you can comment on or make changes to this bug.