Bug 742970 - gpasted baffles copy/paste within libreoffice
Summary: gpasted baffles copy/paste within libreoffice
Keywords:
Status: CLOSED DUPLICATE of bug 742763
Alias: None
Product: Fedora
Classification: Fedora
Component: gpaste
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Mohamed El Morabity
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-10-03 13:14 UTC by Joachim Backes
Modified: 2011-12-05 19:21 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-03 23:04:27 UTC
Type: ---


Attachments (Terms of Use)

Description Joachim Backes 2011-10-03 13:14:40 UTC
Description of problem:
I have a weird problem with the clipboard in a gnome 3 session: selected and copied text (into the clipboard with ctrl+c) always overwrites geometrical objects (rectangles aso) if editing a libreoffice document:

That means: if copying text with ctrl+c (after selection) and then additionally copy some graphical object (with ctrl+c too), then if perform a pasting
with ctrl+v will always paste the older clipboard text entry and not the copied graphical object.

I found out that I can get rid of this effect by killing gpasted (/usr/libexec/gpaste/gpasted). After this, I can work with ctrl+c/ctrl+v as usual.
Version-Release number of selected component (if applicable):


How reproducible:
See description

Steps to Reproduce:
1.See description
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Joachim Backes 2011-10-03 13:22:54 UTC
gpaste version: gpaste-1.6-1.fc16.x86_64 (sorry, I forgot)

Comment 2 Joachim Backes 2011-10-03 13:52:11 UTC
I can state more precisely my report: I found out that killing only once gpasted, in the following gnome3 session the described buggy copy/paste behaviour did no more appear!

I can additionally report that the clipboard contents even survived a system reboot or a logout (during the buggy copy/paste periods of gnome3 sessions I reported above)

Comment 3 Joachim Backes 2011-10-03 15:34:49 UTC
(In reply to comment #2)
> I can state more precisely my report: I found out that killing only once
> gpasted, in the following gnome3 session the described buggy copy/paste
> behaviour did no more appear!
> 
> I can additionally report that the clipboard contents even survived a system
> reboot or a logout (during the buggy copy/paste periods of gnome3 sessions I
> reported above)

I found out that gpaste always is installed together with
gnome-shell-extension-gpaste which I installed for testing purposes. I removed gnome-shell-extension-gpaste in the mean time by yum, but gpaste was not removed together with gnome-shell-extension-gpaste. Question: Can this be the reason for the described misbehaviour?

Comment 4 Mohamed El Morabity 2011-10-03 23:04:27 UTC

*** This bug has been marked as a duplicate of bug 742763 ***

Comment 5 Gabriel 2011-12-05 19:21:27 UTC
*** Bug 756604 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.