Bug 744136 - [ja_JP][ko_KR] Invalid date format error always happens in localized subscription manager GUI
[ja_JP][ko_KR] Invalid date format error always happens in localized subscrip...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
All All
unspecified Severity urgent
: rc
: ---
Assigned To: Bryan Kearney
QE Internationalization Bugs
: i18n, Regression, TestBlocker
: 744362 (view as bug list)
Depends On:
Blocks: rhsm-rhel62 748554
  Show dependency treegraph
 
Reported: 2011-10-07 04:17 EDT by Kenichi Takemura
Modified: 2014-08-04 18:04 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:25:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
subscription-manager-0.96.15-1.el6 (99.67 KB, image/png)
2011-10-13 01:21 EDT, Lijun Li
no flags Details
en_US (76.29 KB, image/png)
2011-10-13 01:32 EDT, Lijun Li
no flags Details

  None (edit)
Description Kenichi Takemura 2011-10-07 04:17:40 EDT
Description of problem:

When starting subscription-manager GUI in localized desktop(such as ja_JP.UTF8) and registering the system, 'Invalid date format' error dialogue always pops-up.

This bug almost makes the GUI unusable.

Version-Release number of selected component (if applicable):
subscription-manager-0.96.13-1.el6.i686
subscription-manager-firstboot-0.96.13-1.el6.i686
subscription-manager-debuginfo-0.95.8-1.el6.i686
subscription-manager-gnome-0.96.13-1.el6.i686


How reproducible:
100%

Steps to Reproduce:
1. $ LANG=ja_JP.UTF8 subscription-manager-gui
2. Register the system
3. Click My Subscriptions or Available Subscriptions tabs or Click 'Update' or 'Calendar'

Actual results:
'Invalid date format' error comes up.

Expected results:
No dialogues please since the date is correct(set by default).

Additional info:
Comment 2 A S Alam 2011-10-07 05:26:25 EDT
I can reproduce above bug with following locales only:
ja_JP.UTF-8
ko_KR.UTF-8

other Red Hat supported locale, it is working as expected
Comment 5 A S Alam 2011-10-09 23:37:43 EDT
*** Bug 744362 has been marked as a duplicate of this bug. ***
Comment 6 Lijun Li 2011-10-10 04:32:10 EDT
Tested on subscription-manager-0.96.12-1.el6, also had this issue.
Comment 8 Adrian Likins 2011-10-10 11:45:21 EDT
commit c900ff31d099801fdb832801e85730c3a49a88c8
Author: Adrian Likins <alikins@redhat.com>
Date:   Fri Oct 7 16:03:28 2011 -0400

    744136: workaround date parsing problems in some locales
    
    work around for bz #744136 and #704069. Basically, we don't
    seem to be able to parse dates with time.strptime()
    in some locales, even if the date is exactly the
    string created by today.strftime("%x"). So we
    just set LC_TIME to en_GB which we can parse



It's not a great fix, but it is a generalized version of the fix we had for in_OR as well. It will prevent the crash, however, it doesn't show a properly localized date string for this case.
Comment 14 Lijun Li 2011-10-13 01:19:47 EDT
Verified it's fixed on subscription-manager-0.96.15-1.el6.x86_64, but it doesn't show a properly localized date string and the calendar is English, please see the screenshot.
Comment 15 Lijun Li 2011-10-13 01:21:09 EDT
Created attachment 527830 [details]
subscription-manager-0.96.15-1.el6
Comment 16 Lijun Li 2011-10-13 01:32:32 EDT
For the date format, it's better to keep the format the same as en_US, it's  10/13/2011 or 13/10/2011, but not 13/10/11.
Comment 17 Lijun Li 2011-10-13 01:32:59 EDT
Created attachment 527833 [details]
en_US
Comment 18 John Sefler 2011-10-17 13:02:08 EDT
(In reply to comment #8)
> It's not a great fix, but it is a generalized version of the fix we had for
> in_OR as well. It will prevent the crash, however, it doesn't show a properly
> localized date string for this case.

(In reply to comment #14)
> Verified it's fixed on subscription-manager-0.96.15-1.el6.x86_64, but it
> doesn't show a properly localized date string and the calendar is English,
> please see the screenshot.

Agreed.
Opening bug 746732 to be reviewed again in the future.

moving to VERIFIED
[root@jsefler-onprem-62server ~]# rpm -q subscription-manager
subscription-manager-0.96.15-1.git.2.6c0ad28.el6.x86_64
Comment 19 John Sefler 2011-10-17 13:08:03 EDT
(In reply to comment #16)
> For the date format, it's better to keep the format the same as en_US, it's 
> 10/13/2011 or 13/10/2011, but not 13/10/11.

The fix for this bug from development is a work-around.  As such, the chosen work-around locale en_GB is being used for ja_JP ko_KR and or_IN.  Therefore all users of these three locales are affected.  Can all three locale communities agree that an en_US work-around is better than en_GB?
Comment 20 Kenichi Takemura 2011-10-17 21:33:30 EDT
For ja_JP and ko_KR, en_US(mm/dd/yyyy hopefully than dd/mm/yyyy) is preferable.
Sorry but not sure about or_IN.

> 
> The fix for this bug from development is a work-around.  As such, the chosen
> work-around locale en_GB is being used for ja_JP ko_KR and or_IN.  Therefore
> all users of these three locales are affected.  Can all three locale
> communities agree that an en_US work-around is better than en_GB?
Comment 21 errata-xmlrpc 2011-12-06 12:25:45 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.