This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 74426 - Documentation Indexing results in infinite loop
Documentation Indexing results in infinite loop
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: kdevelop (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Petr Rockai
Ben Levenson
:
: 75260 88882 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-23 22:58 EDT by Daniel
Modified: 2007-04-18 12:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 13:58:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel 2002-09-23 22:58:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020809

Description of problem:
When indexing qt and kde documentation (the default, with nothing added), and a
medium index size, the system will indefinately index. I let it run for 7 hours
before stopping it (on a P3/1200).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. run kdevelop-setup
2. choose the default options, and then "start indexing"
3.
	

Actual Results:  never completes

Expected Results:  complete indexing and integration into the online help system
of kdevelop

Additional info:
Comment 1 Arnoud Jagerman 2003-02-17 04:21:36 EST
Cause of the problem:

htdig indexes everything from the root of the filesystem, including directories 
like /proc/ and /dev/ which causes the problem.


Work-around:

The kdevelop setup-utility tells htdig to use the htdig.conf file located in 
$HOME/.kde/share/apps/kdevelop/tools/. This file contains the following line:

limit_urls_to: file://

This causes htdig to index everything from the root of the filesystem.

To avoid this, start kdevelop-setup and write down the qt3 and kde 
documentation directories. In my case these are /usr/lib/qt3-gcc3.2/doc/html/ 
and /usr/share/doc/kdelibs-devel-3/. Before clicking the 'Index' button, edit 
the htdig.conf file in /home/your_directory/.kde/share/apps/kdevelop/tools/ and 
add the following line:

start_url:     /usr/lib/qt3-gcc3.2/doc/html/      /usr/share/doc/kdelibs-devel-
3/

Also, replace the limit_urls_to: line with the following line:

limit_urls_to:     ${start_url}

Now save the file, click the 'Index' button and continue with the setup process 
as normal.
Comment 2 Daniel 2003-04-07 11:48:32 EDT
This bug is still present is Red Hat 9
Comment 3 Marcin Garski 2004-11-23 09:33:21 EST
*** Bug 88882 has been marked as a duplicate of this bug. ***
Comment 4 Marcin Garski 2004-11-23 09:39:39 EST
*** Bug 75260 has been marked as a duplicate of this bug. ***
Comment 5 Marcin Garski 2004-11-23 09:48:44 EST
Daniel thank you for the bug report. This bug is reported aginst
KDevelop 2.x, recent version is 3.x, so many things have been
changed/added. Shortly I'll try to reproduce this bug on KDevelop 3.x
and see if it still happens. Just give me some time.
Comment 6 Marcin Garski 2004-11-26 16:37:20 EST
I've tried indexing Qt and KDE documentation (default settings) on 
KDevelop 3.3.1 and I can't reproduce this bug (indexing went fine).

Could you please try to reprdouce this bug on recent version of
KDevelop (3.x or above) with various configuration.
Comment 7 Petr Rockai 2006-07-17 14:16:16 EDT
This bug is reported against old release of Red Hat Linux or Fedora Core 
that is no longer supported. Chances are that it has been already fixed in 
newer Fedora Core release. If you still experience the problem with 
current release of Fedora Core, please update the Version field (you may 
need to switch Product to Fedora Core first) in the bug report and put it 
back to NEW state.
Comment 8 Bill Nottingham 2006-10-18 13:58:58 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
If this issue is still present in a current Fedora Core release, please
open a new bug with the relevant information.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.