Bug 745518 - Network is not UP by default after installation if "minimal install" option is selected when installing
Network is not UP by default after installation if "minimal install" option i...
Status: CLOSED DUPLICATE of bug 693602
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
16
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-12 11:03 EDT by Igor Mammedov
Modified: 2011-10-13 14:27 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-13 14:27:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Igor Mammedov 2011-10-12 11:03:20 EDT
Description of problem:

Selecting "minimal" installation option when installing,leads to a state where freshly installed system doesn't have network connectivity by default on boot and doesn't have an option to protect itself if networking is enabled manually.

This caused by the fact that NetworkManager is not installed with this installation mode.However file /etc/sysconfig/network-scripts/ifcfg-eth0 has option "NM_CONTROLLED=yes".

Problem can be solved by adding 
   1.1 NetworkManager to a package set installed for "Minimal" option
    or
   1.2 Enabling legacy "network" service to be launched on start-up
   2   Adding iptables package to the set a well.

Otherwise the system is in bare and pretty much useless state and it is difficult to update packages in a secure way, without manually installing 'iptables' from CD (if we have it) and manually enabling networking on the system after turning on firewall.


How reproducible:
always


Steps to Reproduce:
1. When installing, select  "Minimal" install option.
2. After reboot network interface is in 'DOWN' state
  
Actual results:
no network connectivity after installation, without manual tuning.

Expected results:
system should have firewall and network connectivity enabled by default after installing.
Comment 1 Andre Robatino 2011-10-12 11:51:42 EDT
You probably want to mark this as a duplicate of bug 741199 which already appears close to being fixed.
Comment 2 Andre Robatino 2011-10-12 18:28:49 EDT
Actually, I misunderstood exactly what bug 741199 covered - see https://bugzilla.redhat.com/show_bug.cgi?id=741199#c11 . So this is not actually a dupe, although fixing that bug helps in fixing this one.
Comment 3 Radek Vykydal 2011-10-13 02:44:34 EDT
Seems more like duplicate of bug #702261 with requirement of firewall setup added.
Comment 4 Igor Mammedov 2011-10-13 04:50:13 EDT
(In reply to comment #3)
> Seems more like duplicate of bug #702261 with requirement of firewall setup
> added.

Yes, It looks like it's a dup of fc15 bug 702261 (CLOSED|NOTABUG)  or duped to it fc16 bug 740674 or still open bug 693602 plus additional req for firewall

I've read comments in this bugs and so far haven't seen a clear explanation why it shouldn't be be fixed and why freshly installed system should be left in a crippled state. 

I suppose this kind of bug will reappear repeatedly until it is fixed for several reasons:
  1. fc16 bug 740674 - for netinstall it's implied that network should work after install, a system possibly does not have any other means to deliver software packages/updates (only network).
  2. minimal install is convenient for testing purposes (takes less time to install) and for installing customised servers with possible minimal package set. This tasks often require to install additional packages that will make the minimal installation usable. So having working network out of box will save time and save users from being annoyed.
  3. even with minimal install, system should be able get updates after install,  thus it needs working network and firewall to protect it right after install.


I think it is not fair to dup this kind of bugs to a closed/notabug, and there is no point in fixing it for fc15 since images for it already released and we can't change them. However issue is still fixable for fc16 (I won't object to duping this bug to bug 740674 and reopening the last one).

In the worst case, if it's too late for fc16, we can move it to rawhide and have it fixed for fc17.
Comment 5 Bill Nottingham 2011-10-13 14:26:15 EDT
I'd just dup it to 740674.

Possible solutions:

1) a mechanism to enable network IFF NetworkManager isn't installed. This doesn't exist right now, and would be tricky.
2) enabling network.service in all cases. This isn't doable now due to bug 742840.
3) adding NetworkManager to the minimal install. This would get a *lot* of pushback.
Comment 6 Adam Williamson 2011-10-13 14:27:33 EDT
I'm going to go with 693602 as it's the oldest bug: let's dupe everything off to that one.

*** This bug has been marked as a duplicate of bug 693602 ***

Note You need to log in before you can comment on or make changes to this bug.