Bug 746827 - black screen in X after installing Fedora-16-TC1-x86_64-Live-Desktop.iso to physical hard drive
black screen in X after installing Fedora-16-TC1-x86_64-Live-Desktop.iso to p...
Status: CLOSED DUPLICATE of bug 746844
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
16
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F16Blocker/F16FinalBlocker
  Show dependency treegraph
 
Reported: 2011-10-17 17:11 EDT by Zach Carter
Modified: 2011-10-18 19:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-18 19:12:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Zach Carter 2011-10-17 17:11:48 EDT
Description of problem:
Fedora-16-TC1-x86_64-Live-Desktop.iso boots successfully and I can install to
hard drive and boot into the installed system, but X only has a black screen. I
can switch to a VT, however. 

Version-Release number of selected component (if applicable):
Fedora-16-TC1-x86_64-Live-Desktop.iso

How reproducible:
only tried once

Steps to Reproduce:
1. Boot Fedora-16-TC1-x86_64-Live-Desktop.iso and install to hard drive
2. Reboot into installed system

Actual results:
X has black screen. Don't seem to be able to do anything in it except switch to
a VT.

Expected results:
X should work normally.

Additional info:
AMD processor, radeon driver.   
Very similar to BZ #746509 (description pasted from there to here and then edited)
Comment 1 Matěj Cepl 2011-10-18 08:20:02 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information especially concerning your hardware we require that will be helpful in our diagnosis of this issue.

If the anaconda crashes during the switching to the graphic mode, most likely the problem lies in Xorg support for your graphics chip. There are couple of options how we can obtain information necessary for resolving the issue.

If the computer is not completely frozen when installation fails, switch to the console (Ctrl+Alt+F2) and copy /tmp/X* and /var/log/anaconda.xlog to some other place -- USB stick, some other computer via network, somewhere on the Internet, and please attach it to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

If the computer is completely useless after installation fails, you can also install Fedora with a VESA mode driver (see http://docs.fedoraproject.org/en-US/Fedora/13/html/Installation_Guide/
for more information on that). Then after successful installation you can collect /var/log/anaconda.xlog, /var/log/Xorg.0.log, and the output of the program dmesg instead.

Or you can install Fedora in a text mode completely, and then start X after that. If it fails, still /var/log/Xorg.0.log and the output of dmesg program from the failed attempt to start X would be useful.

We will review this issue again once you've had a chance to attach this information.

Thank you very much in advance.
Comment 2 Andre Robatino 2011-10-18 09:41:52 EDT
It would probably speed things up to first provide the information Adam asked for in bug 746529, which was marked as a duplicate of bug 746844. There's a good chance this is another duplicate.
Comment 3 Zach Carter 2011-10-18 12:03:48 EDT
(In reply to comment #1)

Matej, the installation is 100% successful.  The X server on the Live CD functions with no problems.  The problem only occurs during first boot after the installation.   As Andre pointed out, this is probably a duplicate of bug 746844, which Adam and others have reproduced.
Comment 4 Adam Williamson 2011-10-18 19:12:34 EDT
yup, this is almost certainly a dupe. try with the updates.img from that bug.

*** This bug has been marked as a duplicate of bug 746844 ***

Note You need to log in before you can comment on or make changes to this bug.