Bug 74784 - Sawfish preferences do not work
Sawfish preferences do not work
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: sawfish (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
David Lawrence
:
: 75686 76474 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-01 13:05 EDT by berto
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-02 12:17:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description berto 2002-10-01 13:05:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020827

Description of problem:
when going through the control center ( nautilus interface ) or through the
redhat menu, the sawfish preferences dialogs do not appear when they are selected.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. open up the preferences
2. click on extras
3. click on the sawfish folder
4. select a preference to change
5. nothing happens

OR 

1. open the redhat menu
2. select extras -> preferences -> sawfish window manager
3. select a pref to edit
4. nothing happens

Actual Results:  nothing

Expected Results:  a pref dialog to appear to change sawfish settings.

Additional info:

Upon digging a little deeper, I was able to get an error message when trying to
edit the sawfish preferences.  For example:

$ sawfish-ui --group=focus
error: can't connect to socket /tmp/.sawfish-berto/localhost.localdomain:0.0
*** Error: can't connect to sawfish on display, :0.0

Looking in /tmp, I noticed there is no .sawfish directory of any kind, which is
what the sawfish-ui command is looking for.
Comment 1 Havoc Pennington 2002-10-01 13:56:29 EDT
Are you running sawfish? they don't work unless sawfish is running.
Comment 2 Philip Imants Long 2002-10-02 12:17:26 EDT
Ok, I ran into the same thing.  I was running METACITY.  But the RELEASE NOTES
make no mention of changing the WM so I spent a LOT OF TIME being VERY CONFUSED.

So, I'd submit there is a problem with the release notes.

I'd also submit that there is a UI bug with control-center as the sawfish dialog
should not be present in the absense of sawfish.  Otherwise you're going to have
a TON of semi-sophisticated users wondering WTF is going on when cliking on
those icons.  Nothing happens ergo, ITS BROKEN they will think.  In my case, it
only wasted an hour of my time down the wrong path to try to get
drag-across-desktop behavior.

BTW - sorry about the yelling.  RH 8 has made great UI strides - and thus raised
the bar.  Still this is bad UI, - thats why menus grey out un avialable options,
after all.  It should be fixed.
Comment 3 Havoc Pennington 2002-10-02 14:58:18 EDT
Moving the control panel issue to http://bugzilla.gnome.org/show_bug.cgi?id=94711, 
closing on Red Hat level.

Release notes are already out the door, can't really be fixed retroactively.
Comment 4 Havoc Pennington 2002-10-10 22:26:30 EDT
*** Bug 75686 has been marked as a duplicate of this bug. ***
Comment 5 lanzi 2002-10-22 05:10:28 EDT
*** Bug 76474 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.