Bug 748005 - rhev-hypervisor renamed to rhev-hypervisor6
Summary: rhev-hypervisor renamed to rhev-hypervisor6
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rhev-hypervisor6
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Mike Burns
QA Contact: Virtualization Bugs
URL:
Whiteboard:
: 747646 749400 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-10-21 17:06 UTC by Jay Greguske
Modified: 2016-04-26 13:50 UTC (History)
12 users (show)

Fixed In Version: rhev-hypervisor6-6.2-20111019.3.1.el6
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 19:29:29 UTC
Target Upstream Version:
moli: needinfo-


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1783 normal SHIPPED_LIVE rhev-hypervisor6 bug fix and enhancement update 2011-12-06 15:10:54 UTC

Description Jay Greguske 2011-10-21 17:06:44 UTC
The rhev-hypervisor package should be renamed to rhev-hypervisor6. The reason is so in RHN we can have rhev-hypervisor6 and rhev-hypervisor5 in the same channel together, since they are both supported by RHEV-M 3.x. They should be parallel-installable.

Comment 5 Suzanne Yeghiayan 2011-10-21 19:03:41 UTC
*** Bug 747646 has been marked as a duplicate of this bug. ***

Comment 6 Mike Burns 2011-10-21 20:51:02 UTC
Changes made:

RPM names are rhev-hypervisor6 and rhev-hypervisor6-tools

installing rhev-hypervisor6 should not pull -tools, but installing -tools
should pull rhev-hypervisor6.

Only 1 requirement for rhev-hypervisor6 -- rpmdevtools which is a %post
requirement.

Layout of the installation should be the same in /usr/share/rhev-hypervisor

-tools package should require isomd5sum, parted, dosfstools

rhev-hypervisor5 should obsolete all rhev-hypervisor- packages

yum install rhev-hypervisor should pull latest rhev-hypervisor6

Should still be installable side-by-side

Comment 7 Mike Burns 2011-10-27 13:38:57 UTC
*** Bug 749400 has been marked as a duplicate of this bug. ***

Comment 8 Mike Burns 2011-10-27 13:39:28 UTC
Need to ensure that rhev-hypervisor-release file doesn't change name

Comment 9 Mike Burns 2011-10-27 13:56:25 UTC
diff -u -r1.4 Makefile
--- Makefile	26 Oct 2011 22:29:51 -0000	1.4
+++ Makefile	27 Oct 2011 13:55:21 -0000
@@ -14,6 +14,7 @@
 RHEVH_PRODUCT_CODE := $(shell awk '/^%define product_code/ {{$$1="";$$2="";sub(/^ */,"");print $$0}}' $(SPECFILE))
 RHEVH_RECIPE_SHA256 := $(shell  sha256sum $(RECIPES)/*.ks | sha256sum | cut -f1 -d' ')
 RHEVH_RECIPE_RPM := $(shell rpm -qf $(RECIPES)/$(NAME0).ks)
+PACKAGE := $(shell awk '/^%define base_name/ {{$$1="";$$2="";sub(/^ */,"");print $$0}}' $(SPECFILE))
 
 $(NAME).ks:
 	( \
@@ -22,7 +23,7 @@
 	    echo "PRODUCT_CODE=$(RHEVH_PRODUCT_CODE)" ;\
 	    echo "RECIPE_SHA256=$(RHEVH_RECIPE_SHA256)" ;\
 	    echo "RECIPE_RPM=$(RHEVH_RECIPE_RPM)" ;\
-	    echo "PACKAGE=$(NAME)" ;\
+	    echo "PACKAGE=$(PACKAGE)" ;\
 	    echo "VERSION=$(VERSION)" ;\
 	    echo "RELEASE=$(RELEASE)" ;\
 	) > version.ks

Comment 12 Mohua Li 2011-11-09 07:56:15 UTC
answering myself,

[root@dhcp-93-131 yum.repos.d]# rhn-channel  --list
rhel-x86_64-server-6
rhel-x86_64-server-6-rhevh-beta
rhel-x86_64-server-6-rhevm-3-beta

[root@dhcp-93-131 yum.repos.d]# yum search rhev-hypervisor
Loaded plugins: aliases, changelog, downloadonly, kabi, presto, product-id, refresh-packagekit, rhnplugin, security, subscription-manager, verify, versionlock
Updating certificate-based repositories.
Loading support for Red Hat kernel ABI
======================================================================================================= N/S Matched: rhev-hypervisor ========================================================================================================
rhev-hypervisor.noarch : Red Hat Enterprise Virtualization Hypervisor ISO image
rhev-hypervisor6.noarch : Red Hat Enterprise Virtualization Hypervisor ISO image
rhev-hypervisor6-tools.noarch : Tools for deploying RHEV Hypervisor Images

Comment 13 errata-xmlrpc 2011-12-06 19:29:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1783.html


Note You need to log in before you can comment on or make changes to this bug.