Bug 748725 - rhev-hypervisor livecd can't boot after enable UEFI
rhev-hypervisor livecd can't boot after enable UEFI
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.2
x86_64 Linux
medium Severity medium
: rc
: 6.3
Assigned To: Joey Boggs
Virtualization Bugs
:
Depends On: 810060
Blocks: 798688 813852 813894
  Show dependency treegraph
 
Reported: 2011-10-25 03:31 EDT by Mohua Li
Modified: 2016-04-26 09:23 EDT (History)
14 users (show)

See Also:
Fixed In Version: ovirt-node-2.3.0-8.el6
Doc Type: Bug Fix
Doc Text:
Previously, the ISO image did not include a UEFI kernel and initramfs. As a result it was not possible to boot UEFI enabled systems from optical media created using the image. The image has been updated. It now includes the components and directory structure needed to boot on a UEFI enabled machine.
Story Points: ---
Clone Of:
: 813852 (view as bug list)
Environment:
Last Closed: 2012-07-19 10:16:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Dell R210 UEFI (29.30 KB, image/jpeg)
2012-04-16 04:36 EDT, shaochen
no flags Details
fail to boot (21.31 KB, image/png)
2012-04-16 04:37 EDT, shaochen
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 69649 None None None Never

  None (edit)
Description Mohua Li 2011-10-25 03:31:41 EDT
Description of problem:

burn the iso to cdrom/usb, fail to boot with UEFI enable in IBM x3550, but ok to boot with the legacy bios, compare with rhel6.2, could boot with UEFI enable

Version-Release number of selected component (if applicable):
rhev-hypervisor 6.2(snapshot3) 19.2

How reproducible:
always

Steps to Reproduce:
1.burn the iso to cdrom/livecd-iso-to-disk $usb
2.boot with legacy biso(ok to boot)
3.boot with UEFI(fail to boot)
  
Actual results:
in x3550, rhev-hypervisor install disk always fail to boot in UEFI mode, 

Expected results:
rhev-hypervisor could boot in UEFI mode

Additional info:
Comment 5 Alan Pevec 2011-10-27 10:57:21 EDT
(In reply to comment #0)
> 3.boot with UEFI(fail to boot)

How do you choose between UEFI/legacy?
It seems that default (at least on those machines) is to try UEFI and automatically boot legacy if EFI fails, in which case this is not that critical issue.
Comment 13 shaochen 2012-04-16 04:36:14 EDT
Created attachment 577660 [details]
Dell R210 UEFI
Comment 14 shaochen 2012-04-16 04:37:14 EDT
Created attachment 577661 [details]
fail to boot
Comment 20 Guohua Ouyang 2012-04-18 01:49:40 EDT
Since the usb disk media can boot with efi mode and the iso is blocked by bz810060, move this bug to ON_QA and we will verify it after bz810060 is fixed.
Comment 33 yuanquan chen 2012-05-15 07:02:22 EDT
I retry UEFI boot with latest build rhev-hypervisor6-6.3-20120509.1.el6 according to comment#30 steps.Both Dell R210 and Dell optiplex 990 fail to boot from usb disk under UEFI mode. But the Dell optiplex 990 success to boot rhev-hypervisor6-6.3-20120502.3.el6 under UEFI mode. So it may be a regression bug. I will go on to try the Dell R210 UEFI boot with rhev-hypervisor6-6.3-20120502.3.el6 tomorrow.
Comment 35 yuanquan chen 2012-05-16 05:44:44 EDT
I retry the UEFI boot test, the Dell R210 can boot the rhev-hypervisor6-6.3-20120502.3.el6 from usb disk under UEFI mode.

I also retry the Dell optiplex 990 to boot rhev-hypervisor6-6.3-20120509.1.el6 from usb disk under UEFI mode and find that the boot failure is mainly caused by /EFI/BOOT/BOOTX64.conf of the boot media,  which specifies path of  vmlinuz0 and initrd0.img as "/EFI/BOOT". While the last build rhev-hypervisor6-6.3-20120502.3.el6 specifies the correct path as "/syslinux". So edit the UEFI boot item as the correct path, the Dell optiplex 990 also can boot rhev-hypervisor6-6.3-20120509.1.el6 from usb disk under UEFI mode.

After bootting under UEFI mode, install the rhev-hypervisor6-6.3-20120509.1.el6 into local disk, it successes without error. But it fails to boot from local disk with UEFI or legacy BIOS mode. This is tracked by another bug 749621.
Comment 38 yuanquan chen 2012-05-18 07:09:57 EDT
Environment:
rhev-hypervisor6-6.3-20120516.0.el6
rhev-hypervisor-tools-2.3.0-7.el6
rhevh-iso-to-disk --format --efi rhevh-6.3-20120516.0.el6.iso /dev/sdb

It still fails to boot from usb disk under UEFI mode. The main cause is the specified path of vmlinuz0 and initrd0.img, "/EFI/BOOT/", but there's no vmlinuz0 and initrd0.img in that directory.
Comment 45 yuanquan chen 2012-05-27 23:27:33 EDT
Verify this bug with rhevh-6.3-20120523.1 on Dell R510. Make the usb boot media with command "rhevh-iso-to-disk --format --efi rhevh-6.3-20120523.1.el6.iso /dev/sdb" and boot from the usb disk under UEFI mode, it successes.
Comment 46 Mike Burns 2012-06-13 13:25:47 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, the ISO image did not include UEFI kernel and initramfs.  Now, the image correctly includes the components and directory structure needed to boot the ISO on a UEFI enabled machine.
Comment 47 Stephen Gordon 2012-06-14 11:09:30 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-Previously, the ISO image did not include UEFI kernel and initramfs.  Now, the image correctly includes the components and directory structure needed to boot the ISO on a UEFI enabled machine.+Previously, the ISO image did not include a UEFI kernel and initramfs. As a result it was not possible to boot UEFI enabled systems from optical media created using the image. The image has been updated. It now includes the components and directory structure needed to boot on a UEFI enabled machine.
Comment 49 errata-xmlrpc 2012-07-19 10:16:03 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0741.html

Note You need to log in before you can comment on or make changes to this bug.