Bug 749621 - boot fails on EFI machine after installed
boot fails on EFI machine after installed
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.2
Unspecified Unspecified
high Severity medium
: rc
: 6.3
Assigned To: Joey Boggs
Virtualization Bugs
: TechPreview
: 789364 828845 (view as bug list)
Depends On: 747102 761540
Blocks: 729698 773069 773650 773651 773677 773696 783549 824928
  Show dependency treegraph
 
Reported: 2011-10-27 13:24 EDT by Mike Burns
Modified: 2016-04-26 09:53 EDT (History)
21 users (show)

See Also:
Fixed In Version: ovirt-node-2.3.0-8.el6
Doc Type: Technology Preview
Doc Text:
Installs on UEFI machines will finish successfully but fail to boot. To get around the issue, configure the machine to boot using legacy mode for the device.
Story Points: ---
Clone Of: 747102
: 761540 773069 824928 (view as bug list)
Environment:
Last Closed: 2012-07-19 10:16:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
boot failed in Dell R510 (28.69 KB, image/jpeg)
2012-05-08 22:22 EDT, shaochen
no flags Details

  None (edit)
Description Mike Burns 2011-10-27 13:24:45 EDT
+++ This bug was initially created as a clone of Bug #747102 +++

It appears that RHEV-H installation fails when booted in EFI mode.


Bug 747102 has setup the partitions for allowing boot in EFI mode.  This bug is to do the actual setup needed to setup the ESP

--- Additional comment from apevec@redhat.com on 2011-10-27 10:36:11 EDT ---

Created attachment 530505 [details]
Screenshot of grub menu booted with grub.efi

grub.conf also needs to be in the same folder with grub.efi
When grub.efi is selected manually in UEFI setup menu, it shows grub menu but fails to find partition - need to investigate why.

--- Additional comment from apevec@redhat.com on 2011-10-27 10:59:42 EDT ---

See bug 748725 comment 5 - if default is to try EFI and then legacy, fixing EFI boot shouldn't be a blocker. We only need to push the disk layout change since that affects future upgrades.
Comment 1 Mike Burns 2011-11-30 09:42:22 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Installs on UEFI machines will fail unless the host is configured to boot in legacy mode
Comment 2 Mike Burns 2011-12-01 14:06:51 EST
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-Installs on UEFI machines will fail unless the host is configured to boot in legacy mode+Installs on UEFI machines will finish successfully but fail to boot.  To get around the issue, configure the machine to boot using legacy mode for the device.
Comment 3 Stephen Gordon 2012-01-10 15:19:08 EST
The note update was included in time that it's in the release notes book, I'm going to clone this so that we can action it in the actual books as a z-stream item (at the very least the Installation and Evaluation guides).
Comment 6 Mike Burns 2012-02-10 11:33:34 EST
*** Bug 789364 has been marked as a duplicate of this bug. ***
Comment 12 Guohua Ouyang 2012-04-18 06:13:47 EDT
according to c#19 in bug 748725, move this bug to status "verified".

"This time can boot successful with parameter "--efi". It is useful.
Install RHEV-H can successful."
Comment 17 shaochen 2012-05-08 22:22:59 EDT
Created attachment 583107 [details]
boot failed in Dell R510
Comment 33 Peter Jones 2012-05-16 14:31:39 EDT
Also using \EFI\ovirt is in violation of the specification.
Comment 42 Mike Burns 2012-05-24 11:55:37 EDT
For QE:  Please test all scenarios except the one below.  A problem was found in the scenario below with brew builds only.

Burn iso to cd and boot in UEFI mode causes immediate kernel panic.
Comment 43 Mike Burns 2012-05-24 12:00:28 EDT
On second thought, leave this as ON_QA.  The above issue will be split out in a different bz.
Comment 44 yuanquan chen 2012-05-27 23:31:11 EDT
Verify this bug with rhevh-6.3-20120523.1 on Dell R510. Boot from usb boot media under UEFI mode and install to local disk, then boot from the local disk under UEFI mode, it successes.
Comment 45 Mike Burns 2012-06-05 09:51:28 EDT
*** Bug 828845 has been marked as a duplicate of this bug. ***
Comment 48 errata-xmlrpc 2012-07-19 10:16:08 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0741.html

Note You need to log in before you can comment on or make changes to this bug.