Bug 74911 - gdm text dialogs are broken
gdm text dialogs are broken
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: ncurses (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
Jay Turner
: Triaged
: 74861 78697 (view as bug list)
Depends On:
Blocks: 79579 CambridgeTarget
  Show dependency treegraph
 
Reported: 2002-10-02 14:50 EDT by Alan Cox
Modified: 2015-01-07 19:00 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-14 05:39:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alan Cox 2002-10-02 14:50:51 EDT
On the EPIA box after installing with no mouse it decided to go to run level 5
(doh - installer bug) however gdm did try to cope. Unfortunately the dialog it
stuck up in text mode was basically blank with random weird letters in the
actual yes/no/whatever boxes.

Video Card: Trident Cyberblade
Comment 1 Havoc Pennington 2002-12-19 19:24:21 EST
I'm assuming the text dialog is an upstream thing, if it was
redhat-config-xfree86 we should probably move this bug to r-c-x
Comment 2 Havoc Pennington 2002-12-19 19:27:38 EST
*** Bug 74861 has been marked as a duplicate of this bug. ***
Comment 3 Alan Cox 2002-12-19 19:30:18 EST
Sorry to disagree. It doesn't seem to happen on the same setup with Debian. I
don't know if its kudzu gone wonky, the font copying bug (ie tty8 hasnt got
the fonts set up, or its gdm triggered).

Alan
Comment 4 Havoc Pennington 2003-01-12 21:21:59 EST
Filed http://bugzilla.gnome.org/show_bug.cgi?id=103257
but I didn't actually check if upstream contains its own text dialog
or that's just Xconfigurator.
Comment 5 Owen Taylor 2003-01-16 16:19:55 EST
Taking gdm target/blockers.
Comment 6 Owen Taylor 2003-01-16 17:49:50 EST
GDM is just running 'dialog' in this case; I'd guess this is dialog
not working correctly on the console in UTF-8 mode.
Comment 7 Harald Hoyer 2003-01-29 10:36:03 EST
dialog uses ncurses, so reassigning to ncurses..
btw, tty is not configured to output UTF-8
Comment 8 Owen Taylor 2003-01-29 12:33:18 EST
You reassigned to gdm, not to ncurses... don't really understand the
comment about the tty.
Comment 9 Harald Hoyer 2003-01-29 12:39:48 EST
well, the tty the dialog is running on is not switched in utf-8 mode
see /bin/unicode_start
Comment 10 Eido Inoue 2003-02-03 17:42:25 EST
please test against the ncurses-5.3-3 package
Comment 11 Eido Inoue 2003-02-03 17:44:26 EST
*** Bug 78697 has been marked as a duplicate of this bug. ***
Comment 12 Alan Cox 2003-02-04 10:31:44 EST
Tested: The main text area is readable, the buttons are garbage as are the borders.
Comment 13 Jay Turner 2003-02-06 08:09:22 EST
Pushing this back to assigned as Alan is still seeing some issues.
Comment 14 Alan Cox 2003-08-14 05:39:12 EDT
Seems to be resolved as of the RHLP beta 1

Note You need to log in before you can comment on or make changes to this bug.