Bug 74973 - Program crashes when installing cups package
Program crashes when installing cups package
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-packages (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 76913 77512 78779 79213 80234 80789 82737 83450 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-03 06:10 EDT by Pedritor
Modified: 2014-01-21 17:48 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-19 16:42:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pedritor 2002-10-03 06:10:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
When I install cups using redhat-config-packages and LANG is set to es_ES.UTF-8
or es_ES

When I use LANG=en_US works.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.LANG=es_ES.UTF-8
2.export LANG
3.redhat-config-packages
4.Click on 'Details' in 'Printing support'
	

Actual Results:  (MainWindow.py:17319): Gtk-WARNING **: Failed to set cell text
from markup due to error parsing markup: Error en la l?nea
1,?caracter?40:?El?elemento?'markup' fue cerrado,?pero el elemento que est?
abierto actualmente es 'b'

(MainWindow.py:17319): Gtk-WARNING **: Failed to set cell text from markup due
to error parsing markup: Error en la l?nea 1,?caracter?40:?El?elemento?'markup'
fue cerrado,?pero el elemento que est? abierto actualmente es 'b'

** (MainWindow.py:17319): WARNING **: Invalid UTF8 string passed to
pango_layout_set_text()

** (MainWindow.py:17319): WARNING **: Invalid UTF8 string passed to
pango_layout_set_text()

** ERROR **: file pango-layout.c: line 2899 (pango_layout_check_lines):
assertion failed: (end <= (layout->text + layout->length))
aborting...
Abortado


Additional info:

I rus it as an normal user (uid=500, gid=500) and as root. Everytime crashes.
Comment 1 Jeremy Katz 2002-10-11 16:14:23 EDT
Fixed in CVS and will be in a newer package available at
http://people.redhat.com/~katzj/redhat-config-packages/ in the next week or so.
Comment 2 Jeremy Katz 2002-10-31 17:59:25 EST
*** Bug 76913 has been marked as a duplicate of this bug. ***
Comment 3 Jeremy Katz 2002-11-08 10:45:11 EST
*** Bug 77512 has been marked as a duplicate of this bug. ***
Comment 4 Jeremy Katz 2002-11-30 11:41:50 EST
*** Bug 78779 has been marked as a duplicate of this bug. ***
Comment 5 Jeremy Katz 2002-12-10 23:46:28 EST
*** Bug 79213 has been marked as a duplicate of this bug. ***
Comment 6 Jeremy Katz 2002-12-22 22:11:55 EST
*** Bug 80234 has been marked as a duplicate of this bug. ***
Comment 7 Jeremy Katz 2002-12-31 10:26:08 EST
*** Bug 80789 has been marked as a duplicate of this bug. ***
Comment 8 Juan J. Peña 2003-01-06 14:23:04 EST
When installing the updated version of redhat-config-package found on the link   
that Jeremy gave, RPM says "rpm-python >= 4.2 is needed by 
redhat-config-packages-1.1.2-1" 
 
So far I have been unable to find a rpm-python with a version so high, not 
even inside RHN nor in Python.org. Anyways, installed with the --nodeps option 
and everything seems to work fine so far. 
 
Just for you to know. 
Comment 9 Josep L. Guallar-Esteve 2003-01-19 23:30:35 EST
Hi,

Is this bug going to be solved? It's remarkably annoying for (at least) Spanish
users. I'm seeing questions about this once and again on Spanish Linux newsgroups.

Maybe you could move Jeremy's version to up2date.

HTH
Comment 10 Jeremy Katz 2003-01-25 11:36:48 EST
*** Bug 82737 has been marked as a duplicate of this bug. ***
Comment 11 Jeremy Katz 2003-02-04 12:53:21 EST
*** Bug 83450 has been marked as a duplicate of this bug. ***
Comment 12 tirant 2003-02-27 13:13:13 EST
Adding myself to CC List. Sorry for the spam, but this is a *VERY IMPORTANT* bug.
Comment 13 Seth Vidal 2003-11-19 01:56:28 EST
is this true on rhl 9 or fedora core 1?

Has this bug been fixed?

I can't get this to occur on fedora core 1 but I might not be
generating it properly.
Comment 14 Jeremy Katz 2003-11-19 16:42:40 EST
Should be fixed -- was a bad translation in that version IIRC

Note You need to log in before you can comment on or make changes to this bug.