Bug 75197 - Install failure with Anaconda / RPM
Install failure with Anaconda / RPM
Status: CLOSED DUPLICATE of bug 75377
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
: 77187 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2002-10-05 07:17 EDT by David Wilson
Modified: 2007-04-18 12:47 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 13:49:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Install failure message from Anaconda (62.81 KB, text/plain)
2002-10-05 07:21 EDT, David Wilson
no flags Details
Install failure message from Anaconda (62.81 KB, text/plain)
2002-10-05 07:23 EDT, David Wilson
no flags Details
Install failure message from Anaconda (62.81 KB, text/plain)
2002-10-05 07:28 EDT, David Wilson
no flags Details
torrent@nixe.com (68.26 KB, patch)
2002-10-07 12:17 EDT, Need Real Name
no flags Details | Diff
torrent@nixe.com (68.26 KB, patch)
2002-10-07 12:18 EDT, Need Real Name
no flags Details | Diff
Dump from install program, stoped at the same line as others (91.14 KB, text/plain)
2002-10-14 10:19 EDT, Gautam Saha
no flags Details
Anaconda (installation) dump file (86.01 KB, text/plain)
2002-10-28 15:26 EST, fbadescu
no flags Details
dump created by anaconda (69.95 KB, text/plain)
2002-11-20 00:30 EST, Pierre Honeyman
no flags Details

  None (edit)
Description David Wilson 2002-10-05 07:17:25 EDT
Description of Problem:
I have tried numerous times to install RH8.0 on a system with an AMD K6-200 with
American Megatrends bios. Release 12/15/1997 S.  I have tried both text and GUI
installs on this machine.  

I can't tell if it is an RPM or Anaconda issue, the dump from the install
program will follow

Version-Release number of selected component (if applicable):
RPM 4.04

How Reproducible:
Very.   I have made around 12 attempts to install the software, none sucessful. 
it has on one occasion made it past the formatting of the drive and started to
install the first packages from the CDROM. The machine passes memtest 86 and the
media verifys as being fine.  I have used the install disks on an AMD XP1600
machine without a problem.

Steps to Reproduce:
1. Boot from CDROM 
2. Go through the setup screens and complete everything required before
formatting the drive
3. Things seem to die shortly after the read test for all partitions is

Actual Results:
A complaint from Anaconda (attached)

Expected Results:
Completed install

Additional Information
I disabled internal and external cache on this board.  I tried various PIO
settings, auto mode and LBA 32Bit and 32Bit Mode settings. on the IDE
interface.  The system has 64MB of RAM, over 256 MB of swap set up on the
AMI bios ID:
Comment 1 David Wilson 2002-10-05 07:21:55 EDT
Created attachment 78865 [details]
Install failure message from Anaconda
Comment 2 David Wilson 2002-10-05 07:23:56 EDT
Created attachment 78866 [details]
Install failure message from Anaconda
Comment 3 David Wilson 2002-10-05 07:28:48 EDT
Created attachment 78867 [details]
Install failure message from Anaconda
Comment 4 Need Real Name 2002-10-07 12:12:07 EDT
I have the same problem. Seeing the dump files, I found that the error occurs 
at the same line.
I have an Intel 440bx2, Pentium II 350, 128 RAM, 2 HD IDE, 1 CD IDE.
I tried installing GUI and text mode.
I also tried to do network install, but the process hanged up when it was 
installing rpm files.
I tried to do a Sever Install (Mail, Network, KDE, X, and so).

This is my dump file
Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 786, in handleRenderCallback
  File "/usr/lib/anaconda/iw/progress_gui.py", line 149, in renderCallback
  File "/usr/lib/anaconda/gui.py", line 632, in nextClicked
  File "/usr/lib/anaconda/dispatch.py", line 150, in gotoNext
  File "/usr/lib/anaconda/dispatch.py", line 215, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 628, in doInstall
    db = rpm.opendb(1, instPath)
rpm404.error: cannot open 

If you need all my dump, please let me know.

Thank you
Comment 5 Need Real Name 2002-10-07 12:17:00 EDT
Created attachment 79224 [details]
Comment 6 Need Real Name 2002-10-07 12:18:21 EDT
Created attachment 79225 [details]
Comment 7 Jeremy Katz 2002-10-09 11:24:05 EDT
When you say that the media verifies as being fine, this is that it verifies
using the built-in media check in anaconda described at
Comment 8 David Wilson 2002-10-09 14:39:15 EDT
I verified that the media was good with the test routine on the cdrom.  It was
downloaded from an FTP site.
Since this effort I finally decided to do a network load.  I was able to install
everything from the net
without a problem.
Comment 9 Gautam Saha 2002-10-14 10:16:30 EDT
I have the Same problem. I am trying a server install with most of the components. In CD disk#3 it gives me the error. I have the dump saved which I will attached.
I stops at the same line  - Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 786, in handleRenderCallback    
  File "/usr/lib/anaconda/iw/progress_gui.py", line 149, in renderCallback .......
I checked all the install disks using the tool provided by the RH8.0 anaconda install program (disk1).
I have a AMD Athlon 750 CPU.
What is the fix? Did any one able to install some how?
Comment 10 Gautam Saha 2002-10-14 10:19:41 EDT
Created attachment 80304 [details]
Dump from install program, stoped at the same line as others
Comment 11 Tom Barrett 2002-10-16 13:09:06 EDT
I have tried to install at least 15 times.  anaconda stops with an exception every time.  However, the exception occurs at a different spot each time.  
In the last 9 tries, I recorded the point where the exception terminated the installation.  There are 501 packages to install for my configuration and I 
had failures at random points while installing from CD1 and CD2.  Here are the number of  packages left to install when each of the 9 installation 
attempts failed (this illustrates the randomness):
                                 #1 191
                                 #2 43
                                 #3 465
                                 #4 246
                                 #5 267
                                 #6 22
                                 #7 443
                                 #8 199
                                 #9 21
You can see that on tries #6 and #9, I got within 22 and 21 packages from being finished.  How frustrating.  Since then, I have been scaling down 
the number of packages I elect to initially install, but I keep getting failure before I reach the end of the installer.

Here is a walkthrough of what I see.  In one of my most resent attempts, I restarted the installer and saw this sequence when the error occurs:

1.  Dialog window displays: The file /mnt/sysimage/var/tmp/python-2.2.1-17.i386.rpm cannot be opened.  This is due to a missing file, a bad 
package, or bad media.  Press <return> to try again.

2.  I press return and see:

3.  Dialog window displays:  An unhandled exception has occurred.  This is most likely a bug.  Please copy the full text of this exception or 
save the crash dump to a floppy then file a detailed bug report against anaconda at 

4.  I click Save to floppy button and get the following saved to my diskette followed by a message: "Your system's 
state has been successfully written to the floppy.  Your system will now be reset.  I press OK. I have the anaconda dump I can share with you.

Please let me know where to go from here.  I keep trying over and over again in hopes of making it all the way through all 501 packages.  I don't 
understand why the failure is happening at random points.  I would feel better if it always failed at the same place.  Another note, I also selected the 
media to be verified in the installer.  No errors were found.
Comment 12 Need Real Name 2002-10-23 15:48:50 EDT
I received the same dump as torrent@nixe.com before anything was installed using
a NFS install to a Dell GX100 with the GUI. The system uses a Celeron CPU AND
the i810 chipset. A text based install via NFS worked fine on that system.  I
then did a GUI install via NFS to a Dell GX150 that has a Riva TNT card and that
worked as well.  hth
Comment 13 carlos carrillo 2002-10-23 20:02:55 EDT
I'm experiencing the exact same failure on my AMD Athlon 750/512 RAM/existing 
VFAT partition.
Comment 14 Sean Barbour 2002-10-24 03:00:50 EDT
I am having the same problem with every machine choosing either a canned setup
or installing everything. I didn't attach the message from Anaconda since others
have posted the same one. I tried the patch that was posted (and followed the
directions for the media check and disabled the some bios settings ). Of cource
nothing worked. However I did notice something when i was doing the expert text
install. The error message that stated that it could not find the rpm file (its
random with every attempt), it was looking in /tmp/source//RedHat/RPMS/. I went
to the CLI and I was able to cded into that directory and do a ls on the file
name which produced the file. Could this have something to do with the fact that
the path has the "//" in it? I tried to move the /tmp directory and create a
symlink but it i failed to get the link to work (still new at this).  Also, I
started to get a bad hardware or not enough disk space errors along with the
files that are MIA. I was able to install 7.3 and try to do an upgrade (which
made matters worse), now I cannot even reinstall 7.3 without getting the same
errors. I know its not a disk space issue, or a hardware issue since I was able
to install 7.3 and I tested all of my hardware. Here's my system:

AMD 1 gighz
384 MB RAM
40 GB HDD 66/100ATA
20 GB HDD 66/100ATA
Asus Motherboard with Promise 100ATA.

sorry for the long message, just though it might be of some help.
Comment 15 fbadescu 2002-10-28 15:24:15 EST
I'm having the same problem, on a PIII-500MHz, 440BX chipset, 256MB RAM, with a
SCSI Seagate Cheetah harddisk. It's been two weeks by now since I've started.
Thomas Barrett is right: how frustrating it is to have only 5 MB left out of the
installation, and then the installer crashes  !

Anaconda crashes at random times, while accessing different CDs (CD 1, or CD 2,
or CD 3). It crashes when installing big files (Open Office), and when
installing small ones (ftp). And, rather than giving you a choice of either to
try to re-load that specific file, or to skip it and go on with the
installation, it chooses to exit the installation.

I am so frustrated that I've decided to go back to RH 7.3 and stay there until
this bug is being fixed FOR GOOD.
Comment 16 fbadescu 2002-10-28 15:26:28 EST
Created attachment 82445 [details]
Anaconda (installation) dump file
Comment 17 Tivadar Horvath 2002-10-28 16:57:31 EST
I tried to install both RH7.3 and 8.0 on a Compaq Deskpro 2000 (Pentium 
166/MMX, 128 RAM, 3 GByte HD). After making the selections for the install and 
formatting the HD, Anaconda fails installing the very first package. The issue 
is very consistent regardless which features I choose.
What is interesting that when I originally had only 32 Mbyte RAM then Anaconda 
failed while creating the Swap memmory while with 128 it failed a little bit 
I was able to install the Suse Linux 8.0 without any problems on the same 
machine. I am curious to see though if RH finds the solution eventually.
Comment 18 Need Real Name 2002-11-04 10:28:36 EST
*** Bug 77187 has been marked as a duplicate of this bug. ***
Comment 19 Pierre Honeyman 2002-11-20 00:27:23 EST
I have had exactly the same problem.  My system is:
- AMD Athlon XP 2100+ processor
- MSI KT4 Ultra motherboard
- not overclocked.

Every time I try to install Redhat 8.0 I get exactly this problem.

Comment 20 Pierre Honeyman 2002-11-20 00:30:45 EST
Created attachment 85647 [details]
dump created by anaconda
Comment 21 Troy Fraley 2003-01-01 17:41:43 EST
I have the same issue and it happens every time I try to install RH8.0 on my 
AMD 1.4t-bird w/512mb on a BiostarM7V board. It always happens when the install 
reaches the S-Lang files

Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 786, in handleRenderCallback
  File "/usr/lib/anaconda/iw/progress_gui.py", line 149, in renderCallback
  File "/usr/lib/anaconda/gui.py", line 632, in nextClicked
  File "/usr/lib/anaconda/dispatch.py", line 150, in gotoNext
  File "/usr/lib/anaconda/dispatch.py", line 215, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 719, in doInstall
    problems = ts.run(0, ~rpm.RPMPROB_FILTER_DISKSPACE, cb.cb, 0)
  File "/usr/lib/anaconda/packages.py", line 283, in cb
    fn = self.method.getFilename(h, self.pkgTimer)
  File "/usr/lib/anaconda/image.py", line 119, in getFilename
    f = open("/mnt/source/.discinfo")
IOError: [Errno 2] No such file or directory: '/mnt/source/.discinfo'
Comment 22 Michael Lee Yohe 2003-01-07 15:52:51 EST
Some of you are encountering one common bug, and some of you are encountering
another Anaconda weirdism altogether.  If you are encountering the "can't find
/mnt/source/.discinfo" bug, you'll find some handy information by checking out
Bug 75377.

For those not experiencing the .discinfo bug, you may want to follow the
procedures found in Bug 75377 (using the updates disk) to absorb some
modifications to Anaconda since Red Hat Linux 8.0 gold was released.  It may
help you out.
Comment 23 Bill 2003-03-01 17:19:22 EST
I have the exact problem as described here.  I have done the media checks as 

Asus A7V with AMD 1200
512 ram
40 gb hd with nothing else on it
geforce 3
sb live

Comment 24 Bill 2003-03-02 03:38:06 EST
Ok, i tried the 'linux updates' thing with the diskette and it works perfectly 
Comment 25 Bill 2003-03-02 14:50:25 EST
Ok, I spoke too soon.  I was trying several different installations and this 
is what i found:

This fix solved the problem for CD 1.  When a bad package was encountered, it 
would spit out and remount the CDROM.

However, now on CD 2 it crashes in a different way than before.  It never 
opens the drive and spits out the CD.  I can eject it manually and reinsert 
but that does not help.  I even tried CD's 1 & 3 just in case.  It keeps 
popping up the same screen that says:

" The file /mnt/sysimage/var/tmp/???.rpm cannot be opened.  This is due to a 
missing file, a bad package, or bad media. Press <return> to try again. "

I hit return, the ok button goes grey, then the ok button goes ungrey.  The 
error box necer goes away.  A traceback is never returned either.  It is stuck 
and i have to reboot.

So far i have received this message with two different rpms. (OpenOffice and 
the KDE low color icon set)
Comment 26 Ricardo Zayola 2003-03-12 11:50:52 EST
I have read all the comments and I've got the same problem, I hope this issue 
will be fixed quickly. The processor is an AMD 1.2Ghz
Comment 27 Michael Fulbright 2003-03-13 16:40:51 EST

*** This bug has been marked as a duplicate of 75377 ***
Comment 28 Red Hat Bugzilla 2006-02-21 13:49:45 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.