Bug 75281 - apxs -i does not work due missing instdso.sh (http-devel package)(
apxs -i does not work due missing instdso.sh (http-devel package)(
Status: CLOSED DUPLICATE of bug 73428
Product: Red Hat Linux
Classification: Retired
Component: httpd (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-06 15:09 EDT by paluch
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-06 15:09:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description paluch 2002-10-06 15:09:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.8 [en] (X11; U; Linux 2.4.18-14 i686)

Description of problem:
When invoking apxs -i (install module) it will fail with this message:
/usr/sbin/apxs -i -a -n php4 libphp4.la
/usr/lib/httpd/build/instdso.sh SH_LIBTOOL='/usr/lib/httpd/build/libtool'
libphp4.la /usr/lib/httpd/modules
sh: line 1: /usr/lib/httpd/build/instdso.sh: No such file or directory
apxs:Error: Command failed with rc=8323072


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. tar xfj php-4.2.3.tar.bz2
2. ./configure --with-apxs2=/usr/sbin/apxs
3. make
4. make install


Actual Results:  make[1]: Entering directory `/tmp/php-4.2.3'
/usr/sbin/apxs -i -a -n php4 libphp4.la
/usr/lib/httpd/build/instdso.sh SH_LIBTOOL='/usr/lib/httpd/build/libtool'
libphp4.la /usr/lib/httpd/modules
sh: line 1: /usr/lib/httpd/build/instdso.sh: No such file or directory
apxs:Error: Command failed with rc=8323072
.

Expected Results:  Installation of apache module into /usr/lib/httpd/modules

Additional info:

When instdso.sh is manually copied into /usr/lib/httpd/build (from
httpd-2.0.40-8.src.rpm) then the apxs -i works ok.
Comment 1 Joe Orton 2002-10-07 06:20:17 EDT

*** This bug has been marked as a duplicate of 73428 ***

Note You need to log in before you can comment on or make changes to this bug.