Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 756833 - Can't type in code::blocks with ibus after certain control characters are typed
Can't type in code::blocks with ibus after certain control characters are typed
Status: CLOSED DUPLICATE of bug 769133
Product: Fedora
Classification: Fedora
Component: codeblocks (Show other bugs)
16
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Dan Horák
Fedora Extras Quality Assurance
http://developer.berlios.de/bugs/?fun...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-24 14:27 EST by James
Modified: 2012-01-03 09:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-03 09:10:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James 2011-11-24 14:27:46 EST
This behaviour appears only in code::blocks if ibus is enabled, so I am not sure which component has the bug. A bug has been filed on the code::blocks project http://developer.berlios.de/bugs/?func=detailbug&bug_id=18417&group_id=5358 and I see exactly the same problem the filer is seeing.

The Problem:
I normally have ibus enabled in English mode. If I start code::blocks I can type text okay until I press one of the following keys: Any arrow key, 'Tab', 'Enter', Insert', 'Delete', 'Backspace', 'Home' and 'End'. These keys are 'executed' in the editor windows but all keyboard cursor commands and visible characters typed after that are ignored. I have found using Ctrl-Z undoes the text typed before the ignored keys, and then lets me continue typing normally. It seems as though the control keys are 'blocking' subsequent key presses until Ctrl-Z is hit.

* 'Alt', 'Ctrl' and 'Shift' do not cause the problem
* This does not affect code::blocks dialog boxes in any way.
* Quitting ibus fixes it and restarting code::blocks fixes it.
* I have not seen this problem in Nedit or Abiword

Versions:
Fedora 16/XFCE
ibus 1.4.0
code::blocks 10.05
Comment 1 James 2011-11-24 14:29:46 EST
That should read
* Quitting ibus and restarting code::blocks fixes it.
Comment 2 Dan Horák 2011-11-28 04:48:38 EST
Hm, very interesting problem, which could be related to Scintilla, the editor component of C::B. Could you try the latest nightly build of C::B from http://fedora.danny.cz/danny/ ?
Comment 3 James 2011-11-30 14:16:18 EST
Thanks for the response. I don't know when I'll be able to test a new release.

I did try a few more typing experiments. 

1. Type any ASCII characters, except \t and \n.
2. Press Tab and observe tab character is printed
3. Type any ASCII characters(except \t and \n) and observe all are ignored
4. Type Tab, Enter or Backspace and observe these still work
5. Press Ctrl, Alt or Shift
6. Type any ASCII characters, except \t and \n, and observe these work again.

This behaviour is NOT consistent across all input methods. In at least one all characters I type show up in code::blocks.

Quitting ibus immediately restores normal behaviour. No need to restart code::blocks or press Ctrl, Alt or Shift to fix it.
Comment 4 James 2011-11-30 16:44:04 EST
This now looks like an ibus issue. I see a different problem in Nedit that is fixed by quitting ibus.
Comment 5 James Edgar 2012-01-02 01:14:16 EST
ibus-1.4.0-16.fc16 appears to fix this issue.

see:  https://bugzilla.redhat.com/show_bug.cgi?id=769133

Package ibus-1.4.0-16.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-1.4.0-16.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-17574/ibus-1.4.0-16.fc16
then log in and leave karma (feedback).
Comment 6 James 2012-01-03 09:10:46 EST

*** This bug has been marked as a duplicate of bug 769133 ***

Note You need to log in before you can comment on or make changes to this bug.