Bug 758889 - IBUS blocks typing in certain applications
IBUS blocks typing in certain applications
Status: CLOSED DUPLICATE of bug 769133
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
16
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-30 16:58 EST by James
Modified: 2011-12-30 01:03 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Fedora F16/XFCE/x86_64 Nedit 5.5(F16 build) IBUS 1.2.0
Last Closed: 2011-12-30 01:03:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James 2011-11-30 16:58:36 EST
Here is what I see:

Case 1: 
1. Login with ibus enabled in English mode
2. Execute 'nedit blah.txt' and click new file
3. Any typed text is ignored
4. Quit ibus
5. Attempt to type text in nedit results in nedit crashing (SIGSEGV)

Case 2:
1. Login with ibus enabled in English mode
2. Quit ibus
3. Execute 'nedit blah.txt' and click new file
4. Text can be typed as expected

There are other corner cases beyond these. Note that this is different than the cut+paste issue with LessTif. I have not yet seen that problem in F16.

I filed a related bug against code::blocks.


Fedora F16/XFCE/x86_64
Nedit 5.5(F16 build)
IBUS 1.2.0
Comment 1 fujiwara 2011-12-30 01:03:35 EST

*** This bug has been marked as a duplicate of bug 769133 ***

Note You need to log in before you can comment on or make changes to this bug.