This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 758480 - LXDM: can't login without a mouse
LXDM: can't login without a mouse
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lxdm (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
http://sourceforge.net/tracker/?func=...
: Reopened
: 788540 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-29 16:55 EST by Konstantin Svist
Modified: 2012-04-03 15:55 EDT (History)
2 users (show)

See Also:
Fixed In Version: lxdm-0.4.1-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-23 13:42:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Konstantin Svist 2011-11-29 16:55:50 EST
Description of problem:
In GDM, user can be selected on the keyboard with up/down/enter keys. In LXDM this doesn't work.
Pressing down twice switches to password dialog, but it's uncertain which user (if any) was selected.


Version-Release number of selected component (if applicable):
lxdm 0.3.0-4.fc16

How reproducible:
every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
lxde.org is down, so filing here
Comment 1 Christoph Wickert 2011-11-29 18:49:45 EST
Please file this issue in the LXDE bug tracker at
http://sourceforge.net/tracker/?group_id=180858&atid=894869.

Once you have done this, please add a link to the item in the "See Also" field and close this bug with the resolution "Upstream".
Comment 3 Christoph Wickert 2011-11-30 14:14:42 EST
Thanks, I keep watching the upstream bug.
Comment 4 Konstantin Svist 2011-12-30 16:04:24 EST
Please push 0.4 into the repos (at least updates-testing)
Comment 5 Konstantin Svist 2012-01-11 20:09:25 EST
*ping*
Comment 6 Christoph Wickert 2012-01-12 01:48:45 EST
Pong!

Please keep in mind that Fedora is a volunteer effort. If you like to help out, please read https://fedoraproject.org/wiki/PackageMaintainers/Join
I'd be happy to make you co-maintainer.

The reason why I didn't yet update lxdm is bug 716100.
Comment 7 Konstantin Svist 2012-01-12 14:11:12 EST
Thanks very much for response!
I'm not sure if I'd have enough time to be a co-maintainer (how much time do you need to devote to it, normally?). But I definitely want to help you push this one through, this bug is causing me a lot of grief!
Comment 8 Christoph Wickert 2012-02-08 07:33:08 EST
*** Bug 788540 has been marked as a duplicate of this bug. ***
Comment 9 Christoph Wickert 2012-02-15 16:38:00 EST
(In reply to comment #6)
>
> The reason why I didn't yet update lxdm is bug 716100.

Sorry, I meant bug 767861.
Comment 10 Fedora Update System 2012-03-21 16:49:35 EDT
lxdm-0.4.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/lxdm-0.4.1-1.fc17
Comment 11 Fedora Update System 2012-03-21 16:52:17 EDT
lxdm-0.4.1-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/lxdm-0.4.1-1.fc16
Comment 12 Fedora Update System 2012-03-21 16:59:06 EDT
lxdm-0.4.1-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/lxdm-0.4.1-1.fc15
Comment 13 Fedora Update System 2012-03-21 21:55:00 EDT
Package lxdm-0.4.1-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lxdm-0.4.1-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-4399/lxdm-0.4.1-1.fc16
then log in and leave karma (feedback).
Comment 14 Konstantin Svist 2012-03-22 16:32:09 EDT
Works pretty well. One issue I've noticed is related to a non-standard boot procedure I'm using -- when booting without initramfs, mouse cursor stays invisible on the 1st login. If I log in and log out, cursor appears correctly. Sounds like it should be a separate bug, though
Comment 15 Fedora Update System 2012-03-23 13:42:13 EDT
lxdm-0.4.1-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2012-04-03 15:53:03 EDT
lxdm-0.4.1-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2012-04-03 15:55:00 EDT
lxdm-0.4.1-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.