Bug 759337 - Translation editor: Long word in source cell invades the editor cell
Summary: Translation editor: Long word in source cell invades the editor cell
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Zanata
Classification: Retired
Component: Component-UI
Version: 1.4.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Alex Eng
QA Contact: Carlos Munoz
URL:
Whiteboard:
: 760828 (view as bug list)
Depends On:
Blocks: 755773 zanata-1.5.0
TreeView+ depends on / blocked
 
Reported: 2011-12-02 02:23 UTC by Ding-Yi Chen
Modified: 2012-06-29 01:12 UTC (History)
6 users (show)

Fixed In Version: 1.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-07 00:06:43 UTC


Attachments (Terms of Use)
Screen shoot of the symptom (540.08 KB, image/png)
2011-12-02 02:23 UTC, Ding-Yi Chen
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 834145 None None None Never

Internal Links: 834145

Description Ding-Yi Chen 2011-12-02 02:23:29 UTC
Created attachment 539480 [details]
Screen shoot of the symptom

Description of problem:
When encounter an unbreakable long word, usually url, near the right border of source cell, the long word does not wrap properly and shows on top of editor cell.

This does not only looks bad, but also make "copy from source" button hard to press.

Version-Release number of selected component (if applicable):
Zanata version 1.4.1 (20111006-0937)
This also appear in 1.4.3

How reproducible:
Always

Steps to Reproduce:
1. login in translate.jboss.org
2. Go to "JBoss EAP - Security Guide", version 5.1.0, click translate (any language will do)
3. click Document "chap-JBoss_Security_Extension_Architecture"
4. Normally the symptom can already be seen. If not, narrower the browser.
  
Actual results:
Long source word invaded the editor cell.

Expected results:
Long source word stays in source cell/column.

Additional info:
Two workarounds:
1. Use bigger screen.
2. Opera seems to handle the rendering properly.

Comment 1 Runa Bhattacharjee 2011-12-07 05:38:46 UTC
*** Bug 760828 has been marked as a duplicate of this bug. ***

Comment 2 Alex Eng 2012-02-22 06:15:34 UTC
Bug fixed in 1.5. See https://github.com/zanata/zanata/commit/fbd647830843d3a18a3e548e3d55290aeb6f3212

Implementation: 
Google Chrome - word break properly.(CSS 3)
Firefox - Scroll bar on X-axis if word break didn't act. (CSS 2)

Comment 4 Carlos Munoz 2012-02-23 23:55:20 UTC
Works well on Firefox 3.6, displaying the horizontal scroll bar.
On Chrome it starts out fine, but after resizing the browser window back and forth multiple times, the text overflows on top of the adjacent columns.

Comment 6 Carlos Munoz 2012-02-27 06:01:59 UTC
Verified with Zanata version 1.5.0-alpha-3-SNAPSHOT (20120227-1458).


Note You need to log in before you can comment on or make changes to this bug.