Bug 761540 - Install fails on EFI machine
Install fails on EFI machine
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
unspecified
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Joey Boggs
:
Depends On: 783211
Blocks: 749621 753297 773069 824928
  Show dependency treegraph
 
Reported: 2011-12-08 10:08 EST by Mike Burns
Modified: 2016-04-26 21:24 EDT (History)
14 users (show)

See Also:
Fixed In Version: 2.2.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 749621
Environment:
Last Closed: 2012-01-30 08:54:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Burns 2011-12-08 10:08:49 EST
ovirt-node installation fails when booted in EFI mode.


Partitioning should already setup the EFI partition, but we don't currently populate it correctly.

We need to make sure that we can boot on EFI machines correctly but still maintain compatibility with non EFI machines
Comment 1 Alan Pevec 2011-12-08 11:31:24 EST
Here's how anaconda detects efi system: http://git.fedorahosted.org/git/?p=anaconda.git;a=blob;f=pyanaconda/iutil.py;h=d29bf1edf174dc50ebcbc6cd3251fb9248a7f678;hb=HEAD#l698

And here's how to install EFI bootloader:
http://www.rodsbooks.com/efi-bootloaders/installation.html

Easiest seems to be to just copy grub.efi to the default boot loader's location EFI/BOOT/BOOTX64.EFI
Comment 3 Perry Myers 2012-01-18 10:40:04 EST
This didn't make 2.2.1, so moving to 2.2.2.

@jboggs, can you update status here?
Comment 4 Joey Boggs 2012-01-25 12:53:52 EST
current status is waiting on https://bugzilla.redhat.com/show_bug.cgi?id=783211

Once it makes it into the stable repos and remaining uefi patches acked/merged we will have a working install.
Comment 6 Mike Burns 2012-01-30 08:54:26 EST
Bug fixed in 2.2.2 release

Note You need to log in before you can comment on or make changes to this bug.