Bug 824928 - boot fails on EFI machine after installed when booting in EFI mode from optical media
boot fails on EFI machine after installed when booting in EFI mode from opti...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.2
Unspecified Unspecified
urgent Severity medium
: rc
: 6.3
Assigned To: Mike Burns
Virtualization Bugs
:
Depends On: 747102 749621 761540
Blocks: 729698 773069 773650 773651 773677 773696
  Show dependency treegraph
 
Reported: 2012-05-24 12:04 EDT by Mike Burns
Modified: 2016-04-26 10:46 EDT (History)
21 users (show)

See Also:
Fixed In Version: ovirt-node-2.3.0-9.el6
Doc Type: Bug Fix
Doc Text:
When the Hypervisor configures the boot menu for EFI it extracts the CDLABEL from the isolinux.cfg file. The entry in the file contains a period ('.'), which is not matched correctly by the regular expression used to extract the CDLABEL. As a result the kernel parameters generated contained an invalid CDLABEL, resulting in a kernel panic. The regular expression used to extract the CDLABEL has been updated to do so correctly.
Story Points: ---
Clone Of: 749621
Environment:
Last Closed: 2012-07-19 10:13:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mike Burns 2012-05-24 12:04:18 EDT
+++ This bug was initially created as a clone of Bug #749621 +++

This only happens with official image builds.  On boot, a kernel panic happens almost immediately.

Root Cause:

When configuring the boot menu for EFI, we extract the CDLABEL from the regular isolinux.cfg.  The cdlabel for official builds contains a '.' which our automated builds do not.  Because of this '.', the extraction broke causing the commandline to include root=live:CDLABEL= which causes an immediate panic.
Comment 6 Guohua Ouyang 2012-06-01 07:58:32 EDT
verified on 6.3-20120531.0 build, 
1. can reproduce on 6.3-20120523.1, boot will run into kernel panic.

2. tested 6.3-20120531.0 with EFI mode, boot from the iso image successfully and after install finished, rhevh boot normal and can login also.
Comment 7 Stephen Gordon 2012-06-14 14:58:54 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
When the Hypervisor configures the boot menu for EFI it extracts the CDLABEL from the isolinux.cfg file. The entry in the file contains a period ('.'), which is not matched correctly by the regular expression used to extract the CDLABEL. As a result the kernel parameters generated contained an invalid CDLABEL, resulting in a kernel panic. The regular expression used to extract the CDLABEL has been updated to do so correctly.
Comment 9 errata-xmlrpc 2012-07-19 10:13:10 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0741.html

Note You need to log in before you can comment on or make changes to this bug.