Bug 762184 (GLUSTER-452) - Support mandatory locking in glusterfs
Summary: Support mandatory locking in glusterfs
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: GLUSTER-452
Product: GlusterFS
Classification: Community
Component: locks
Version: mainline
Hardware: All
OS: All
medium
medium
Target Milestone: ---
Assignee: Anoop C S
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1332162
TreeView+ depends on / blocked
 
Reported: 2009-12-07 13:17 UTC by Pavan Vilas Sondur
Modified: 2016-07-08 09:52 UTC (History)
4 users (show)

Fixed In Version: glusterfs-3.8.0
Doc Type: Enhancement
Doc Text:
Clone Of:
: 1332162 (view as bug list)
Environment:
Last Closed: 2016-06-17 07:22:16 UTC
Regression: RTP
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Pavan Vilas Sondur 2009-12-07 13:17:22 UTC
Need to get mandatory locking supported over glusterfs.

Comment 1 Vijay Bellur 2010-08-28 09:15:51 UTC
No immediate plans to address this.

Comment 2 Anand Avati 2015-02-27 09:30:45 UTC
REVIEW: http://review.gluster.org/9768 (features/locks: Fixing mandatory-locking code path) posted (#1) for review on master by Anoop C S (achiraya@redhat.com)

Comment 3 Anand Avati 2015-03-12 11:53:57 UTC
REVIEW: http://review.gluster.org/9768 (features/locks: Fixing mandatory-locking code path) posted (#2) for review on master by Anoop C S (achiraya@redhat.com)

Comment 4 Anand Avati 2015-03-30 08:47:13 UTC
REVIEW: http://review.gluster.org/9768 (features/locks: Fixing mandatory-locking code path) posted (#3) for review on master by Anoop C S (achiraya@redhat.com)

Comment 5 Anand Avati 2015-04-29 11:54:35 UTC
REVIEW: http://review.gluster.org/9768 (features/locks: Fixing mandatory-locking code path) posted (#4) for review on master by Anoop C S (achiraya@redhat.com)

Comment 6 Anand Avati 2015-05-04 09:49:28 UTC
REVIEW: http://review.gluster.org/9768 (features/locks: Fixing mandatory-locking code path) posted (#5) for review on master by Anoop C S (achiraya@redhat.com)

Comment 7 Anand Avati 2015-06-04 11:00:05 UTC
REVIEW: http://review.gluster.org/9768 (features/locks: Fixing mandatory-locking code path) posted (#7) for review on master by Anoop C S (achiraya@redhat.com)

Comment 8 Anand Avati 2015-06-04 11:00:08 UTC
REVIEW: http://review.gluster.org/11082 (features/locks: Include zerofill fop in locks translator) posted (#2) for review on master by Anoop C S (achiraya@redhat.com)

Comment 9 Anand Avati 2015-06-05 05:35:42 UTC
REVIEW: http://review.gluster.org/9768 (features/locks: Fixing mandatory-locking code path) posted (#8) for review on master by Anoop C S (achiraya@redhat.com)

Comment 10 Anand Avati 2015-06-05 05:35:45 UTC
REVIEW: http://review.gluster.org/11082 (features/locks: Include zerofill call in locks translator) posted (#3) for review on master by Anoop C S (achiraya@redhat.com)

Comment 11 Anand Avati 2015-06-08 11:53:27 UTC
REVIEW: http://review.gluster.org/9768 (features/locks: Fixing mandatory-locking code path) posted (#9) for review on master by Anoop C S (achiraya@redhat.com)

Comment 12 Anand Avati 2015-06-11 09:13:09 UTC
REVIEW: http://review.gluster.org/9768 (features/locks: Fixing mandatory-locking code path) posted (#10) for review on master by Anoop C S (achiraya@redhat.com)

Comment 13 Anand Avati 2015-08-24 11:22:00 UTC
REVIEW: http://review.gluster.org/11177 (gfapi: Add API support for applying mandatory-locks) posted (#2) for review on master by Anoop C S (anoopcs@redhat.com)

Comment 14 Anand Avati 2015-08-26 10:22:41 UTC
REVIEW: http://review.gluster.org/11177 (gfapi: Add API support for applying mandatory-locks) posted (#3) for review on master by Raghavendra Talur (rtalur@redhat.com)

Comment 15 Kaleb KEITHLEY 2015-10-22 15:46:38 UTC
because of the large number of bugs filed against mainline version\ is ambiguous and about to be removed as a choice.

If you believe this is still a bug, please change the status back to NEW and choose the appropriate, applicable version for it.

Comment 16 Anoop C S 2015-11-24 09:24:04 UTC
As part of preparing GlusterFS to work with multi-Protocol environment we have to support basic mandatory locking semantics. Please see the following design doc for more details.

http://review.gluster.org/#/c/12014/1/in_progress/Mandatory+Locks.md

Comment 17 Vijay Bellur 2015-12-02 00:59:38 UTC
REVIEW: http://review.gluster.org/9768 (features/locks: Fixing mandatory-locking code path) posted (#12) for review on master by Anoop C S (anoopcs@redhat.com)

Comment 18 Vijay Bellur 2015-12-02 00:59:42 UTC
REVIEW: http://review.gluster.org/11082 (features/locks: Include zerofill fop in locks translator) posted (#6) for review on master by Anoop C S (anoopcs@redhat.com)

Comment 19 Vijay Bellur 2015-12-02 07:31:09 UTC
REVIEW: http://review.gluster.org/11177 (gfapi: Add API support for applying mandatory-locks) posted (#5) for review on master by Anoop C S (anoopcs@redhat.com)

Comment 20 Vijay Bellur 2015-12-09 12:32:09 UTC
REVIEW: http://review.gluster.org/9768 (features/locks: Fixing mandatory-locking code path) posted (#13) for review on master by Anoop C S (anoopcs@redhat.com)

Comment 21 Vijay Bellur 2015-12-09 12:32:13 UTC
REVIEW: http://review.gluster.org/11177 (gfapi: Add API support for applying mandatory-locks) posted (#6) for review on master by Anoop C S (anoopcs@redhat.com)

Comment 22 Vijay Bellur 2015-12-09 12:32:17 UTC
REVIEW: http://review.gluster.org/11082 (features/locks: Include zerofill fop in locks translator) posted (#7) for review on master by Anoop C S (anoopcs@redhat.com)

Comment 23 Vijay Bellur 2015-12-09 12:32:20 UTC
REVIEW: http://review.gluster.org/12924 (tests: Add libgfapi test case for mandatory locks) posted (#1) for review on master by Anoop C S (anoopcs@redhat.com)

Comment 24 Vijay Bellur 2016-01-06 07:22:08 UTC
REVIEW: http://review.gluster.org/9768 (features/locks: Fixing mandatory-locking code path) posted (#14) for review on master by Anoop C S (anoopcs@redhat.com)

Comment 25 Vijay Bellur 2016-01-06 07:22:13 UTC
REVIEW: http://review.gluster.org/11177 (gfapi: Add API support for applying mandatory-locks) posted (#7) for review on master by Anoop C S (anoopcs@redhat.com)

Comment 26 Vijay Bellur 2016-01-06 07:22:17 UTC
REVIEW: http://review.gluster.org/11082 (features/locks: Include zerofill fop in locks translator) posted (#8) for review on master by Anoop C S (anoopcs@redhat.com)

Comment 27 Vijay Bellur 2016-01-19 09:09:24 UTC
REVIEW: http://review.gluster.org/9768 (features/locks: Implement mandatory locks) posted (#15) for review on master by Anoop C S (anoopcs@redhat.com)

Comment 28 Vijay Bellur 2016-01-19 09:09:28 UTC
REVIEW: http://review.gluster.org/11177 (libgfapi: Add support for mandatory-locks) posted (#8) for review on master by Anoop C S (anoopcs@redhat.com)

Comment 29 Vijay Bellur 2016-02-05 11:54:53 UTC
REVIEW: http://review.gluster.org/9768 (features/locks: Implement mandatory locks) posted (#16) for review on master by Anoop C S (anoopcs@redhat.com)

Comment 30 Vijay Bellur 2016-02-05 11:54:56 UTC
REVIEW: http://review.gluster.org/11177 (libgfapi: Add new api for supporting mandatory-locks) posted (#9) for review on master by Anoop C S (anoopcs@redhat.com)

Comment 31 Vijay Bellur 2016-02-10 12:57:22 UTC
REVIEW: http://review.gluster.org/9768 (features/locks: Implement mandatory locks) posted (#17) for review on master by Anoop C S (anoopcs@redhat.com)

Comment 32 Vijay Bellur 2016-02-10 12:57:25 UTC
REVIEW: http://review.gluster.org/11177 (libgfapi: Add new api for supporting mandatory-locks) posted (#10) for review on master by Anoop C S (anoopcs@redhat.com)

Comment 33 Vijay Bellur 2016-02-18 12:17:24 UTC
REVIEW: http://review.gluster.org/9768 (features/locks: Implement mandatory locks) posted (#18) for review on master by Anoop C S (anoopcs@redhat.com)

Comment 34 Vijay Bellur 2016-02-18 12:17:27 UTC
REVIEW: http://review.gluster.org/11177 (libgfapi: Add new api for supporting mandatory-locks) posted (#11) for review on master by Anoop C S (anoopcs@redhat.com)

Comment 35 Vijay Bellur 2016-02-18 12:56:14 UTC
REVIEW: http://review.gluster.org/9768 (features/locks: Implement mandatory locks) posted (#19) for review on master by Anoop C S (anoopcs@redhat.com)

Comment 36 Vijay Bellur 2016-02-18 12:56:18 UTC
REVIEW: http://review.gluster.org/11177 (libgfapi: Add new api for supporting mandatory-locks) posted (#12) for review on master by Anoop C S (anoopcs@redhat.com)

Comment 37 Vijay Bellur 2016-03-01 15:58:44 UTC
REVIEW: http://review.gluster.org/11177 (libgfapi: Add new api for supporting mandatory-locks) posted (#13) for review on master by Anoop C S (anoopcs@redhat.com)

Comment 38 Vijay Bellur 2016-03-03 15:01:04 UTC
REVIEW: http://review.gluster.org/9768 (features/locks: Implement mandatory locks) posted (#20) for review on master by Anoop C S (anoopcs@redhat.com)

Comment 39 Mike McCune 2016-03-28 22:15:42 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 40 Vijay Bellur 2016-04-12 18:07:38 UTC
REVIEW: http://review.gluster.org/9768 (features/locks: Implement mandatory locks) posted (#21) for review on master by Anoop C S (anoopcs@redhat.com)

Comment 41 Vijay Bellur 2016-04-13 05:17:56 UTC
REVIEW: http://review.gluster.org/9768 (features/locks: Implement mandatory locks) posted (#22) for review on master by Anoop C S (anoopcs@redhat.com)

Comment 42 Vijay Bellur 2016-04-29 05:33:47 UTC
REVIEW: http://review.gluster.org/9768 (features/locks: Implement mandatory locks) posted (#23) for review on master by Anoop C S (anoopcs@redhat.com)

Comment 43 Vijay Bellur 2016-05-02 11:18:49 UTC
COMMIT: http://review.gluster.org/9768 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 4517bf8dd6de310950cc5a612955aa3a2fddb57e
Author: Anoop C S <anoopcs@redhat.com>
Date:   Wed Feb 4 10:34:33 2015 +0530

    features/locks: Implement mandatory locks
    
    Initial change to fix/enable the mandatory locking support in GlusterFS
    as per the following design:
    
    https://review.gluster.org/#/c/12014/
    
    Accordingly 'locks.mandatory-locking' option is available as part of this
    change which will accept one among the following values:
    
    * off
    * file
    * forced
    * optimal
    
    See design doc for more details
    
    Change-Id: I14c489b3f8af5ebcbfa155a03f0c175e9558ac46
    BUG: 762184
    Signed-off-by: Anoop C S <anoopcs@redhat.com>
    Reviewed-on: http://review.gluster.org/9768
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Poornima G <pgurusid@redhat.com>
    Reviewed-by: Raghavendra Talur <rtalur@redhat.com>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>

Comment 44 Vijay Bellur 2016-06-09 06:55:14 UTC
REVIEW: http://review.gluster.org/11177 (libgfapi: Add new api for supporting mandatory-locks) posted (#14) for review on master by Anoop C S (anoopcs@redhat.com)

Comment 45 Vijay Bellur 2016-06-13 08:48:36 UTC
REVIEW: http://review.gluster.org/11177 (libgfapi: Add new api for supporting mandatory-locks) posted (#15) for review on master by Anoop C S (anoopcs@redhat.com)

Comment 46 Anoop C S 2016-06-13 16:26:46 UTC
BZ #1346010 has been raised to keep track of libgfapi changes related to mandatory-lock support for GlusterFS.

Comment 47 Vijay Bellur 2016-06-15 05:42:36 UTC
REVIEW: http://review.gluster.org/11177 (libgfapi: Add new api for supporting mandatory-locks) posted (#16) for review on master by Anoop C S (anoopcs@redhat.com)

Comment 48 Anoop C S 2016-06-17 07:22:16 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 49 Vijay Bellur 2016-07-08 09:52:42 UTC
REVIEW: http://review.gluster.org/11177 (libgfapi: Add new api for supporting mandatory-locks) posted (#18) for review on master by Anoop C S (anoopcs@redhat.com)


Note You need to log in before you can comment on or make changes to this bug.