This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 76361 - neat has exception when adding network device
neat has exception when adding network device
Status: CLOSED DUPLICATE of bug 76446
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-20 16:55 EDT by Dan Sullivan
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-20 18:21:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
this is the text that neat produces in a window when the exception occurs (2.22 KB, text/plain)
2002-10-20 16:57 EDT, Dan Sullivan
no flags Details

  None (edit)
Description Dan Sullivan 2002-10-20 16:55:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.0.0-10; Linux)

Description of problem:
I am using Ximian and when I open neat and add a network device, an exception is thrown

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Run RH Linix 7.3 with Ximian
2.Open kontrol-panel and open network configuration
3.Press add device
 

Actual Results:  A window pops up stating an exception has occured

Expected Results:  I should have been allowed to add a network device

Additional info:

Traceback (innermost last):
  File "/usr/sbin/neat", line 1402, in ?
    gtk.mainloop()
  File "/home/dobey/ximian-desktop/pygtk/dest/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop
    _gtk.gtk_main()
  File "/home/dobey/ximian-desktop/pygtk/dest/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/neat", line 473, in on_deviceAddButton_clicked
    interface = NewInterfaceDialog()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/gui/NewInterfaceDialog.py", line 82, in __init__
    iface = iface_creator (self.toplevel, do_save = None, druid = self.druid)
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/gui/EthernetInterface.py", line 101, in __init__
    self.hwDruid = ethernetHardware(self.toplevel)
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/gui/EthernetHardwareDruid.py", line 64, in __init__
    self.setup()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/gui/EthernetHardwareDruid.py", line 118, in setup
    list.append(modInfo[i]['description'])
KeyError: description

Local variables in innermost frame:
modInfo: <netconfpkg.Conf.ConfModInfo instance at 84d34a8>
list: ['RealTek RTL8129', 'Raytheon Raylink/WebGear/Aviator PCMCIA wireless', 'SMC Ultra32 EISA', 'DEC 21*40 and clones', 'Lucent Orinoco/Melco PCMCIA wireless (alternate)', 'SMC 91c92 series PCMCIA', 'Aironet 4500 PCI-ISA-i365 wireless', 'Intel EtherExpress/1000', 'PCI NE2000 clones', 'MiCom-Interlan NI5010', '3Com 3c515 Corkscrew', 'SMC 83c170 EPIC/100', 'NI5210 ethernet', 'AT1500, HP J2405A, most NE2100/clone', 'MyriCOM MyriNET SBUS', '3Com EtherLink16', 'AT&T/Lucent/Hitachi ISA WaveLAN', 'SiS 900/7016CI', 'Cabletron E2100', 'NE1000, NE2000, and compatible', 'Intel EtherExpress Pro 100B', 'Allied Telesis AT1700', 'Greenwigh GIrBIL IrDA', 'Older DEC 21040, most 21*40', 'NSC IrDA', 'Sun Quad', 'ICL EtherTeam 16i/32 EISA', '3Com 3c590/3c595/3c90x/3cx980', '3Com 3c589 series PCMCIA', 'Sun BigMac', 'ThunderLAN', '3Com 3c574 series PCMCIA', 'Ansel Communications Model 3200', 'Aironet 4500 PCMCIA wireless', 'Xircom CBE-100 CardBus', 'General Instruments SB1000']
self: <netconfpkg.gui.EthernetHardwareDruid.ethernetHardware instance at 854a580>
i: defxx
Comment 1 Dan Sullivan 2002-10-20 16:57:13 EDT
Created attachment 81224 [details]
this is the text that neat produces in a window when the exception occurs
Comment 2 Michael Schwendt 2002-10-20 18:17:27 EDT
Exactly the same here.
Comment 3 Michael Schwendt 2002-10-20 18:21:23 EDT
Duplicate of bug #76287 (Internet Configuration Wizard). But this report
contains the traceback in the description, not just as an attachment.
Comment 4 Harald Hoyer 2002-10-23 05:31:39 EDT

*** This bug has been marked as a duplicate of 76446 ***
Comment 5 Harald Hoyer 2002-11-15 09:38:55 EST
third beta of erratum for 7.3/7.2/AS2 is available at:
ftp://people.redhat.com/harald/redhat-config-network/1.0.3-1/

Most of the bugs reported have been removed, but as in every software change,
there could be new bugs introduced.

Please report bugs against this with explicitly stating the 1.0.3 version... Thx
and please test.

Note You need to log in before you can comment on or make changes to this bug.