This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 763925 - (GLUSTER-2193) glusterd lockup recovery.
glusterd lockup recovery.
Status: CLOSED DUPLICATE of bug 765052
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
3.1.1
All Linux
low Severity low
: ---
: ---
Assigned To: Pranith Kumar K
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-05 02:14 EST by Harshavardhana
Modified: 2015-03-22 21:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: RTP
Mount Type: ---
Documentation: DNR
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Harshavardhana 2010-12-05 02:14:17 EST
Once in a while due to network issues gluster cli locks up the whole trusted cluster of nodes. 

This makes subsequent gluster cli commands to fail.  Need to way to jumpstart all  the process by relinquishing the locks held.
Comment 1 Harshavardhana 2011-01-26 17:39:11 EST
(In reply to comment #0)
> Once in a while due to network issues gluster cli locks up the whole trusted
> cluster of nodes. 
> 
> This makes subsequent gluster cli commands to fail.  Need to way to jumpstart
> all  the process by relinquishing the locks held.


This is a scenario which we hit almost everyday. 

Node1 is editing volume graph by holding a lock, simultaneously another node tries to delete another volume results in a clash of locks. Latter node just locks up and never comes out of it. 

There is a need for "gluster cli" to be easily relinquish and communicate properly the locks to its friends.
Comment 2 Harshavardhana 2011-08-15 12:06:48 EDT

*** This bug has been marked as a duplicate of bug 3320 ***

Note You need to log in before you can comment on or make changes to this bug.