Bug 765052 - (GLUSTER-3320) Improve handling of concurrent operations in glusterd.
Improve handling of concurrent operations in glusterd.
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: krishnan parthasarathi
:
: GLUSTER-2193 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-03 07:35 EDT by krishnan parthasarathi
Modified: 2015-11-03 18:03 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions: glusterfs-3.3.0qa10
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description krishnan parthasarathi 2011-08-03 07:35:03 EDT
This bug tracks the following changes,

- removal of glusterd's local cli lock and use the cluster wide lock to serialize
  concurrent cli requests to the same glusterd.

- improve glusterd's internal cluster-wide locking mechanism when multiple clients request operations via multiple glusterds.
Comment 1 Harshavardhana 2011-08-15 12:06:48 EDT
*** Bug 2193 has been marked as a duplicate of this bug. ***
Comment 2 Anand Avati 2011-09-04 23:58:49 EDT
CHANGE: http://review.gluster.com/123 (This change contains,) merged in master by Vijay Bellur (vijay@gluster.com)
Comment 3 Raghavendra Bhat 2011-09-23 02:59:08 EDT
Its fixed now. Checked with glusterfs-3.3.0qa10. Now parallel cli operations will make only one of them succeed, and glusterd wont crash.

Note You need to log in before you can comment on or make changes to this bug.