Bug 762935 - (GLUSTER-1203) glusterfs returns 0 even if it fails
glusterfs returns 0 even if it fails
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: core (Show other bugs)
3.1-alpha
All Linux
urgent Severity high
: ---
: ---
Assigned To: krishnan parthasarathi
Raghavendra Bhat
:
: GLUSTER-1284 GLUSTER-2016 764027 GLUSTER-2955 GLUSTER-3085 837817 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-22 08:05 EDT by Raghavendra Bhat
Modified: 2015-11-03 18:03 EST (History)
11 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:53:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raghavendra Bhat 2010-07-22 08:05:42 EDT
Suppose a server process of glusterfs is started and using the same volfile if another server is executed it should fail returning a non zero value. But it is returning a zero. Thus applications which use glusterfs such as glusterd, cli may cause some errors due to this behavior.
Comment 1 Pavan Vilas Sondur 2010-08-04 09:55:23 EDT
*** Bug 1284 has been marked as a duplicate of this bug. ***
Comment 2 Vijay Bellur 2010-10-28 10:32:30 EDT
*** Bug 2016 has been marked as a duplicate of this bug. ***
Comment 3 Amar Tumballi 2011-04-25 05:33:15 EDT
Please update the status of this bug as its been more than 6months since its filed (bug id < 2000)

Please resolve it with proper resolution if its not valid anymore. If its still valid and not critical, move it to 'enhancement' severity.
Comment 4 Amar Tumballi 2011-07-04 21:29:24 EDT
*** Bug 2295 has been marked as a duplicate of this bug. ***
Comment 5 Amar Tumballi 2011-07-04 21:39:05 EDT
*** Bug 3085 has been marked as a duplicate of this bug. ***
Comment 6 Amar Tumballi 2011-07-15 01:38:29 EDT
*** Bug 2955 has been marked as a duplicate of this bug. ***
Comment 7 Amar Tumballi 2011-09-27 01:49:57 EDT
Planing to keep 3.4.x branch as "internal enhancements" release without any features. So moving these bugs to 3.4.0 target milestone.
Comment 8 Anand Avati 2012-01-26 08:23:38 EST
CHANGE: http://review.gluster.com/2694 (protocol/client: Pass the right arguments to CLIENT_GET_REMOTE_FD) merged in master by Anand Avati (avati@gluster.com)
Comment 9 Anand Avati 2012-03-21 14:58:19 EDT
CHANGE: http://review.gluster.com/479 (glusterd: bring in feature to use syncop for mgmt ops) merged in master by Anand Avati (avati@redhat.com)
Comment 10 Anand Avati 2012-03-21 14:58:37 EDT
CHANGE: http://review.gluster.com/579 (core: enable process to return the appropriate error code) merged in master by Anand Avati (avati@redhat.com)
Comment 11 Amar Tumballi 2012-07-11 02:05:03 EDT
*** Bug 837817 has been marked as a duplicate of this bug. ***
Comment 12 Vijay Bellur 2012-08-20 23:41:25 EDT
CHANGE: http://review.gluster.org/3832 (rpcsvc: remove .vector_actor and related changes) merged in master by Vijay Bellur (vbellur@redhat.com)
Comment 13 Sachidananda Urs 2012-12-19 02:49:04 EST
Firstly with the current usage this scenario does not arise. Since we no longer write glusterfs volume files by hand. And no longer start the gluster process by hand, but instead use the cli.

To test this, create a volume, and use the generated volume file to start glusterfsd by hand using the command line:

glusterfsd -f <vol-filename>

This will start the glusterfsd process. Now try to start glusterfsd process again, by using the same command and the same volume file. glusterfsd should fail with non-zero return status.

Note You need to log in before you can comment on or make changes to this bug.