Bug 76610 - xinetd 2.3.9-0.72 leaves sockets hanging in CLOSE_WAIT status
xinetd 2.3.9-0.72 leaves sockets hanging in CLOSE_WAIT status
Status: CLOSED DUPLICATE of bug 76146
Product: Red Hat Linux
Classification: Retired
Component: xinetd (Show other bugs)
7.2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-23 23:16 EDT by Elson, Del
Modified: 2007-04-18 12:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-24 23:06:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elson, Del 2002-10-23 23:16:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
xinetd 2.3.9-0.72 leaves sockets hanging in a CLOSE_WAIT status when connections
are opened and then closed to an internal service (such as time or daytime).


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.enable the "daytime" service (eg: using ntsysv)
2.telnet localhost daytime
3.The date and time will be displayed, but the socket is never closed.
4.Close the socket manually using ^] quit
5.netstat -a | grep CLOSE_WAIT

	

Actual Results:  The hanging socket will be displayed.

The machine eventually fails to open any further connections, and the "too many
open files" error is displayed in the log.


Expected Results:  The socket should have been closed by the xinetd server.


Additional info:

This happened to an older version of inetd but was fixed, it has now recurred in
the latest release of xinetd.

For example, see bugs # 14876, 11548, 12779, 13636, 16729, 21740, 44722, etc.
Comment 1 R P Herrold 2002-10-24 23:05:56 EDT
I am receiving this with the tftp service under high load (40 simultaneous
connections at the start of the day when PXE booting is starting up), and this
version -- I had to revert to the prior version to re-establish service
Comment 2 Milan Kerslager 2002-10-25 03:47:43 EDT
I see the same problem on RH 7.3: xinetd-2.3.9-0.73
Marked as duplicate of #76146 which have kernel-patch included too.

*** This bug has been marked as a duplicate of 76146 ***

Note You need to log in before you can comment on or make changes to this bug.