Bug 77682 - Blaster/Critical xscreensaver hacks lock system
Summary: Blaster/Critical xscreensaver hacks lock system
Status: CLOSED DUPLICATE of bug 64419
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xscreensaver (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-11 22:54 UTC by Peter Fales
Modified: 2014-03-17 02:32 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-11 22:54:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Peter Fales 2002-11-11 22:54:40 UTC
Description of Problem:

On the IBM Thinkpad T23 (uses the S3 Savage), running the xscreensaver hacks
"Blaster" and "Critical" cause hard lockups.  (No response to mouse/keyboard,
and network connections are also dead.  This is not a problem on other systems.

How Reproducible:

Very

Steps to Reproduce:
1. On an IBM Thinkpad T23, run xscreensaver-dem
2. Select Blaster, and click "Demo"
3. Be prepared to reboot the system

Actual Results:

System locks up

Expected Results:

No lockup 

Additional Information:  XF86Config-4 is pretty generic - built with
Xconfigurator.

Comment 1 Bill Nottingham 2002-11-12 00:14:08 UTC

*** This bug has been marked as a duplicate of 64419 ***

Comment 2 Peter Fales 2002-11-12 14:44:52 UTC
Tracing the dependency tree back to bug 64166 and bug 63916 implies that the
bug is closed because it's fixed in XFree86 4.05.  However, we're still seeing
the problem in RedHat 7.3 which used XFree86 4.2.  Did the XFree86 fix or
the the blaster fix get lost somewhere along the way.

Comment 3 Bill Nottingham 2002-11-12 16:28:44 UTC
It's fixed in *xscreensaver-4.05*, although the underlying issue is an XFree86
driver bug in the savage driver.


Note You need to log in before you can comment on or make changes to this bug.