Bug 77708 - TB EthernetHardwareDruid:118:setup
TB EthernetHardwareDruid:118:setup
Status: CLOSED DUPLICATE of bug 76446
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
7.3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Harald Hoyer
:
: 77990 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-12 11:19 EST by Kin Yip
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-12 11:19:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kin Yip 2002-11-12 11:19:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
Every time I start the "network configuration" (ie. 
redhat-config-network), it'd crash and tell me the following :

Please visit http://bugzilla.redhat.com/bugzilla/ !
File a bug against component redhat-config-network. Thank you!

Traceback (innermost last):
  File "/usr/sbin/neat", line 1402, in ?
    gtk.mainloop()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/neat", line 473, in on_deviceAddButton_clicked
    interface = NewInterfaceDialog()
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/NewInterfaceDialog.py",
line 82, in __init__
    iface = iface_creator (self.toplevel, do_save = None, druid = self.druid)
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/EthernetInterface.py",
line 101, in __init__
    self.hwDruid = ethernetHardware(self.toplevel)
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/EthernetHardwareDruid.py",
line 64, in __init__
    self.setup()
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/EthernetHardwareDruid.py",
line 118, in setup
    list.append(modInfo[i]['description'])
KeyError: description


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1./usr/bin/redhat-config-network
2.Hit the "Add" button
3.You will see the above error messages I quote.

Or, in KDE, you could 
(1) go to "System"
(2) click "Network Configuration" 
(3) hit "Add" and you'll get the error message.
	

Actual Results:  The "Network Configuration" showed me the above errors and all
I can do is try to save the "error message" and hit "OK" and the
"Network Configuration" icon would disappear.

Expected Results:  I should be able to add a network component and continue with 
"Network Configuration".

Additional info:

I have updated all the rpms using "up2date".
Comment 1 Harald Hoyer 2002-11-13 06:16:23 EST
third beta of erratum for 7.3/7.2/AS2 is available at:
ftp://people.redhat.com/harald/redhat-config-network/1.0.3-1/

Most of the bugs reported have been removed, but as in every software change,
there could be new bugs introduced.

Please report bugs against this with explicitly stating the 1.0.3 version... Thx
and please test.

*** This bug has been marked as a duplicate of 76446 ***
Comment 2 Roger Warnock 2002-11-26 03:07:41 EST
*** Bug 77990 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.